summaryrefslogtreecommitdiffstats
path: root/recipes-core
diff options
context:
space:
mode:
authorNathan Rossi <nathan@nathanrossi.com>2017-05-30 21:01:59 +1000
committerNathan Rossi <nathan@nathanrossi.com>2017-06-03 16:55:31 +1000
commit0071b9673743ee93ede97ce132bd898b0da13a0a (patch)
tree0cf3442d7022610447566a2253d8ec23ddafffd3 /recipes-core
parentd391df08fd5bda57454a7f88d2ba2a78bd22a81e (diff)
downloadmeta-xilinx-0071b9673743ee93ede97ce132bd898b0da13a0a.tar.gz
libgloss_2.5.0: Add libgloss recipe
Add a recipe for libgloss 2.5.0. This library is used to provide startup code, and IO for baremetal targets. This is used by newlib to provide a functional libc. This library is used by the Xilinx standalone libraries/applications. Signed-off-by: Nathan Rossi <nathan@nathanrossi.com> Tested-by: Alistair Francis <alistair.francis@xilinx.com> Tested-by: Koteswararao Nayudu <kotin@xilinx.com>
Diffstat (limited to 'recipes-core')
-rw-r--r--recipes-core/newlib/libgloss_2.5.0.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes-core/newlib/libgloss_2.5.0.bb b/recipes-core/newlib/libgloss_2.5.0.bb
new file mode 100644
index 00000000..6fbafc1d
--- /dev/null
+++ b/recipes-core/newlib/libgloss_2.5.0.bb
@@ -0,0 +1,18 @@
1
2require newlib.inc
3
4DEPENDS += "newlib"
5
6do_configure() {
7 ${S}/libgloss/configure ${CONFIGUREOPTS}
8}
9
10do_install_prepend() {
11 # install doesn't create this itself
12 install -d ${D}${prefix}/${TARGET_SYS}/lib
13}
14
15FILES_${PN} += "${libdir}/*.ld ${libdir}/*.specs"
16
17INHIBIT_PACKAGE_STRIP = "1"
18INHIBIT_PACKAGE_DEBUG_SPLIT = "1"