summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorNathan Rossi <nathan@nathanrossi.com>2016-01-06 16:46:46 +1000
committerNathan Rossi <nathan@nathanrossi.com>2016-01-06 16:46:46 +1000
commitae3a05b5be811d4a7d7a9651a4b28b5bff5df2cb (patch)
tree6a9d9376608e6dc0c2ac0856cac4950e9b7bc6d2 /recipes-bsp
parent02babaeb6b599d031925249e0521816bf06d7dbd (diff)
downloadmeta-xilinx-ae3a05b5be811d4a7d7a9651a4b28b5bff5df2cb.tar.gz
u-boot-xlnx_2015.04: Drop this version
Newer version of u-boot-xlnx superseeds this version. Also remove any patches which are only needed by this version of u-boot-xlnx. Signed-off-by: Nathan Rossi <nathan@nathanrossi.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/u-boot/u-boot-xlnx/ARM-zynq-Fix-up-the-target-file-name-for-u-boot.patch27
-rw-r--r--recipes-bsp/u-boot/u-boot-xlnx/microblaze-Fix-EMAC-Lite-initialization.patch31
-rw-r--r--recipes-bsp/u-boot/u-boot-xlnx/microblaze-generic_defconfig-Disable-configs.patch42
-rw-r--r--recipes-bsp/u-boot/u-boot-xlnx/zynq-Add-Zynq-PicoZed-board-support.patch143
-rw-r--r--recipes-bsp/u-boot/u-boot-xlnx_2015.04.bb30
5 files changed, 0 insertions, 273 deletions
diff --git a/recipes-bsp/u-boot/u-boot-xlnx/ARM-zynq-Fix-up-the-target-file-name-for-u-boot.patch b/recipes-bsp/u-boot/u-boot-xlnx/ARM-zynq-Fix-up-the-target-file-name-for-u-boot.patch
deleted file mode 100644
index 2ab6fdd3..00000000
--- a/recipes-bsp/u-boot/u-boot-xlnx/ARM-zynq-Fix-up-the-target-file-name-for-u-boot.patch
+++ /dev/null
@@ -1,27 +0,0 @@
1From: Nathan Rossi <nathan@nathanrossi.com>
2Subject: [PATCH] ARM: zynq: Fix up the target file name for u-boot
3
4This should be 'u-boot.img' because all zynq configs are OF_EMBED.
5
6Signed-off-by: Nathan Rossi <nathan@nathanrossi.com>
7Upstream-Status: Configuration [mirror upstream...]
8---
9 include/configs/zynq-common.h | 2 +-
10 1 file changed, 1 insertion(+), 1 deletion(-)
11
12diff --git a/include/configs/zynq-common.h b/include/configs/zynq-common.h
13index e5f2fc5..10c9f18 100644
14--- a/include/configs/zynq-common.h
15+++ b/include/configs/zynq-common.h
16@@ -501,7 +501,7 @@
17 #define CONFIG_SYS_MMCSD_FS_BOOT_PARTITION 1
18 #define CONFIG_SPL_LIBDISK_SUPPORT
19 #define CONFIG_SPL_FAT_SUPPORT
20-#define CONFIG_SPL_FS_LOAD_PAYLOAD_NAME "u-boot-dtb.img"
21+#define CONFIG_SPL_FS_LOAD_PAYLOAD_NAME "u-boot.img"
22 #endif
23
24 /* Disable dcache for SPL just for sure */
25--
262.6.2
27
diff --git a/recipes-bsp/u-boot/u-boot-xlnx/microblaze-Fix-EMAC-Lite-initialization.patch b/recipes-bsp/u-boot/u-boot-xlnx/microblaze-Fix-EMAC-Lite-initialization.patch
deleted file mode 100644
index 09c48fbc..00000000
--- a/recipes-bsp/u-boot/u-boot-xlnx/microblaze-Fix-EMAC-Lite-initialization.patch
+++ /dev/null
@@ -1,31 +0,0 @@
1From 83f0e6e733aba458b9afac67f3c95c4e29712263 Mon Sep 17 00:00:00 2001
2From: Nathan Rossi <nathan.rossi@xilinx.com>
3Date: Tue, 14 Apr 2015 15:35:57 +1000
4Subject: [PATCH] microblaze: Fix EMAC Lite initialization
5
6It is possible for CONFIG_XILINX_EMACLITE to be defined without
7XILINX_EMACLITE_BASEADDR being defined as the EMAC Lite driver support
8OF init. Check that the driver is enabled and the base address is
9available before initializing with a static base address.
10
11Signed-off-by: Nathan Rossi <nathan.rossi@xilinx.com>
12---
13 board/xilinx/microblaze-generic/microblaze-generic.c | 2 +-
14 1 file changed, 1 insertion(+), 1 deletion(-)
15
16diff --git a/board/xilinx/microblaze-generic/microblaze-generic.c b/board/xilinx/microblaze-generic/microblaze-generic.c
17index eee5f6b..8c926a2 100644
18--- a/board/xilinx/microblaze-generic/microblaze-generic.c
19+++ b/board/xilinx/microblaze-generic/microblaze-generic.c
20@@ -63,7 +63,7 @@ int board_eth_init(bd_t *bis)
21 XILINX_AXIDMA_BASEADDR);
22 #endif
23
24-#ifdef CONFIG_XILINX_EMACLITE
25+#if defined(CONFIG_XILINX_EMACLITE) && defined(XILINX_EMACLITE_BASEADDR)
26 u32 txpp = 0;
27 u32 rxpp = 0;
28 # ifdef CONFIG_XILINX_EMACLITE_TX_PING_PONG
29--
301.7.10.4
31
diff --git a/recipes-bsp/u-boot/u-boot-xlnx/microblaze-generic_defconfig-Disable-configs.patch b/recipes-bsp/u-boot/u-boot-xlnx/microblaze-generic_defconfig-Disable-configs.patch
deleted file mode 100644
index 316d89af..00000000
--- a/recipes-bsp/u-boot/u-boot-xlnx/microblaze-generic_defconfig-Disable-configs.patch
+++ /dev/null
@@ -1,42 +0,0 @@
1From: Nathan Rossi <nathan.rossi@xilinx.com>
2Date: Mon, 20 Apr 2015 17:57:34 +1000
3Subject: [PATCH] microblaze-generic_defconfig: Disable configs
4
5Signed-off-by: Nathan Rossi <nathan.rossi@xilinx.com>
6Upstream-Status: Configuration
7---
8 configs/microblaze-generic_defconfig | 4 +---
9 include/configs/microblaze-generic.h | 5 +++++
10 2 files changed, 6 insertions(+), 3 deletions(-)
11
12diff --git a/configs/microblaze-generic_defconfig b/configs/microblaze-generic_defconfig
13index 4211d71..69b8023 100644
14--- a/configs/microblaze-generic_defconfig
15+++ b/configs/microblaze-generic_defconfig
16@@ -1,6 +1,4 @@
17-CONFIG_SPL=y
18 CONFIG_MICROBLAZE=y
19 CONFIG_TARGET_MICROBLAZE_GENERIC=y
20-CONFIG_OF_CONTROL=y
21-CONFIG_OF_EMBED=y
22 CONFIG_DEFAULT_DEVICE_TREE="microblaze-generic"
23+CONFIG_SYS_BOOTM_LEN=33554432
24diff --git a/include/configs/microblaze-generic.h b/include/configs/microblaze-generic.h
25index 073f3ef..26e85c7 100644
26--- a/include/configs/microblaze-generic.h
27+++ b/include/configs/microblaze-generic.h
28@@ -219,6 +219,11 @@
29 #endif
30
31 /*
32+ * BOOTM options
33+ */
34+#define CONFIG_SYS_BOOTM_LEN (32 * 1024 * 1024)
35+
36+/*
37 * BOOTP options
38 */
39 #define CONFIG_BOOTP_BOOTFILESIZE
40--
412.5.1
42
diff --git a/recipes-bsp/u-boot/u-boot-xlnx/zynq-Add-Zynq-PicoZed-board-support.patch b/recipes-bsp/u-boot/u-boot-xlnx/zynq-Add-Zynq-PicoZed-board-support.patch
deleted file mode 100644
index 73220774..00000000
--- a/recipes-bsp/u-boot/u-boot-xlnx/zynq-Add-Zynq-PicoZed-board-support.patch
+++ /dev/null
@@ -1,143 +0,0 @@
1From 8d00cfe0fb3132a5d2035f5945e81c212121326e Mon Sep 17 00:00:00 2001
2From: Nathan Rossi <nathan.rossi@xilinx.com>
3Date: Tue, 14 Apr 2015 14:58:10 +1000
4Subject: [PATCH] zynq: Add Zynq PicoZed board support
5
6The PicoZed is a System-on-Module board which is marketed as part of
7the ZedBoard/MicroZed/etc. collection. It includes a Zynq-7000
8processor.
9
10This patch adds support that covers all the variants of the PicoZed
11including the SKUs with Z7010/Z7020 and Z7015/Z7030 Zynq chips. This
12patch set however only covers support for the System-on-Module and does
13not cover any extra components that are available on carrier boards
14(except those that are fanned out of the module itself).
15
16More information on this board, its variants and available carrier
17boards is available at: http://zedboard.org/product/picozed
18
19Signed-off-by: Nathan Rossi <nathan.rossi@xilinx.com>
20Signed-off-by: Michal Simek <michal.simek@xilinx.com>
21Upstream-Status: Backport
22---
23 arch/arm/cpu/armv7/zynq/Kconfig | 4 ++++
24 arch/arm/dts/Makefile | 1 +
25 arch/arm/dts/zynq-picozed.dts | 23 +++++++++++++++++++++++
26 configs/zynq_picozed_defconfig | 6 ++++++
27 include/configs/zynq_picozed.h | 27 +++++++++++++++++++++++++++
28 5 files changed, 61 insertions(+)
29 create mode 100644 arch/arm/dts/zynq-picozed.dts
30 create mode 100644 configs/zynq_picozed_defconfig
31 create mode 100644 include/configs/zynq_picozed.h
32
33diff --git a/arch/arm/cpu/armv7/zynq/Kconfig b/arch/arm/cpu/armv7/zynq/Kconfig
34index 2482bbb..d0874ab 100644
35--- a/arch/arm/cpu/armv7/zynq/Kconfig
36+++ b/arch/arm/cpu/armv7/zynq/Kconfig
37@@ -9,6 +9,9 @@ config TARGET_ZYNQ_ZED
38 config TARGET_ZYNQ_MICROZED
39 bool "Zynq MicroZed"
40
41+config TARGET_ZYNQ_PICOZED
42+ bool "Zynq PicoZed"
43+
44 config TARGET_ZYNQ_ZC70X
45 bool "Zynq ZC702/ZC706 Board"
46
47@@ -38,6 +41,7 @@ config SYS_SOC
48 config SYS_CONFIG_NAME
49 default "zynq_zed" if TARGET_ZYNQ_ZED
50 default "zynq_microzed" if TARGET_ZYNQ_MICROZED
51+ default "zynq_picozed" if TARGET_ZYNQ_PICOZED
52 default "zynq_zc70x" if TARGET_ZYNQ_ZC70X
53 default "zynq_zc770" if TARGET_ZYNQ_ZC770
54 default "zynq_zybo" if TARGET_ZYNQ_ZYBO
55diff --git a/arch/arm/dts/Makefile b/arch/arm/dts/Makefile
56index e08546b..84b0bed 100644
57--- a/arch/arm/dts/Makefile
58+++ b/arch/arm/dts/Makefile
59@@ -44,6 +44,7 @@ dtb-$(CONFIG_ZYNQ) += zynq-zc702.dtb \
60 zynq-zed.dtb \
61 zynq-zybo.dtb \
62 zynq-microzed.dtb \
63+ zynq-picozed.dtb \
64 zynq-cc108.dtb \
65 zynq-zc770-xm010.dtb \
66 zynq-zc770-xm011.dtb \
67diff --git a/arch/arm/dts/zynq-picozed.dts b/arch/arm/dts/zynq-picozed.dts
68new file mode 100644
69index 0000000..686b98f
70--- /dev/null
71+++ b/arch/arm/dts/zynq-picozed.dts
72@@ -0,0 +1,23 @@
73+/*
74+ * Avnet PicoZed board DTS
75+ *
76+ * Copyright (C) 2015 Xilinx, Inc.
77+ *
78+ * SPDX-License-Identifier: GPL-2.0+
79+ */
80+/dts-v1/;
81+#include "zynq-7000.dtsi"
82+
83+/ {
84+ model = "Zynq PicoZed Board";
85+ compatible = "xlnx,zynq-picozed", "xlnx,zynq-7000";
86+
87+ aliases {
88+ serial0 = &uart1;
89+ };
90+
91+ memory {
92+ device_type = "memory";
93+ reg = <0 0x40000000>;
94+ };
95+};
96diff --git a/configs/zynq_picozed_defconfig b/configs/zynq_picozed_defconfig
97new file mode 100644
98index 0000000..b782873
99--- /dev/null
100+++ b/configs/zynq_picozed_defconfig
101@@ -0,0 +1,6 @@
102+CONFIG_SPL=y
103+CONFIG_ARM=y
104+CONFIG_ZYNQ=y
105+CONFIG_TARGET_ZYNQ_PICOZED=y
106+CONFIG_OF_CONTROL=n
107+CONFIG_DEFAULT_DEVICE_TREE="zynq-picozed"
108diff --git a/include/configs/zynq_picozed.h b/include/configs/zynq_picozed.h
109new file mode 100644
110index 0000000..d116e05
111--- /dev/null
112+++ b/include/configs/zynq_picozed.h
113@@ -0,0 +1,27 @@
114+/*
115+ * (C) Copyright 2015 Xilinx, Inc.
116+ *
117+ * Configuration for PicoZed
118+ * See zynq-common.h for Zynq common configs
119+ *
120+ * SPDX-License-Identifier: GPL-2.0+
121+ */
122+
123+#ifndef __CONFIG_ZYNQ_PICOZED_H
124+#define __CONFIG_ZYNQ_PICOZED_H
125+
126+#define CONFIG_SYS_SDRAM_SIZE (1024 * 1024 * 1024)
127+
128+#define CONFIG_ZYNQ_SERIAL_UART1
129+#define CONFIG_ZYNQ_GEM0
130+#define CONFIG_ZYNQ_GEM_PHY_ADDR0 0
131+
132+#define CONFIG_SYS_NO_FLASH
133+
134+#define CONFIG_ZYNQ_SDHCI1
135+#define CONFIG_ZYNQ_USB
136+#define CONFIG_ZYNQ_BOOT_FREEBSD
137+
138+#include <configs/zynq-common.h>
139+
140+#endif /* __CONFIG_ZYNQ_PICOZED_H */
141--
1422.5.1
143
diff --git a/recipes-bsp/u-boot/u-boot-xlnx_2015.04.bb b/recipes-bsp/u-boot/u-boot-xlnx_2015.04.bb
deleted file mode 100644
index 0bcbffd8..00000000
--- a/recipes-bsp/u-boot/u-boot-xlnx_2015.04.bb
+++ /dev/null
@@ -1,30 +0,0 @@
1include u-boot-xlnx.inc
2include u-boot-extra.inc
3include u-boot-spl-zynq-init.inc
4
5# this matches u-boot-xlnx 'xilinx-v2015.2' release tag
6SRCREV = "1160fbcc619f23bf87cde01ed651566474e17eb9"
7PV = "v2015.04${XILINX_EXTENSION}+git${SRCPV}"
8
9FILESEXTRAPATHS_prepend := "${THISDIR}/u-boot-xlnx:"
10SRC_URI += " \
11 file://ARM-zynq-Fix-up-the-target-file-name-for-u-boot.patch \
12 file://zynq-Add-Zynq-PicoZed-board-support.patch \
13 file://microblaze-Fix-EMAC-Lite-initialization.patch \
14 file://microblaze-generic_defconfig-Disable-configs.patch \
15 file://0001-microblaze-Fix-style-issues-in-header-files.patch \
16 file://0002-microblaze-Fix-C99-gnu99-compatiblity-for-inline-fun.patch \
17 "
18
19LIC_FILES_CHKSUM = "file://README;beginline=1;endline=6;md5=157ab8408beab40cd8ce1dc69f702a6c"
20
21UBOOT_ENV_zc702-zynq7 = "uEnv"
22UBOOT_ENV_zedboard-zynq7 = "uEnv"
23
24SRC_URI_append_zc702-zynq7 = " file://uEnv.txt"
25SRC_URI_append_zedboard-zynq7 = " file://uEnv.txt"
26
27# 2015.04 - does not split the zc702 and zc706 into two configs
28UBOOT_MACHINE_zc702-zynq7 = "zynq_zc70x_config"
29UBOOT_MACHINE_zc706-zynq7 = "zynq_zc70x_config"
30