diff options
author | Nathan Rossi <nathan@nathanrossi.com> | 2016-01-06 16:49:34 +1000 |
---|---|---|
committer | Nathan Rossi <nathan@nathanrossi.com> | 2016-01-06 16:49:34 +1000 |
commit | b5e4b37bff4749b22af6b8c94b5af7a654bb2b35 (patch) | |
tree | 0ff14e8031f3a29c89d19b1592d120126081e0c4 /recipes-bsp/u-boot | |
parent | ae3a05b5be811d4a7d7a9651a4b28b5bff5df2cb (diff) | |
download | meta-xilinx-b5e4b37bff4749b22af6b8c94b5af7a654bb2b35.tar.gz |
u-boot-extra.inc: Retire use of this configuration framework
This is only used by MicroBlaze targets for U-Boot, and due to U-Boot
moving to Device Model this is no longer sufficent to configure U-Boot.
Instead support for MicroBlaze must be added by patches to U-Boot with
partial DM and xparameters support.
Signed-off-by: Nathan Rossi <nathan@nathanrossi.com>
Diffstat (limited to 'recipes-bsp/u-boot')
-rw-r--r-- | recipes-bsp/u-boot/u-boot-extra.inc | 52 | ||||
-rw-r--r-- | recipes-bsp/u-boot/u-boot-xlnx-dev.bb | 1 |
2 files changed, 0 insertions, 53 deletions
diff --git a/recipes-bsp/u-boot/u-boot-extra.inc b/recipes-bsp/u-boot/u-boot-extra.inc deleted file mode 100644 index ff824d85..00000000 --- a/recipes-bsp/u-boot/u-boot-extra.inc +++ /dev/null | |||
@@ -1,52 +0,0 @@ | |||
1 | |||
2 | inherit xilinx-utils | ||
3 | |||
4 | # Appends the '<layer>/conf/machine/boards' path to FILESEXTRAPATHS for all | ||
5 | # layers (using the ${BBPATH}) | ||
6 | FILESEXTRAPATHS_append := "${@get_additional_bbpath_filespath('conf/machine/boards', d)}" | ||
7 | |||
8 | # Append the xparameters file to the SRC_URI if set | ||
9 | SRC_URI_append = " ${@paths_affix(d.getVar("MACHINE_XPARAMETERS", True) or '', prefix = 'file://')}" | ||
10 | |||
11 | # Full path to the xparameters.h file | ||
12 | UBOOT_XPARAMETERS ?= "${@expand_workdir_paths("MACHINE_XPARAMETERS", d)}" | ||
13 | |||
14 | # Install the MicroBlaze System configuration into the board configuration, | ||
15 | # and generate a u-boot specific config.mk | ||
16 | python do_configmk_generate () { | ||
17 | import re, sys, os, shutil | ||
18 | |||
19 | machine_xparameters = d.getVar("UBOOT_XPARAMETERS", True) | ||
20 | |||
21 | if machine_xparameters and os.path.exists(machine_xparameters): | ||
22 | boardpath = os.path.join("board", "xilinx", "microblaze-generic") | ||
23 | configmk = os.path.join(d.getVar("S", True), boardpath, "config.mk") | ||
24 | xparameters = os.path.join(d.getVar("S", True), boardpath, "xparameters.h") | ||
25 | |||
26 | shutil.copyfile(machine_xparameters, xparameters) | ||
27 | |||
28 | # Search the xparameters.h file for the RAM base addr and size. | ||
29 | ram = None | ||
30 | with open(machine_xparameters, "r") as f: | ||
31 | filedata = f.read() | ||
32 | ramstart = re.search("XILINX_RAM_START.*?(0x.*)", filedata) | ||
33 | ramsize = re.search("XILINX_RAM_SIZE.*?(0x.*)", filedata) | ||
34 | if ramstart and ramsize: | ||
35 | ram = (int(ramstart.group(1), 16), int(ramsize.group(1), 16)) | ||
36 | |||
37 | # build up the config.mk file from known info | ||
38 | with open(configmk, "wb") as f: | ||
39 | f.write("# This file is generated by the meta-xilinx layers.\n") | ||
40 | f.write("\n") | ||
41 | |||
42 | for i in d.getVar("TUNE_CCARGS", True).split(): | ||
43 | f.write("PLATFORM_CCPFLAGS += %s\n" % i) | ||
44 | f.write("\n") | ||
45 | |||
46 | if ram != None: | ||
47 | base_offset = ram[0] + ram[1] - 0x400000 | ||
48 | f.write("TEXT_BASE = 0x%x\n" % base_offset) | ||
49 | f.write("CONFIG_SYS_TEXT_BASE = 0x%x\n" % base_offset) | ||
50 | } | ||
51 | addtask configmk_generate before do_configure after do_unpack | ||
52 | |||
diff --git a/recipes-bsp/u-boot/u-boot-xlnx-dev.bb b/recipes-bsp/u-boot/u-boot-xlnx-dev.bb index 9fa22fed..50bbf543 100644 --- a/recipes-bsp/u-boot/u-boot-xlnx-dev.bb +++ b/recipes-bsp/u-boot/u-boot-xlnx-dev.bb | |||
@@ -7,7 +7,6 @@ | |||
7 | UBRANCH ?= "master" | 7 | UBRANCH ?= "master" |
8 | 8 | ||
9 | include u-boot-xlnx.inc | 9 | include u-boot-xlnx.inc |
10 | include u-boot-extra.inc | ||
11 | include u-boot-spl-zynq-init.inc | 10 | include u-boot-spl-zynq-init.inc |
12 | 11 | ||
13 | LIC_FILES_CHKSUM = "file://README;beginline=1;endline=6;md5=157ab8408beab40cd8ce1dc69f702a6c" | 12 | LIC_FILES_CHKSUM = "file://README;beginline=1;endline=6;md5=157ab8408beab40cd8ce1dc69f702a6c" |