summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot
diff options
context:
space:
mode:
authorNathan Rossi <nathan@nathanrossi.com>2017-11-14 23:15:23 +1000
committerManjukumar Matha <manjukumar.harthikote-matha@xilinx.com>2017-11-21 11:19:00 -0800
commit9814008b5ff354142e644609b6b4356c4161c521 (patch)
treec3fb20effbb06b72257e876ea9f4212fc81b9cd2 /recipes-bsp/u-boot
parent06d3a9509ed38ae39ee4bfaa698e625011576318 (diff)
downloadmeta-xilinx-9814008b5ff354142e644609b6b4356c4161c521.tar.gz
Update recipes for Xilinx v2017.3 release
Update the arm-trusted-firmware, pmu-firmware, u-boot-xlnx, linux-xlnx, qemu-xilinx and qemu-devicetrees recipes for to the 'xilinx-v2017.3' release tags. Drop/update existing patches where applicable. Signed-off-by: Nathan Rossi <nathan@nathanrossi.com> Reviewed-by: Alistair Francis <alistair.francis@xilinx.com> Signed-off-by: Manjukumar Matha <manjukumar.harthikote-matha@xilinx.com>
Diffstat (limited to 'recipes-bsp/u-boot')
-rw-r--r--recipes-bsp/u-boot/u-boot-xlnx/v2017.1/arm-zynqmp-xilinx_zynqmp.h-Auto-boot-in-JTAG-if-imag.patch39
-rw-r--r--recipes-bsp/u-boot/u-boot-xlnx_2017.3.bb (renamed from recipes-bsp/u-boot/u-boot-xlnx_2017.1.bb)12
2 files changed, 4 insertions, 47 deletions
diff --git a/recipes-bsp/u-boot/u-boot-xlnx/v2017.1/arm-zynqmp-xilinx_zynqmp.h-Auto-boot-in-JTAG-if-imag.patch b/recipes-bsp/u-boot/u-boot-xlnx/v2017.1/arm-zynqmp-xilinx_zynqmp.h-Auto-boot-in-JTAG-if-imag.patch
deleted file mode 100644
index de7954a8..00000000
--- a/recipes-bsp/u-boot/u-boot-xlnx/v2017.1/arm-zynqmp-xilinx_zynqmp.h-Auto-boot-in-JTAG-if-imag.patch
+++ /dev/null
@@ -1,39 +0,0 @@
1From 05fc0a41a14dac435248aa4ea2afa44450f70d46 Mon Sep 17 00:00:00 2001
2From: Nathan Rossi <nathan@nathanrossi.com>
3Date: Fri, 4 Nov 2016 21:33:14 +1000
4Subject: [PATCH] arm: zynqmp: xilinx_zynqmp.h: Auto boot in JTAG if images in
5 memory
6
7Add a command that checks if the Kernel image (in aarch64 Image format)
8and optionally a rootfs is in memory and automatically boot these images
9if in JTAG boot mode.
10
11This allows for simpler boot automation in JTAG boot environments
12(including QEMU) where manual interaction would otherwise be required.
13
14Signed-off-by: Nathan Rossi <nathan@nathanrossi.com>
15Upstream-Status: Denied [Upstream prefers FIT instead]
16---
17 include/configs/xilinx_zynqmp.h | 6 ++++--
18 1 file changed, 4 insertions(+), 2 deletions(-)
19
20diff --git a/include/configs/xilinx_zynqmp.h b/include/configs/xilinx_zynqmp.h
21index 9371dbb585..cd4edcf2b5 100644
22--- a/include/configs/xilinx_zynqmp.h
23+++ b/include/configs/xilinx_zynqmp.h
24@@ -253,8 +253,10 @@
25 "run xen_prepare_dt_qemu && " \
26 "tftpb 6000000 xen.ub && tftpb 0x1000000 image.ub && " \
27 "bootm 6000000 0x1000000 $fdt_addr\0" \
28- "jtagboot=tftpboot 80000 Image && tftpboot $fdt_addr system.dtb && " \
29- "tftpboot 6000000 rootfs.cpio.ub && booti 80000 6000000 $fdt_addr\0" \
30+ "jtagmemboot=if itest.w *0x80038 == 0x644d5241; then if iminfo 0x6000000; then booti 0x80000 0x6000000 $fdt_addr; else booti 0x80000 - $fdt_addr; fi; fi\0" \
31+ "jtagboot=run jtagmemboot || " \
32+ "tftpboot 80000 Image && tftpboot $fdt_addr system.dtb && " \
33+ "tftpboot 6000000 rootfs.cpio.ub && booti 80000 6000000 $fdt_addr\0" \
34 "nosmp=setenv bootargs $bootargs maxcpus=1\0" \
35 "nfsroot=setenv bootargs $bootargs root=/dev/nfs nfsroot=$serverip:/mnt/sata,tcp ip=$ipaddr:$serverip:$serverip:255.255.255.0:zynqmp:eth0:off rw\0" \
36 "sdroot0=setenv bootargs $bootargs root=/dev/mmcblk0p2 rw rootwait\0" \
37--
382.11.0
39
diff --git a/recipes-bsp/u-boot/u-boot-xlnx_2017.1.bb b/recipes-bsp/u-boot/u-boot-xlnx_2017.3.bb
index d70dfefd..867f72e2 100644
--- a/recipes-bsp/u-boot/u-boot-xlnx_2017.1.bb
+++ b/recipes-bsp/u-boot/u-boot-xlnx_2017.3.bb
@@ -1,24 +1,20 @@
1include u-boot-xlnx.inc 1include u-boot-xlnx.inc
2include u-boot-spl-zynq-init.inc 2include u-boot-spl-zynq-init.inc
3 3
4XILINX_RELEASE_VERSION = "v2017.1" 4XILINX_RELEASE_VERSION = "v2017.3"
5SRCREV = "92e3dd638b50ad22dd90072673c80d8730903e95" 5SRCREV ?= "da811c4511ef9caeb95f9a22fe49d38bd8e56ded"
6PV = "v2017.01-xilinx-${XILINX_RELEASE_VERSION}+git${SRCPV}" 6PV = "v2017.01-xilinx-${XILINX_RELEASE_VERSION}+git${SRCPV}"
7 7
8SRC_URI_append = " \
9 file://arm-zynqmp-xilinx_zynqmp.h-Auto-boot-in-JTAG-if-imag.patch \
10 "
11
12LICENSE = "GPLv2+" 8LICENSE = "GPLv2+"
13LIC_FILES_CHKSUM = "file://README;beginline=1;endline=6;md5=157ab8408beab40cd8ce1dc69f702a6c" 9LIC_FILES_CHKSUM = "file://README;beginline=1;endline=6;md5=157ab8408beab40cd8ce1dc69f702a6c"
14 10
15# u-boot 2016.07 has support for these 11# u-boot-xlnx has support for these
16HAS_PLATFORM_INIT ?= " \ 12HAS_PLATFORM_INIT ?= " \
17 zynq_microzed_config \ 13 zynq_microzed_config \
18 zynq_zed_config \ 14 zynq_zed_config \
19 zynq_zc702_config \ 15 zynq_zc702_config \
20 zynq_zc706_config \ 16 zynq_zc706_config \
21 zynq_zybo_config \ 17 zynq_zybo_config \
22 xilinx_zynqmp_zcu102_config \ 18 xilinx_zynqmp_zcu102_rev1_0_config \
23 " 19 "
24 20