summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot/u-boot-xlnx_2015.04.bb
diff options
context:
space:
mode:
authorNathan Rossi <nathan@nathanrossi.com>2015-09-15 19:49:45 +1000
committerNathan Rossi <nathan@nathanrossi.com>2015-09-15 21:57:38 +1000
commit02a97e0f1082376fd7982fceeb140a93497eecf8 (patch)
tree24e10bf3b5eab25af406ce44b62ddc9bf044f3b3 /recipes-bsp/u-boot/u-boot-xlnx_2015.04.bb
parent117623e4042e6a2b3fa55e21ac75b3f82df74bc3 (diff)
downloadmeta-xilinx-02a97e0f1082376fd7982fceeb140a93497eecf8.tar.gz
u-boot-xlnx: Update to 2015.04 'xilinx-v2015.2'
* Update to the 'xilinx-v2015.2' release tag, this corresponds to 2015.04 version of u-boot * Update microblaze configuration patch for this version * Swap picozed patch for a upstream backported version Signed-off-by: Nathan Rossi <nathan@nathanrossi.com>
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-xlnx_2015.04.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-xlnx_2015.04.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-xlnx_2015.04.bb b/recipes-bsp/u-boot/u-boot-xlnx_2015.04.bb
new file mode 100644
index 00000000..fd28fbee
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-xlnx_2015.04.bb
@@ -0,0 +1,17 @@
1include u-boot-xlnx.inc
2include u-boot-xlnx-2015.04.inc
3include u-boot-extra.inc
4
5UBOOT_ENV_zc702-zynq7 = "uEnv"
6UBOOT_ENV_zedboard-zynq7 = "uEnv"
7
8SRC_URI_append_zc702-zynq7 += "file://uEnv.txt"
9SRC_URI_append_zedboard-zynq7 += "file://uEnv.txt"
10
11do_compile_append() {
12 # link u-boot-dtb.img to u-boot.img.
13 if [ ! -e ${B}/u-boot-dtb.img ]; then
14 ln -sf u-boot.img ${B}/u-boot-dtb.img
15 fi
16}
17