summaryrefslogtreecommitdiffstats
path: root/meta-xilinx-vendor/conf
diff options
context:
space:
mode:
authorSandeep Gundlupet Raju <sandeep.gundlupet-raju@xilinx.com>2022-05-05 18:50:43 -0600
committerMark Hatle <mark.hatle@kernel.crashing.org>2022-07-28 14:45:08 -0500
commit4cd0ab00c97616b7a608f82c294176c153d94c43 (patch)
treedc849842123855d62cd429b868abf1afcc9e06b4 /meta-xilinx-vendor/conf
parentf8c539d132287876539e4e12c5eff6b55717e26e (diff)
downloadmeta-xilinx-4cd0ab00c97616b7a608f82c294176c153d94c43.tar.gz
meta-xilinx: Clean up vendor specific machine configuration files
1. Add new metal-xilinx-vendor layer which supports vendor specific machine configuration files, device-tree, kernel, platform-init etc. 2. Moved below vendor machine conf files, dt and related configs from meta-xilinx-bsp and meta-xilinx-contrib to meta-xilinx-vendor layer. - microzed-zynq7.conf - minized-zynq7.conf - picozed-zynq7.conf - zedboard-zynq7.conf - zybo-zynq7.conf - zybo-linux-bd-zynq7.conf - ultra96-zynqmp.conf 3. Obsolete qemu-zynq7, s3adsp1800-qemu-microblazeeb, v350-versal and vc-p-a2197-00-versal from meta-xilinx-bsp layer. Users should use zynq-generic.conf for zynq7000 qemu boot should be functionally equivalent to qemu-zynq7. 4. Add new MAINTAINERS.md file and move maintainers, Mailing list and Patches content from meta-xilinx-* README.md to MAINTAINERS.md file. 5. Updated README.md file for supported board machines files in meta-xilinx-bsp, meta-xilinx-contrib and meta-xilinx-vendor layers. 6. Disabled old drm kernel patches for zybo-linux-bd-zynq mahcine in meta-xilinx-contrib layer as these patches doesn't apply on 5.x kernel, if we don't hear from patch submitter we will remove these patches from meta-xilinx-contrib layer. 7. Removed drm kernel cache metadate for zybo-linux-bd-zynq7 machine as these configs are already available in xilinx_zynq_defconfig. 8. Fixed build issue for u-boot by changing PREFERRED_PROVIDER_virtual/bootloader from u-boot to u-boot-xlnx. 9. Add meta-xilinx-vendor to bblayers.conf.sample Signed-off-by: Sandeep Gundlupet Raju <sandeep.gundlupet-raju@xilinx.com> Signed-off-by: Mark Hatle <mhatle@xilinx.com>
Diffstat (limited to 'meta-xilinx-vendor/conf')
-rw-r--r--meta-xilinx-vendor/conf/layer.conf13
-rw-r--r--meta-xilinx-vendor/conf/machine/include/board/ultra96.inc12
-rw-r--r--meta-xilinx-vendor/conf/machine/microzed-zynq7.conf23
-rw-r--r--meta-xilinx-vendor/conf/machine/minized-zynq7.conf24
-rw-r--r--meta-xilinx-vendor/conf/machine/picozed-zynq7.conf25
-rw-r--r--meta-xilinx-vendor/conf/machine/ultra96-zynqmp.conf23
-rw-r--r--meta-xilinx-vendor/conf/machine/zedboard-zynq7.conf24
-rw-r--r--meta-xilinx-vendor/conf/machine/zybo-linux-bd-zynq7.conf24
-rw-r--r--meta-xilinx-vendor/conf/machine/zybo-zynq7.conf27
9 files changed, 195 insertions, 0 deletions
diff --git a/meta-xilinx-vendor/conf/layer.conf b/meta-xilinx-vendor/conf/layer.conf
new file mode 100644
index 00000000..b3e81efc
--- /dev/null
+++ b/meta-xilinx-vendor/conf/layer.conf
@@ -0,0 +1,13 @@
1# We have a conf and classes directory, add to BBPATH
2BBPATH .= ":${LAYERDIR}"
3
4# We have a packages directory, add to BBFILES
5BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
6 ${LAYERDIR}/recipes-*/*/*.bbappend"
7
8BBFILE_COLLECTIONS += "xilinx-vendor"
9BBFILE_PATTERN_xilinx-vendor = "^${LAYERDIR}/"
10BBFILE_PRIORITY_xilinx-vendor = "5"
11
12LAYERDEPENDS_xilinx-vendor = "xilinx"
13LAYERSERIES_COMPAT_xilinx-vendor = "honister"
diff --git a/meta-xilinx-vendor/conf/machine/include/board/ultra96.inc b/meta-xilinx-vendor/conf/machine/include/board/ultra96.inc
new file mode 100644
index 00000000..bfb57e00
--- /dev/null
+++ b/meta-xilinx-vendor/conf/machine/include/board/ultra96.inc
@@ -0,0 +1,12 @@
1# Ultra96 items that need to be configured from zynqmp-generic
2KERNEL_DEVICETREE:ultra96 = "xilinx/zynqmp-zcu100-revC.dtb"
3
4# Affects meta-xilinx-tools xsctyaml.bbclass related items
5YAML_SERIAL_CONSOLE_STDIN:ultra96 ?= "psu_uart_1"
6YAML_SERIAL_CONSOLE_STDOUT:ultra96 ?= "psu_uart_1"
7
8YAML_COMPILER_FLAGS:append:ultra96 = " -DBOARD_SHUTDOWN_PIN=2 -DBOARD_SHUTDOWN_PIN_STATE=0 "
9
10# Enable bluetooth and wifi module
11MACHINE_ESSENTIAL_EXTRA_RDEPENDS:append:ultra96 = " linux-firmware-wl18xx linux-firmware-ti-bt-wl180x"
12
diff --git a/meta-xilinx-vendor/conf/machine/microzed-zynq7.conf b/meta-xilinx-vendor/conf/machine/microzed-zynq7.conf
new file mode 100644
index 00000000..ce8058e4
--- /dev/null
+++ b/meta-xilinx-vendor/conf/machine/microzed-zynq7.conf
@@ -0,0 +1,23 @@
1#@TYPE: Machine
2#@NAME: microzed-zynq7
3#@DESCRIPTION: Machine support for microZed. (http://www.microzed.org/)
4
5require conf/machine/zynq-generic.conf
6
7SPL_BINARY ?= "spl/boot.bin"
8UBOOT_ELF = "u-boot"
9
10EXTRA_IMAGEDEPENDS += " \
11 u-boot-zynq-uenv \
12 virtual/boot-bin \
13 virtual/bootloader \
14 u-boot-zynq-scr \
15 "
16
17KERNEL_DEVICETREE = "zynq-microzed.dtb"
18
19IMAGE_BOOT_FILES += " \
20 boot.bin \
21 uEnv.txt \
22 "
23
diff --git a/meta-xilinx-vendor/conf/machine/minized-zynq7.conf b/meta-xilinx-vendor/conf/machine/minized-zynq7.conf
new file mode 100644
index 00000000..af9d982d
--- /dev/null
+++ b/meta-xilinx-vendor/conf/machine/minized-zynq7.conf
@@ -0,0 +1,24 @@
1#@TYPE: Machine
2#@NAME: minized-zynq7
3#@DESCRIPTION: Machine support for MiniZed. (http://www.minized.org/)
4
5require conf/machine/zynq-generic.conf
6
7MACHINE_FEATURES = "ext2 vfat usbhost wifi bluetooth"
8
9UBOOT_MACHINE ?= "zynq_minized_config"
10
11EXTRA_IMAGEDEPENDS += " \
12 u-boot-zynq-uenv \
13 virtual/bootloader \
14 "
15
16SERIAL_CONSOLES ?= "115200;ttyPS0"
17
18MACHINE_ESSENTIAL_EXTRA_RDEPENDS += "device-tree"
19
20MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS += "linux-firmware-bcm43430"
21
22IMAGE_BOOT_FILES += " \
23 uEnv.txt \
24 "
diff --git a/meta-xilinx-vendor/conf/machine/picozed-zynq7.conf b/meta-xilinx-vendor/conf/machine/picozed-zynq7.conf
new file mode 100644
index 00000000..31f5e220
--- /dev/null
+++ b/meta-xilinx-vendor/conf/machine/picozed-zynq7.conf
@@ -0,0 +1,25 @@
1#@TYPE: Machine
2#@NAME: picozed-zynq7
3#@DESCRIPTION: Machine support for picoZed. (http://www.picozed.org/)
4#
5# Note: This machine configuration is intended as a generic config for
6# the picozed SOM. It also covers the multiple SKUs for the picoZed
7# including 7010, 7020, 7015 and 7030.
8
9require conf/machine/zynq-generic.conf
10
11SPL_BINARY ?= "spl/boot.bin"
12UBOOT_ELF = "u-boot"
13
14EXTRA_IMAGEDEPENDS += " \
15 u-boot-zynq-uenv \
16 virtual/boot-bin \
17 virtual/bootloader \
18 u-boot-zynq-scr \
19 "
20
21IMAGE_BOOT_FILES += " \
22 boot.bin \
23 uEnv.txt \
24 "
25
diff --git a/meta-xilinx-vendor/conf/machine/ultra96-zynqmp.conf b/meta-xilinx-vendor/conf/machine/ultra96-zynqmp.conf
new file mode 100644
index 00000000..ff74ac3d
--- /dev/null
+++ b/meta-xilinx-vendor/conf/machine/ultra96-zynqmp.conf
@@ -0,0 +1,23 @@
1#@TYPE: Machine
2#@NAME: ultra96-zynqmp
3#@DESCRIPTION: Machine support for Ultra96 Evaluation Board.
4#
5
6SOC_VARIANT = 'eg'
7
8require conf/machine/zynqmp-generic.conf
9
10# Add board compatibility override
11MACHINEOVERRIDES .= ":ultra96"
12
13KERNEL_DEVICETREE = "xilinx/zynqmp-zcu100-revC.dtb"
14
15# Affects meta-xilinx-tools xsctyaml.bbclass related items
16YAML_SERIAL_CONSOLE_STDIN ?= "psu_uart_1"
17YAML_SERIAL_CONSOLE_STDOUT ?= "psu_uart_1"
18
19YAML_COMPILER_FLAGS:append = " -DBOARD_SHUTDOWN_PIN=2 -DBOARD_SHUTDOWN_PIN_STATE=0 "
20
21# Enable bluetooth and wifi module
22MACHINE_ESSENTIAL_EXTRA_RDEPENDS:append = " linux-firmware-wl18xx linux-firmware-ti-bt-wl180x"
23
diff --git a/meta-xilinx-vendor/conf/machine/zedboard-zynq7.conf b/meta-xilinx-vendor/conf/machine/zedboard-zynq7.conf
new file mode 100644
index 00000000..4da6bb4e
--- /dev/null
+++ b/meta-xilinx-vendor/conf/machine/zedboard-zynq7.conf
@@ -0,0 +1,24 @@
1#@TYPE: Machine
2#@NAME: zedboard-zynq7
3#@DESCRIPTION: Machine support for ZedBoard. (http://www.zedboard.org/)
4#
5# For details on the Evaluation board:
6# http://www.zedboard.org/content/overview
7# For design files (including 'zynq_fsbl_0.elf') for the ZedBoard:
8# http://www.zedboard.org/reference-designs-categories/zynq-concepts-tools-and-techniques-zedboard
9#
10
11require conf/machine/zynq-generic.conf
12
13# Add board compatibility override
14MACHINEOVERRIDES .= ":zedboard"
15
16SPL_BINARY ?= "spl/boot.bin"
17
18KERNEL_DEVICETREE = "zynq-zed.dtb"
19
20IMAGE_BOOT_FILES += " \
21 boot.bin \
22 uEnv.txt \
23 boot.scr \
24 "
diff --git a/meta-xilinx-vendor/conf/machine/zybo-linux-bd-zynq7.conf b/meta-xilinx-vendor/conf/machine/zybo-linux-bd-zynq7.conf
new file mode 100644
index 00000000..98718ae3
--- /dev/null
+++ b/meta-xilinx-vendor/conf/machine/zybo-linux-bd-zynq7.conf
@@ -0,0 +1,24 @@
1#@TYPE: Machine
2#@NAME: zybo-linux-bd-zynq7
3#@DESCRIPTION: Machine support for zybo-linux-bd project.
4#
5# generated base on ZYBO linux-bd project
6#
7
8require conf/machine/zynq-generic.conf
9
10MACHINE_FEATURES += "keyboard screen alsa sdio"
11
12SPL_BINARY ?= "spl/boot.bin"
13FORCE_PLATFORM_INIT = "1"
14UBOOT_ELF = "u-boot"
15
16IMAGE_BOOT_FILES += " \
17 boot.bin \
18 bitstream \
19 uEnv.txt \
20 "
21
22KERNEL_FEATURES += " \
23 features/xilinx/v4l2/v4l2.scc \
24 "
diff --git a/meta-xilinx-vendor/conf/machine/zybo-zynq7.conf b/meta-xilinx-vendor/conf/machine/zybo-zynq7.conf
new file mode 100644
index 00000000..74d117c0
--- /dev/null
+++ b/meta-xilinx-vendor/conf/machine/zybo-zynq7.conf
@@ -0,0 +1,27 @@
1#@TYPE: Machine
2#@NAME: zybo-zynq7
3#@DESCRIPTION: Machine support for ZYBO.
4#
5# For details on the ZYBO board:
6# https://www.digilentinc.com/Products/Detail.cfm?Prod=ZYBO
7#
8
9require conf/machine/zynq-generic.conf
10
11SPL_BINARY ?= "spl/boot.bin"
12UBOOT_ELF = "u-boot"
13
14EXTRA_IMAGEDEPENDS += " \
15 u-boot-zynq-uenv \
16 virtual/boot-bin \
17 virtual/bootloader \
18 u-boot-zynq-scr \
19 "
20
21KERNEL_DEVICETREE = "zynq-zybo.dtb"
22
23IMAGE_BOOT_FILES += " \
24 boot.bin \
25 uEnv.txt \
26 "
27