summaryrefslogtreecommitdiffstats
path: root/meta-xilinx-standalone/recipes-core
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@amd.com>2023-02-23 13:31:46 -0800
committerMark Hatle <mark.hatle@amd.com>2023-04-10 09:03:22 -0700
commit66e2e7760900d8e3c24c7871a92a5a89545bf498 (patch)
tree2ff3dc8e3f21b262f6bf5cdf0b6938669fcc0d3f /meta-xilinx-standalone/recipes-core
parentfbe8f13d8d728d3faa3e8e98fa33f73707d1c099 (diff)
downloadmeta-xilinx-66e2e7760900d8e3c24c7871a92a5a89545bf498.tar.gz
packagegroup-standalone-cross-canadian: Move from bbappend to new bb
We want to avoid modifying the default package, as it can break Yocto Project Compatibility guidelines. Signed-off-by: Mark Hatle <mark.hatle@amd.com>
Diffstat (limited to 'meta-xilinx-standalone/recipes-core')
-rw-r--r--meta-xilinx-standalone/recipes-core/packagegroups/packagegroup-standalone-cross-canadian.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-xilinx-standalone/recipes-core/packagegroups/packagegroup-standalone-cross-canadian.bb b/meta-xilinx-standalone/recipes-core/packagegroups/packagegroup-standalone-cross-canadian.bb
new file mode 100644
index 00000000..56bd7aca
--- /dev/null
+++ b/meta-xilinx-standalone/recipes-core/packagegroups/packagegroup-standalone-cross-canadian.bb
@@ -0,0 +1,23 @@
1SUMMARY = "Host SDK package for standalone cross canadian toolchain"
2PN = "packagegroup-stadalone-cross-canadian-${MACHINE}"
3
4inherit cross-canadian packagegroup
5
6PACKAGEGROUP_DISABLE_COMPLEMENTARY = "1"
7
8# Use indirection to stop these being expanded prematurely
9BINUTILS = "binutils-cross-canadian-${TRANSLATED_TARGET_ARCH}"
10GCC = "gcc-cross-canadian-${TRANSLATED_TARGET_ARCH}"
11GDB = "gdb-cross-canadian-${TRANSLATED_TARGET_ARCH}"
12
13# Create the links to the multilib toolchain components
14GNUTCLINKS = "standalone-gnu-toolchain-canadian-${TARGET_SYS}"
15
16# Without the := the eval during do_package is occasionally missing multilibs
17RDEPENDS:${PN}:xilinx-standalone := " \
18 ${@all_multilib_tune_values(d, 'GNUTCLINKS')} \
19 ${BINUTILS} \
20 ${GCC} \
21 ${GDB} \
22 meta-environment-${MACHINE} \
23"