summaryrefslogtreecommitdiffstats
path: root/meta-xilinx-standalone/recipes-core
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@xilinx.com>2020-02-24 12:14:48 -0800
committerMark Hatle <mark.hatle@xilinx.com>2020-02-27 08:36:00 -0800
commit4f3edb6da405ffff957d6f194bc7db7bdd9f1463 (patch)
tree50895bd7e0126620749adff252f5eb6b9da84540 /meta-xilinx-standalone/recipes-core
parentc6fc0f9a034a3a3c8748e0a650f8728f8c044065 (diff)
downloadmeta-xilinx-4f3edb6da405ffff957d6f194bc7db7bdd9f1463.tar.gz
xlnx-compatible-os.bbclass: Class to allow recipes to list OS compatibility
Following the example of base.bbclass in OE-Core, a new COMPATIBLE_OS variable is defined. Similar to COMPATIBLE_MACHINE, it is a regex that can be used to declare TARGET_OS string compatibility on a per-recipe basis. Either the distro configuration or the recipes themselves will need to inherit this class. By default the class assumes we're building a Linux based system, and thus any recipe who has not declared compatibility is compatible with Linux. The default compatible field was copied from bitbake.conf to ensure there are no surprised. Additionally, enable the usage of this class throughout meta-xilinx-standalone layer. Signed-off-by: Mark Hatle <mark.hatle@xilinx.com>
Diffstat (limited to 'meta-xilinx-standalone/recipes-core')
-rw-r--r--meta-xilinx-standalone/recipes-core/meta/meta-toolchain.bbappend2
-rw-r--r--meta-xilinx-standalone/recipes-core/newlib/libgloss_3.1.0.bbappend3
-rw-r--r--meta-xilinx-standalone/recipes-core/newlib/newlib_3.1.0.bbappend2
-rw-r--r--meta-xilinx-standalone/recipes-core/packagegroups/packagegroup-newlib-standalone-sdk-target.bb2
4 files changed, 9 insertions, 0 deletions
diff --git a/meta-xilinx-standalone/recipes-core/meta/meta-toolchain.bbappend b/meta-xilinx-standalone/recipes-core/meta/meta-toolchain.bbappend
index 0b4812d0..cd8638ef 100644
--- a/meta-xilinx-standalone/recipes-core/meta/meta-toolchain.bbappend
+++ b/meta-xilinx-standalone/recipes-core/meta/meta-toolchain.bbappend
@@ -1 +1,3 @@
1COMPATIBLE_OS_xilinx-standalone = "${TARGET_OS}"
2
1TOOLCHAIN_TARGET_TASK_xilinx-standalone = "${@multilib_pkg_extend(d, 'packagegroup-newlib-standalone-sdk-target')}" 3TOOLCHAIN_TARGET_TASK_xilinx-standalone = "${@multilib_pkg_extend(d, 'packagegroup-newlib-standalone-sdk-target')}"
diff --git a/meta-xilinx-standalone/recipes-core/newlib/libgloss_3.1.0.bbappend b/meta-xilinx-standalone/recipes-core/newlib/libgloss_3.1.0.bbappend
index c5dda818..aaf4b77f 100644
--- a/meta-xilinx-standalone/recipes-core/newlib/libgloss_3.1.0.bbappend
+++ b/meta-xilinx-standalone/recipes-core/newlib/libgloss_3.1.0.bbappend
@@ -1,3 +1,6 @@
1COMPATIBLE_OS_xilinx-standalone = "elf"
2COMPATIBLE_OS_arm_xilinx-standalone = "eabi"
3
1# When building multiple, we need to depend on the multilib newlib 4# When building multiple, we need to depend on the multilib newlib
2DEPENDS_append_xilinx-standalone = " ${MLPREFIX}newlib" 5DEPENDS_append_xilinx-standalone = " ${MLPREFIX}newlib"
3 6
diff --git a/meta-xilinx-standalone/recipes-core/newlib/newlib_3.1.0.bbappend b/meta-xilinx-standalone/recipes-core/newlib/newlib_3.1.0.bbappend
index d57f97b1..4e2533d0 100644
--- a/meta-xilinx-standalone/recipes-core/newlib/newlib_3.1.0.bbappend
+++ b/meta-xilinx-standalone/recipes-core/newlib/newlib_3.1.0.bbappend
@@ -1,3 +1,5 @@
1COMPATIBLE_OS_xilinx-standalone = "elf"
2COMPATIBLE_OS_arm_xilinx-standalone = "eabi"
1 3
2EXTRA_OECONF_append_xilinx-standalone = " \ 4EXTRA_OECONF_append_xilinx-standalone = " \
3 --enable-newlib-io-c99-formats \ 5 --enable-newlib-io-c99-formats \
diff --git a/meta-xilinx-standalone/recipes-core/packagegroups/packagegroup-newlib-standalone-sdk-target.bb b/meta-xilinx-standalone/recipes-core/packagegroups/packagegroup-newlib-standalone-sdk-target.bb
index d943938b..6f06f61a 100644
--- a/meta-xilinx-standalone/recipes-core/packagegroups/packagegroup-newlib-standalone-sdk-target.bb
+++ b/meta-xilinx-standalone/recipes-core/packagegroups/packagegroup-newlib-standalone-sdk-target.bb
@@ -1,3 +1,5 @@
1COMPATIBLE_OS_xilinx-standalone = "${TARGET_OS}"
2
1SUMMARY = "Target packages for the standalone SDK" 3SUMMARY = "Target packages for the standalone SDK"
2 4
3PACKAGE_ARCH = "${TUNE_PKGARCH}" 5PACKAGE_ARCH = "${TUNE_PKGARCH}"