summaryrefslogtreecommitdiffstats
path: root/meta-xilinx-standalone/recipes-bsp
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@xilinx.com>2021-02-26 08:51:01 -0800
committerSai Hari Chandana Kalluri <chandana.kalluri@xilinx.com>2021-07-14 14:48:56 -0700
commiteb6b7ed7c2472a773de193a2c2b3aa1fb971b60e (patch)
tree3c656d4aa8cd3f27ad818a4b8f3321c493c881ca /meta-xilinx-standalone/recipes-bsp
parent5a98db991461fdb60b95c81a79314384bcd751f8 (diff)
downloadmeta-xilinx-eb6b7ed7c2472a773de193a2c2b3aa1fb971b60e.tar.gz
Adjust standalone embeddedsw so it can be bbappended by meta-xilinx-tools
Signed-off-by: Mark Hatle <mark.hatle@xilinx.com>
Diffstat (limited to 'meta-xilinx-standalone/recipes-bsp')
-rw-r--r--meta-xilinx-standalone/recipes-bsp/embeddedsw/embeddedsw.inc33
-rw-r--r--meta-xilinx-standalone/recipes-bsp/embeddedsw/plm-firmware.inc4
-rw-r--r--meta-xilinx-standalone/recipes-bsp/embeddedsw/plm-firmware_2020.2.bb2
-rw-r--r--meta-xilinx-standalone/recipes-bsp/embeddedsw/plm-firmware_git.bb2
-rw-r--r--meta-xilinx-standalone/recipes-bsp/embeddedsw/pmu-firmware.inc4
-rw-r--r--meta-xilinx-standalone/recipes-bsp/embeddedsw/pmu-firmware_2020.1.bb2
-rw-r--r--meta-xilinx-standalone/recipes-bsp/embeddedsw/pmu-firmware_2020.2.bb2
-rw-r--r--meta-xilinx-standalone/recipes-bsp/embeddedsw/pmu-firmware_git.bb2
-rw-r--r--meta-xilinx-standalone/recipes-bsp/embeddedsw/psm-firmware.inc4
-rw-r--r--meta-xilinx-standalone/recipes-bsp/embeddedsw/psm-firmware_2020.2.bb2
-rw-r--r--meta-xilinx-standalone/recipes-bsp/embeddedsw/psm-firmware_git.bb2
11 files changed, 17 insertions, 42 deletions
diff --git a/meta-xilinx-standalone/recipes-bsp/embeddedsw/embeddedsw.inc b/meta-xilinx-standalone/recipes-bsp/embeddedsw/embeddedsw.inc
deleted file mode 100644
index 008dfef7..00000000
--- a/meta-xilinx-standalone/recipes-bsp/embeddedsw/embeddedsw.inc
+++ /dev/null
@@ -1,33 +0,0 @@
1# Automatically determnine the version from the bb file
2ESW_VER ?= "${@bb.parse.vars_from_file(d.getVar('FILE', False),d)[1] or 'master'}"
3
4REPO ??= "git://github.com/Xilinx/embeddedsw.git;protocol=https"
5
6ESW_BRANCH[2019.1] = "release-2019.1"
7ESW_BRANCH[2019.2] = "release-2019.2"
8ESW_BRANCH[2020.1] = "release-2020.1"
9ESW_BRANCH[2020.2] = "master-rel-2020.2"
10ESW_BRANCH[git] = "master"
11BRANCH ??= "${@d.getVarFlag('ESW_BRANCH', d.getVar('ESW_VER')) or '${ESW_VER}'}"
12
13ESW_REV[2019.1] = "26c14d9861010a0e3a55c73fb79efdb816eb42ca"
14ESW_REV[2019.2] = "e8db5fb118229fdc621e0ec7848641a23bf60998"
15ESW_REV[2020.1] = "338150ab3628a1ea6b06e964b16e712b131882dd"
16ESW_REV[2020.2] = "2516d5ed8161e16c2813b0e8e4ceac693f23de5c"
17SRCREV ??= "${@d.getVarFlag('ESW_REV', d.getVar('ESW_VER')) or '${AUTOREV}'}"
18
19EMBEDDEDSW_BRANCHARG ?= "${@['nobranch=1', 'branch=${BRANCH}'][d.getVar('BRANCH') != '']}"
20EMBEDDEDSW_SRCURI ?= "${REPO};${EMBEDDEDSW_BRANCHARG}"
21
22LICENSE = "MIT"
23LIC_FILES_CHKSUM[release-2019.1] = 'e9b6d01d45faccfbf05d8caea53f0a35'
24LIC_FILES_CHKSUM[release-2019.2] = '39ab6ab638f4d1836ba994ec6852de94'
25LIC_FILES_CHKSUM[release-2020.1] = '8b565227e1264d677db8f841c2948cba'
26LIC_FILES_CHKSUM[master-rel-2020.2] = '3a6e22aebf6516f0f74a82e1183f74f8'
27LIC_FILES_CHKSUM[master] = '3a6e22aebf6516f0f74a82e1183f74f8'
28LIC_FILES_CHKSUM ??= "file://license.txt;md5=${@d.getVarFlag('LIC_FILES_CHKSUM', d.getVar('BRANCH')) or '0'}"
29
30SRC_URI = "${EMBEDDEDSW_SRCURI}"
31PV = "${ESW_VER}+git${SRCPV}"
32
33FILESPATH .= ":${FILE_DIRNAME}/embeddedsw"
diff --git a/meta-xilinx-standalone/recipes-bsp/embeddedsw/plm-firmware.inc b/meta-xilinx-standalone/recipes-bsp/embeddedsw/plm-firmware.inc
index 8ff96b64..49e6e452 100644
--- a/meta-xilinx-standalone/recipes-bsp/embeddedsw/plm-firmware.inc
+++ b/meta-xilinx-standalone/recipes-bsp/embeddedsw/plm-firmware.inc
@@ -3,9 +3,7 @@ SUMMARY = "Platform Loader and Manager for Versal devices"
3 3
4PROVIDES = "virtual/plm" 4PROVIDES = "virtual/plm"
5 5
6require embeddedsw.inc 6inherit xlnx-embeddedsw deploy
7
8inherit deploy
9 7
10COMPATIBLE_HOST = "microblaze.*-elf" 8COMPATIBLE_HOST = "microblaze.*-elf"
11COMPATIBLE_MACHINE = "microblaze-plm" 9COMPATIBLE_MACHINE = "microblaze-plm"
diff --git a/meta-xilinx-standalone/recipes-bsp/embeddedsw/plm-firmware_2020.2.bb b/meta-xilinx-standalone/recipes-bsp/embeddedsw/plm-firmware_2020.2.bb
index b8a920ae..a1b4aa00 100644
--- a/meta-xilinx-standalone/recipes-bsp/embeddedsw/plm-firmware_2020.2.bb
+++ b/meta-xilinx-standalone/recipes-bsp/embeddedsw/plm-firmware_2020.2.bb
@@ -1,5 +1,7 @@
1require plm-firmware.inc 1require plm-firmware.inc
2 2
3FILESPATH .= ":${FILE_DIRNAME}/embeddedsw"
4
3SRC_URI += " \ 5SRC_URI += " \
4 file://0001-zynqmp_pmufw-Fix-reset-ops-for-assert.patch \ 6 file://0001-zynqmp_pmufw-Fix-reset-ops-for-assert.patch \
5 file://0001-zynqmp_pmufw-Correct-structure-header-of-PmResetOps.patch \ 7 file://0001-zynqmp_pmufw-Correct-structure-header-of-PmResetOps.patch \
diff --git a/meta-xilinx-standalone/recipes-bsp/embeddedsw/plm-firmware_git.bb b/meta-xilinx-standalone/recipes-bsp/embeddedsw/plm-firmware_git.bb
index b625b332..ccabf9dc 100644
--- a/meta-xilinx-standalone/recipes-bsp/embeddedsw/plm-firmware_git.bb
+++ b/meta-xilinx-standalone/recipes-bsp/embeddedsw/plm-firmware_git.bb
@@ -3,6 +3,8 @@ DEFAULT_PREFERENCE = "-1"
3 3
4require plm-firmware.inc 4require plm-firmware.inc
5 5
6FILESPATH .= ":${FILE_DIRNAME}/embeddedsw"
7
6SRC_URI += " \ 8SRC_URI += " \
7 file://0001-zynqmp_pmufw-Fix-reset-ops-for-assert.patch \ 9 file://0001-zynqmp_pmufw-Fix-reset-ops-for-assert.patch \
8 file://0001-zynqmp_pmufw-Correct-structure-header-of-PmResetOps.patch \ 10 file://0001-zynqmp_pmufw-Correct-structure-header-of-PmResetOps.patch \
diff --git a/meta-xilinx-standalone/recipes-bsp/embeddedsw/pmu-firmware.inc b/meta-xilinx-standalone/recipes-bsp/embeddedsw/pmu-firmware.inc
index dc0e1c82..f77976e0 100644
--- a/meta-xilinx-standalone/recipes-bsp/embeddedsw/pmu-firmware.inc
+++ b/meta-xilinx-standalone/recipes-bsp/embeddedsw/pmu-firmware.inc
@@ -2,9 +2,7 @@ DESCRIPTION = "PMU Firmware"
2 2
3PROVIDES = "virtual/pmu-firmware" 3PROVIDES = "virtual/pmu-firmware"
4 4
5require embeddedsw.inc 5inherit xlnx-embeddedsw deploy
6
7inherit deploy
8 6
9COMPATIBLE_HOST = "microblaze.*-elf" 7COMPATIBLE_HOST = "microblaze.*-elf"
10COMPATIBLE_MACHINE = "microblaze-pmu" 8COMPATIBLE_MACHINE = "microblaze-pmu"
diff --git a/meta-xilinx-standalone/recipes-bsp/embeddedsw/pmu-firmware_2020.1.bb b/meta-xilinx-standalone/recipes-bsp/embeddedsw/pmu-firmware_2020.1.bb
index 047047bc..6b90f496 100644
--- a/meta-xilinx-standalone/recipes-bsp/embeddedsw/pmu-firmware_2020.1.bb
+++ b/meta-xilinx-standalone/recipes-bsp/embeddedsw/pmu-firmware_2020.1.bb
@@ -1,5 +1,7 @@
1require pmu-firmware.inc 1require pmu-firmware.inc
2 2
3FILESPATH .= ":${FILE_DIRNAME}/embeddedsw"
4
3SRC_URI += " \ 5SRC_URI += " \
4 file://0001-zynqmp_pmufw-Fix-reset-ops-for-assert.patch \ 6 file://0001-zynqmp_pmufw-Fix-reset-ops-for-assert.patch \
5 file://0001-zynqmp_pmufw-Correct-structure-header-of-PmResetOps.patch \ 7 file://0001-zynqmp_pmufw-Correct-structure-header-of-PmResetOps.patch \
diff --git a/meta-xilinx-standalone/recipes-bsp/embeddedsw/pmu-firmware_2020.2.bb b/meta-xilinx-standalone/recipes-bsp/embeddedsw/pmu-firmware_2020.2.bb
index 12fc5c76..81eaf1ae 100644
--- a/meta-xilinx-standalone/recipes-bsp/embeddedsw/pmu-firmware_2020.2.bb
+++ b/meta-xilinx-standalone/recipes-bsp/embeddedsw/pmu-firmware_2020.2.bb
@@ -1,5 +1,7 @@
1require pmu-firmware.inc 1require pmu-firmware.inc
2 2
3FILESPATH .= ":${FILE_DIRNAME}/embeddedsw"
4
3SRC_URI += " \ 5SRC_URI += " \
4 file://0001-zynqmp_pmufw-Fix-reset-ops-for-assert.patch \ 6 file://0001-zynqmp_pmufw-Fix-reset-ops-for-assert.patch \
5 file://0001-zynqmp_pmufw-Correct-structure-header-of-PmResetOps.patch \ 7 file://0001-zynqmp_pmufw-Correct-structure-header-of-PmResetOps.patch \
diff --git a/meta-xilinx-standalone/recipes-bsp/embeddedsw/pmu-firmware_git.bb b/meta-xilinx-standalone/recipes-bsp/embeddedsw/pmu-firmware_git.bb
index 17ce7693..fe4dcf5f 100644
--- a/meta-xilinx-standalone/recipes-bsp/embeddedsw/pmu-firmware_git.bb
+++ b/meta-xilinx-standalone/recipes-bsp/embeddedsw/pmu-firmware_git.bb
@@ -3,6 +3,8 @@ DEFAULT_PREFERENCE = "-1"
3 3
4require pmu-firmware.inc 4require pmu-firmware.inc
5 5
6FILESPATH .= ":${FILE_DIRNAME}/embeddedsw"
7
6SRC_URI += " \ 8SRC_URI += " \
7 file://0001-zynqmp_pmufw-Fix-reset-ops-for-assert.patch \ 9 file://0001-zynqmp_pmufw-Fix-reset-ops-for-assert.patch \
8 file://0001-zynqmp_pmufw-Correct-structure-header-of-PmResetOps.patch \ 10 file://0001-zynqmp_pmufw-Correct-structure-header-of-PmResetOps.patch \
diff --git a/meta-xilinx-standalone/recipes-bsp/embeddedsw/psm-firmware.inc b/meta-xilinx-standalone/recipes-bsp/embeddedsw/psm-firmware.inc
index 66754b08..25db5bf4 100644
--- a/meta-xilinx-standalone/recipes-bsp/embeddedsw/psm-firmware.inc
+++ b/meta-xilinx-standalone/recipes-bsp/embeddedsw/psm-firmware.inc
@@ -3,9 +3,7 @@ SUMMARY = "PSM firmware for versal devices"
3 3
4PROVIDES = "virtual/psm-firmware" 4PROVIDES = "virtual/psm-firmware"
5 5
6require embeddedsw.inc 6inherit xlnx-embeddedsw deploy
7
8inherit deploy
9 7
10COMPATIBLE_HOST = "microblaze.*-elf" 8COMPATIBLE_HOST = "microblaze.*-elf"
11COMPATIBLE_MACHINE = "microblaze-psm" 9COMPATIBLE_MACHINE = "microblaze-psm"
diff --git a/meta-xilinx-standalone/recipes-bsp/embeddedsw/psm-firmware_2020.2.bb b/meta-xilinx-standalone/recipes-bsp/embeddedsw/psm-firmware_2020.2.bb
index 39353fdf..9603e53f 100644
--- a/meta-xilinx-standalone/recipes-bsp/embeddedsw/psm-firmware_2020.2.bb
+++ b/meta-xilinx-standalone/recipes-bsp/embeddedsw/psm-firmware_2020.2.bb
@@ -1,5 +1,7 @@
1require psm-firmware.inc 1require psm-firmware.inc
2 2
3FILESPATH .= ":${FILE_DIRNAME}/embeddedsw"
4
3SRC_URI += " \ 5SRC_URI += " \
4 file://0001-zynqmp_pmufw-Fix-reset-ops-for-assert.patch \ 6 file://0001-zynqmp_pmufw-Fix-reset-ops-for-assert.patch \
5 file://0001-zynqmp_pmufw-Correct-structure-header-of-PmResetOps.patch \ 7 file://0001-zynqmp_pmufw-Correct-structure-header-of-PmResetOps.patch \
diff --git a/meta-xilinx-standalone/recipes-bsp/embeddedsw/psm-firmware_git.bb b/meta-xilinx-standalone/recipes-bsp/embeddedsw/psm-firmware_git.bb
index 6d34e723..6dd322b1 100644
--- a/meta-xilinx-standalone/recipes-bsp/embeddedsw/psm-firmware_git.bb
+++ b/meta-xilinx-standalone/recipes-bsp/embeddedsw/psm-firmware_git.bb
@@ -3,6 +3,8 @@ DEFAULT_PREFERENCE = "-1"
3 3
4require psm-firmware.inc 4require psm-firmware.inc
5 5
6FILESPATH .= ":${FILE_DIRNAME}/embeddedsw"
7
6SRC_URI += " \ 8SRC_URI += " \
7 file://0001-zynqmp_pmufw-Fix-reset-ops-for-assert.patch \ 9 file://0001-zynqmp_pmufw-Fix-reset-ops-for-assert.patch \
8 file://0001-zynqmp_pmufw-Correct-structure-header-of-PmResetOps.patch \ 10 file://0001-zynqmp_pmufw-Correct-structure-header-of-PmResetOps.patch \