summaryrefslogtreecommitdiffstats
path: root/meta-xilinx-standalone/recipes-bsp
diff options
context:
space:
mode:
authorAppana Durga Kedareswara rao <appana.durga.kedareswara.rao@amd.com>2023-02-10 23:26:14 +0530
committerMark Hatle <mark.hatle@amd.com>2023-02-10 10:46:47 -0800
commit35e82245d5739673818bd59830d2687aba88f99b (patch)
tree09fde85121e584c05329e79bb3dc96dbcf8de8da /meta-xilinx-standalone/recipes-bsp
parent0a7b0bf69fc38f61feb6973bd3733652103c5c96 (diff)
downloadmeta-xilinx-35e82245d5739673818bd59830d2687aba88f99b.tar.gz
meta-xilinx-standalone: recipes-bsp: device-tree: Update recipe for freertos distro
Add support for freertos distro by updating COMPATIBLE_HOST. Signed-off-by: Appana Durga Kedareswara rao <appana.durga.kedareswara.rao@amd.com> Signed-off-by: Mark Hatle <mark.hatle@amd.com>
Diffstat (limited to 'meta-xilinx-standalone/recipes-bsp')
-rw-r--r--meta-xilinx-standalone/recipes-bsp/device-tree/device-tree.bbappend3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta-xilinx-standalone/recipes-bsp/device-tree/device-tree.bbappend b/meta-xilinx-standalone/recipes-bsp/device-tree/device-tree.bbappend
index 056c4edc..fcc041fd 100644
--- a/meta-xilinx-standalone/recipes-bsp/device-tree/device-tree.bbappend
+++ b/meta-xilinx-standalone/recipes-bsp/device-tree/device-tree.bbappend
@@ -1,4 +1,5 @@
1COMPATIBLE_HOST:xilinx-standalone = "${HOST_SYS}" 1COMPATIBLE_HOST:xilinx-standalone = "${HOST_SYS}"
2COMPATIBLE_HOST:xilinx-freertos = "${HOST_SYS}"
2 3
3COMPATIBLE_MACHINE:cortexa53-zynqmp = ".*" 4COMPATIBLE_MACHINE:cortexa53-zynqmp = ".*"
4COMPATIBLE_MACHINE:cortexr5-zynqmp = ".*" 5COMPATIBLE_MACHINE:cortexr5-zynqmp = ".*"
@@ -11,3 +12,5 @@ COMPATIBLE_MACHINE:cortexa9-zynq = ".*"
11# Enable @ flag on dtc which is required by libxil 12# Enable @ flag on dtc which is required by libxil
12DTC_FLAGS:append:xilinx-standalone = " -@" 13DTC_FLAGS:append:xilinx-standalone = " -@"
13DT_INCLUDE:append:xilinx-standalone = " ${WORKDIR}/git/device_tree/data/kernel_dtsi/${XILINX_RELEASE_VERSION}/include/" 14DT_INCLUDE:append:xilinx-standalone = " ${WORKDIR}/git/device_tree/data/kernel_dtsi/${XILINX_RELEASE_VERSION}/include/"
15DTC_FLAGS:append:xilinx-freertos = " -@"
16DT_INCLUDE:append:xilinx-freertos = " ${WORKDIR}/git/device_tree/data/kernel_dtsi/${XILINX_RELEASE_VERSION}/include/"