summaryrefslogtreecommitdiffstats
path: root/meta-xilinx-standalone/recipes-bsp/embeddedsw
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@xilinx.com>2021-03-12 16:22:09 -0800
committerSai Hari Chandana Kalluri <chandana.kalluri@xilinx.com>2021-07-14 14:49:19 -0700
commit9e0f025df88b7e13aa4abf2eff1852a5fc1fb0a4 (patch)
treed7c44a5071c7a8a284300f973741cf2acb589af6 /meta-xilinx-standalone/recipes-bsp/embeddedsw
parent453ba3b622e0dce7834209b453c01412028799fa (diff)
downloadmeta-xilinx-9e0f025df88b7e13aa4abf2eff1852a5fc1fb0a4.tar.gz
embeddedsw; Fixups for missed plm and psm issues
Signed-off-by: Mark Hatle <mark.hatle@xilinx.com>
Diffstat (limited to 'meta-xilinx-standalone/recipes-bsp/embeddedsw')
-rw-r--r--meta-xilinx-standalone/recipes-bsp/embeddedsw/plm-firmware.inc11
-rw-r--r--meta-xilinx-standalone/recipes-bsp/embeddedsw/plm-firmware_2020.2.bb2
-rw-r--r--meta-xilinx-standalone/recipes-bsp/embeddedsw/psm-firmware.inc11
-rw-r--r--meta-xilinx-standalone/recipes-bsp/embeddedsw/psm-firmware_2020.2.bb2
4 files changed, 18 insertions, 8 deletions
diff --git a/meta-xilinx-standalone/recipes-bsp/embeddedsw/plm-firmware.inc b/meta-xilinx-standalone/recipes-bsp/embeddedsw/plm-firmware.inc
index e4feba31..bedb0685 100644
--- a/meta-xilinx-standalone/recipes-bsp/embeddedsw/plm-firmware.inc
+++ b/meta-xilinx-standalone/recipes-bsp/embeddedsw/plm-firmware.inc
@@ -19,6 +19,12 @@ do_configure() {
19 ${B}/../misc/copy_bsp.sh 19 ${B}/../misc/copy_bsp.sh
20} 20}
21 21
22# All do_compiles need this, even if it's overriden
23MB_OBJCOPY ??= "${OBJCOPY}"
24
25# Only add a dependency if we need to use OUR binutils
26DEPENDS .= "${@' virtual/${TARGET_PREFIX}binutils' if d.getVar('MB_OBJCOPY') == d.getVar('OBJCOPY') else ''}"
27
22COMPILER = "${CC}" 28COMPILER = "${CC}"
23COMPILER_FLAGS = "-O2 -c" 29COMPILER_FLAGS = "-O2 -c"
24EXTRA_COMPILER_FLAGS = "-g -Wall -Wextra -Os -flto -ffat-lto-objects" 30EXTRA_COMPILER_FLAGS = "-g -Wall -Wextra -Os -flto -ffat-lto-objects"
@@ -46,11 +52,8 @@ do_compile() {
46 # --build-id=none is required due to linker script not defining a location for it. 52 # --build-id=none is required due to linker script not defining a location for it.
47 # Again, recipe-systoot include is necessary 53 # Again, recipe-systoot include is necessary
48 oe_runmake CC_FLAGS="-MMD -MP -Wl,--build-id=none -I${STAGING_DIR_TARGET}/usr/include" 54 oe_runmake CC_FLAGS="-MMD -MP -Wl,--build-id=none -I${STAGING_DIR_TARGET}/usr/include"
49}
50 55
51# All do_compiles need this, even if the base is overriden 56 ${MB_OBJCOPY} -O binary ${B}/plm.elf ${B}/plm.bin
52do_compile_append() {
53 ${OBJCOPY} -O binary ${B}/plm.elf ${B}/plm.bin
54} 57}
55 58
56do_install() { 59do_install() {
diff --git a/meta-xilinx-standalone/recipes-bsp/embeddedsw/plm-firmware_2020.2.bb b/meta-xilinx-standalone/recipes-bsp/embeddedsw/plm-firmware_2020.2.bb
index a1b4aa00..a1d1c504 100644
--- a/meta-xilinx-standalone/recipes-bsp/embeddedsw/plm-firmware_2020.2.bb
+++ b/meta-xilinx-standalone/recipes-bsp/embeddedsw/plm-firmware_2020.2.bb
@@ -53,4 +53,6 @@ do_compile() {
53 # Again, recipe-systoot include is necessary 53 # Again, recipe-systoot include is necessary
54 echo Construct: executable 54 echo Construct: executable
55 oe_runmake plm.elf ${@bsp_make_vars(d)} CC_FLAGS="-MMD -MP -Wl,--build-id=none -I${STAGING_DIR_TARGET}/usr/include" 55 oe_runmake plm.elf ${@bsp_make_vars(d)} CC_FLAGS="-MMD -MP -Wl,--build-id=none -I${STAGING_DIR_TARGET}/usr/include"
56
57 ${MB_OBJCOPY} -O binary ${B}/plm.elf ${B}/plm.bin
56} 58}
diff --git a/meta-xilinx-standalone/recipes-bsp/embeddedsw/psm-firmware.inc b/meta-xilinx-standalone/recipes-bsp/embeddedsw/psm-firmware.inc
index 11e8981b..da76fedf 100644
--- a/meta-xilinx-standalone/recipes-bsp/embeddedsw/psm-firmware.inc
+++ b/meta-xilinx-standalone/recipes-bsp/embeddedsw/psm-firmware.inc
@@ -19,6 +19,12 @@ do_configure() {
19 ${B}/../misc/copy_bsp.sh 19 ${B}/../misc/copy_bsp.sh
20} 20}
21 21
22# All do_compiles need this, even if it's overriden
23MB_OBJCOPY ??= "${OBJCOPY}"
24
25# Only add a dependency if we need to use OUR binutils
26DEPENDS .= "${@' virtual/${TARGET_PREFIX}binutils' if d.getVar('MB_OBJCOPY') == d.getVar('OBJCOPY') else ''}"
27
22COMPILER = "${CC}" 28COMPILER = "${CC}"
23COMPILER_FLAGS = "-O2 -c" 29COMPILER_FLAGS = "-O2 -c"
24EXTRA_COMPILER_FLAGS = "-g -Wall -Wextra -Os -flto -ffat-lto-objects" 30EXTRA_COMPILER_FLAGS = "-g -Wall -Wextra -Os -flto -ffat-lto-objects"
@@ -46,11 +52,8 @@ do_compile() {
46 # --build-id=none is required due to linker script not defining a location for it. 52 # --build-id=none is required due to linker script not defining a location for it.
47 # Again, recipe-systoot include is necessary 53 # Again, recipe-systoot include is necessary
48 oe_runmake CC_FLAGS="-MMD -MP -Wl,--build-id=none -I${STAGING_DIR_TARGET}/usr/include" 54 oe_runmake CC_FLAGS="-MMD -MP -Wl,--build-id=none -I${STAGING_DIR_TARGET}/usr/include"
49}
50 55
51# All do compiles need this, even if the base is overriden 56 ${MB_OBJCOPY} -O binary ${B}/psmfw.elf ${B}/psmfw.bin
52do_compile_append() {
53 ${OBJCOPY} -O binary ${B}/psmfw.elf ${B}/psmfw.bin
54} 57}
55 58
56do_install() { 59do_install() {
diff --git a/meta-xilinx-standalone/recipes-bsp/embeddedsw/psm-firmware_2020.2.bb b/meta-xilinx-standalone/recipes-bsp/embeddedsw/psm-firmware_2020.2.bb
index 9603e53f..2506ba7b 100644
--- a/meta-xilinx-standalone/recipes-bsp/embeddedsw/psm-firmware_2020.2.bb
+++ b/meta-xilinx-standalone/recipes-bsp/embeddedsw/psm-firmware_2020.2.bb
@@ -53,4 +53,6 @@ do_compile() {
53 # Again, recipe-systoot include is necessary 53 # Again, recipe-systoot include is necessary
54 echo Construct: executable 54 echo Construct: executable
55 oe_runmake psmfw.elf ${@bsp_make_vars(d)} CC_FLAGS="-MMD -MP -Wl,--build-id=none -I${STAGING_DIR_TARGET}/usr/include" 55 oe_runmake psmfw.elf ${@bsp_make_vars(d)} CC_FLAGS="-MMD -MP -Wl,--build-id=none -I${STAGING_DIR_TARGET}/usr/include"
56
57 ${MB_OBJCOPY} -O binary ${B}/psmfw.elf ${B}/psmfw.bin
56} 58}