summaryrefslogtreecommitdiffstats
path: root/meta-xilinx-standalone/classes
diff options
context:
space:
mode:
authorSivaprasad Addepalli <sivaprasad.addepalli@xilinx.com>2023-09-18 23:41:03 +0530
committerSiva Addepalli <sivaprasad.addepalli@xilinx.com>2023-09-19 00:27:12 +0530
commitefaf28a79e2cd25ec97bf74d24c5248899d6b292 (patch)
tree3f7723a01356fdfdc68f3c84ef7cff495e1b4456 /meta-xilinx-standalone/classes
parentdd03a1f8314d2d4d9bf1d5a0d28ccd49874151f6 (diff)
downloadmeta-xilinx-efaf28a79e2cd25ec97bf74d24c5248899d6b292.tar.gz
embeddedsw : Updated SRCREV for 2023.2_4139
sw_services: XilSecure: Input Validations are added for xsecure_elliptic.c file xilpm: examples: Integrate self-suspend example into vitisng/rigle flow sw_services:xilnvm:server: Avoid returning XST_SUCCESS incase of glitch sw_services:xilnvm:client: Avoid returning XST_SUCCESS incase of glitch sw_services: xilnvm: Add volatile keyword to avoid optimization sw_services: xilnvm: Fix assigning Status to XST_SUCCESS sw_services: xilnvm: Fix SW-BP-REDUNDANCY in XNvm_EfuseWriteDmeRevoke and XNvm_EfusePrgmIv lib: sw_apps: Fix race condition in the app CMakeLists.txt for sdt flow versal: Fix for ssit security review comments wdttb: Fixed MISRA-C violation 10.4 wdttb: Fix MISRA C violation 12.1 Fix internal security review comments bsp:standalone: Fixed source code-format issue. bsp:standalone: Fix MISRA-C violation for Rule 12.1 bsp:standalone: Fix MISRA-C violation for Rule 7.2 bsp:standalone: Fix MISRA-C violation for Directive 4.6 bsp:standalone: Fix Misra-c violation for Rule 10.3 xilpm:versal_net: save and restore PL devices hierarchy xilpm:versal_net: Restore missing Pl Devices during PLM update xloader:versal_net: save and restore image info table contents xilpm:versal_common: fix potential issue on array out of bound. updated for changelog xadcps and other components xilpm: versal: server: Fix MISRA-C violation for rule 8.13 xilpm: versal: server: Fix MISRA-C violation for rule 12.1 updated for changelog uartlite sw_services:xilocp:Fixes for Doxygen warnings dpdma: Fix MISRA-C rule 12.1 violation dpdma: Fix MISRA-C rule 15.5 violation Signed-off-by: Siva Addepalli <sivaprasad.addepalli@xilinx.com>
Diffstat (limited to 'meta-xilinx-standalone/classes')
-rw-r--r--meta-xilinx-standalone/classes/xlnx-embeddedsw.bbclass2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-xilinx-standalone/classes/xlnx-embeddedsw.bbclass b/meta-xilinx-standalone/classes/xlnx-embeddedsw.bbclass
index e86f2eaa..b635462f 100644
--- a/meta-xilinx-standalone/classes/xlnx-embeddedsw.bbclass
+++ b/meta-xilinx-standalone/classes/xlnx-embeddedsw.bbclass
@@ -8,7 +8,7 @@ ESW_BRANCH[2023.2] = "xlnx_rel_v2023.2-next"
8BRANCH ??= "${@d.getVarFlag('ESW_BRANCH', d.getVar('ESW_VER')) or '${ESW_VER}'}" 8BRANCH ??= "${@d.getVarFlag('ESW_BRANCH', d.getVar('ESW_VER')) or '${ESW_VER}'}"
9 9
10ESW_REV[2023.1] = "e24fe92b5517ee447e560790e798cad792f53bab" 10ESW_REV[2023.1] = "e24fe92b5517ee447e560790e798cad792f53bab"
11ESW_REV[2023.2] = "8c698994fb414274b530a1d1d36146a3ca69f993" 11ESW_REV[2023.2] = "6dd9d8283c5545c35353089e8ece1acb6c0d20b7"
12SRCREV ??= "${@d.getVarFlag('ESW_REV', d.getVar('ESW_VER')) or '${AUTOREV}'}" 12SRCREV ??= "${@d.getVarFlag('ESW_REV', d.getVar('ESW_VER')) or '${AUTOREV}'}"
13 13
14EMBEDDEDSW_BRANCHARG ?= "${@['nobranch=1', 'branch=${BRANCH}'][d.getVar('BRANCH') != '']}" 14EMBEDDEDSW_BRANCHARG ?= "${@['nobranch=1', 'branch=${BRANCH}'][d.getVar('BRANCH') != '']}"