diff options
author | Mark Hatle <mark.hatle@amd.com> | 2024-05-23 09:49:48 -0600 |
---|---|---|
committer | Mark Hatle <mark.hatle@amd.com> | 2024-11-21 10:43:43 -0600 |
commit | 3fb0ec778d76d509c30dcf1e07dcdd659f823be7 (patch) | |
tree | cbc9c3a8458add6f673b3124ccbd8688767c934e /meta-xilinx-standalone-sdt/recipes-applications/zynq-dram-test/zynq-dram-test_2024.1.bb | |
parent | afad32c5d133a1f8a6e59e51d228161b9f47bb10 (diff) | |
download | meta-xilinx-3fb0ec778d76d509c30dcf1e07dcdd659f823be7.tar.gz |
meta-xilinx-standalone-sdt: Rename from ...-experimental
Add symlink to old name for temporarily compatibility.
Signed-off-by: Mark Hatle <mark.hatle@amd.com>
Diffstat (limited to 'meta-xilinx-standalone-sdt/recipes-applications/zynq-dram-test/zynq-dram-test_2024.1.bb')
-rw-r--r-- | meta-xilinx-standalone-sdt/recipes-applications/zynq-dram-test/zynq-dram-test_2024.1.bb | 28 |
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-xilinx-standalone-sdt/recipes-applications/zynq-dram-test/zynq-dram-test_2024.1.bb b/meta-xilinx-standalone-sdt/recipes-applications/zynq-dram-test/zynq-dram-test_2024.1.bb new file mode 100644 index 00000000..8e0b0c06 --- /dev/null +++ b/meta-xilinx-standalone-sdt/recipes-applications/zynq-dram-test/zynq-dram-test_2024.1.bb | |||
@@ -0,0 +1,28 @@ | |||
1 | inherit esw python3native esw_apps_common | ||
2 | |||
3 | ESW_COMPONENT_SRC = "/lib/sw_apps/zynq_dram_test/src/" | ||
4 | |||
5 | DEPENDS += "libxil xiltimer" | ||
6 | |||
7 | ESW_EXECUTABLE_NAME = "zynq_dram_test" | ||
8 | |||
9 | do_configure:prepend() { | ||
10 | ( | ||
11 | cd ${S} | ||
12 | lopper ${DTS_FILE} -- baremetallinker_xlnx.py ${ESW_MACHINE} ${S}/${ESW_COMPONENT_SRC} | ||
13 | install -m 0755 *.cmake ${S}/${ESW_COMPONENT_SRC}/ | ||
14 | cp -rf ${S}/scripts/linker_files/ ${S}/${ESW_COMPONENT_SRC}/linker_files | ||
15 | install -m 0644 ${S}/cmake/UserConfig.cmake ${S}/${ESW_COMPONENT_SRC} | ||
16 | ) | ||
17 | } | ||
18 | |||
19 | do_generate_app_data() { | ||
20 | # This script should also not rely on relative paths and such | ||
21 | cd ${S} | ||
22 | lopper ${DTS_FILE} -- bmcmake_metadata_xlnx.py ${ESW_MACHINE} ${S}/${ESW_COMPONENT_SRC} hwcmake_metadata ${S} | ||
23 | install -m 0755 *.cmake ${S}/${ESW_COMPONENT_SRC}/ | ||
24 | } | ||
25 | addtask do_generate_app_data before do_configure after do_prepare_recipe_sysroot | ||
26 | do_prepare_recipe_sysroot[rdeptask] = "do_unpack" | ||
27 | |||
28 | FILES:${PN} = "${base_libdir}/firmware/zynq_dram*" | ||