summaryrefslogtreecommitdiffstats
path: root/meta-xilinx-standalone-experimental/recipes-drivers
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@xilinx.com>2022-03-04 16:30:06 -0800
committerMark Hatle <mark.hatle@xilinx.com>2022-03-08 07:27:00 -0800
commitc0f9be6db8689ef10fd363be0c29bfeb674e8588 (patch)
tree991fe0734d6944c31787e84ef78d161bb9e64316 /meta-xilinx-standalone-experimental/recipes-drivers
parent1527b4c74ef8b070024c8bdbe240037d92bac482 (diff)
downloadmeta-xilinx-c0f9be6db8689ef10fd363be0c29bfeb674e8588.tar.gz
meta-xilinx-standalone-experimental: Change from lopper.py to lopper
Upgrade of lopper changed the executable name to lopper. Switch all of the users. Signed-off-by: Mark Hatle <mark.hatle@xilinx.com> (cherry picked from commit 5d28e5640859bc6f275b804e1344c6dd17e5a492) Signed-off-by: Mark Hatle <mark.hatle@xilinx.com>
Diffstat (limited to 'meta-xilinx-standalone-experimental/recipes-drivers')
-rw-r--r--meta-xilinx-standalone-experimental/recipes-drivers/clockps-example_git.bb2
-rw-r--r--meta-xilinx-standalone-experimental/recipes-drivers/common_git.bb4
-rw-r--r--meta-xilinx-standalone-experimental/recipes-drivers/ospipsv_git.bb2
-rw-r--r--meta-xilinx-standalone-experimental/recipes-drivers/uartlite_git.bb2
-rw-r--r--meta-xilinx-standalone-experimental/recipes-drivers/uartns550_git.bb2
-rw-r--r--meta-xilinx-standalone-experimental/recipes-drivers/uartps_git.bb2
-rw-r--r--meta-xilinx-standalone-experimental/recipes-drivers/uartpsv_git.bb2
-rwxr-xr-xmeta-xilinx-standalone-experimental/recipes-drivers/v-frmbuf-rd_git.bb2
-rwxr-xr-xmeta-xilinx-standalone-experimental/recipes-drivers/v-frmbuf-wr_git.bb2
9 files changed, 10 insertions, 10 deletions
diff --git a/meta-xilinx-standalone-experimental/recipes-drivers/clockps-example_git.bb b/meta-xilinx-standalone-experimental/recipes-drivers/clockps-example_git.bb
index 8da16452..0bc67b11 100644
--- a/meta-xilinx-standalone-experimental/recipes-drivers/clockps-example_git.bb
+++ b/meta-xilinx-standalone-experimental/recipes-drivers/clockps-example_git.bb
@@ -10,7 +10,7 @@ inherit python3native
10 10
11do_configure:prepend() { 11do_configure:prepend() {
12 cd ${S} 12 cd ${S}
13 lopper.py ${DTS_FILE} -- baremetallinker_xlnx.py ${ESW_MACHINE} ${S}/${ESW_COMPONENT_SRC} 13 lopper ${DTS_FILE} -- baremetallinker_xlnx.py ${ESW_MACHINE} ${S}/${ESW_COMPONENT_SRC}
14 install -m 0755 memory.ld ${S}/${ESW_COMPONENT_SRC}/ 14 install -m 0755 memory.ld ${S}/${ESW_COMPONENT_SRC}/
15 install -m 0755 *.cmake ${S}/${ESW_COMPONENT_SRC}/ 15 install -m 0755 *.cmake ${S}/${ESW_COMPONENT_SRC}/
16} 16}
diff --git a/meta-xilinx-standalone-experimental/recipes-drivers/common_git.bb b/meta-xilinx-standalone-experimental/recipes-drivers/common_git.bb
index 685e5585..d01a8cac 100644
--- a/meta-xilinx-standalone-experimental/recipes-drivers/common_git.bb
+++ b/meta-xilinx-standalone-experimental/recipes-drivers/common_git.bb
@@ -17,7 +17,7 @@ ESW_COMPONENT_SRC = "/XilinxProcessorIPLib/drivers/common/src/"
17ESW_COMPONENT_NAME = "libcommon.a" 17ESW_COMPONENT_NAME = "libcommon.a"
18 18
19do_configure:prepend() { 19do_configure:prepend() {
20 LOPPER_DTC_FLAGS="-b 0 -@" lopper.py ${DTS_FILE} -- baremetalconfig_xlnx.py ${ESW_MACHINE} ${S}/XilinxProcessorIPLib/drivers/intc/src/ 20 LOPPER_DTC_FLAGS="-b 0 -@" lopper ${DTS_FILE} -- baremetalconfig_xlnx.py ${ESW_MACHINE} ${S}/XilinxProcessorIPLib/drivers/intc/src/
21 LOPPER_DTC_FLAGS="-b 0 -@" lopper.py ${DTS_FILE} -- baremetalconfig_xlnx.py ${ESW_MACHINE} ${S}/XilinxProcessorIPLib/drivers/scugic/src/ 21 LOPPER_DTC_FLAGS="-b 0 -@" lopper ${DTS_FILE} -- baremetalconfig_xlnx.py ${ESW_MACHINE} ${S}/XilinxProcessorIPLib/drivers/scugic/src/
22 install -m 0755 *.cmake ${S}/${ESW_COMPONENT_SRC}/ 22 install -m 0755 *.cmake ${S}/${ESW_COMPONENT_SRC}/
23} 23}
diff --git a/meta-xilinx-standalone-experimental/recipes-drivers/ospipsv_git.bb b/meta-xilinx-standalone-experimental/recipes-drivers/ospipsv_git.bb
index cc71a89d..19cfe8ed 100644
--- a/meta-xilinx-standalone-experimental/recipes-drivers/ospipsv_git.bb
+++ b/meta-xilinx-standalone-experimental/recipes-drivers/ospipsv_git.bb
@@ -13,7 +13,7 @@ addtask do_generate_driver_data before do_configure after do_prepare_recipe_sysr
13do_prepare_recipe_sysroot[rdeptask] = "do_unpack" 13do_prepare_recipe_sysroot[rdeptask] = "do_unpack"
14 14
15do_configure:prepend() { 15do_configure:prepend() {
16 LOPPER_DTC_FLAGS="-b 0 -@" lopper.py ${DTS_FILE} -- baremetal_xparameters_xlnx.py ${ESW_MACHINE} ${S} 16 LOPPER_DTC_FLAGS="-b 0 -@" lopper ${DTS_FILE} -- baremetal_xparameters_xlnx.py ${ESW_MACHINE} ${S}
17 install -m 0755 xparameters.h ${S}/${ESW_COMPONENT_SRC}/ 17 install -m 0755 xparameters.h ${S}/${ESW_COMPONENT_SRC}/
18} 18}
19 19
diff --git a/meta-xilinx-standalone-experimental/recipes-drivers/uartlite_git.bb b/meta-xilinx-standalone-experimental/recipes-drivers/uartlite_git.bb
index 5d4e5a91..270ffb43 100644
--- a/meta-xilinx-standalone-experimental/recipes-drivers/uartlite_git.bb
+++ b/meta-xilinx-standalone-experimental/recipes-drivers/uartlite_git.bb
@@ -10,7 +10,7 @@ ESW_COMPONENT_SRC = "/XilinxProcessorIPLib/drivers/uartlite/src/"
10ESW_COMPONENT_NAME = "libuartlite.a" 10ESW_COMPONENT_NAME = "libuartlite.a"
11 11
12do_configure:prepend() { 12do_configure:prepend() {
13 LOPPER_DTC_FLAGS="-b 0 -@" lopper.py ${DTS_FILE} -- baremetalconfig_xlnx.py ${ESW_MACHINE} ${S}/${ESW_COMPONENT_SRC} stdin 13 LOPPER_DTC_FLAGS="-b 0 -@" lopper ${DTS_FILE} -- baremetalconfig_xlnx.py ${ESW_MACHINE} ${S}/${ESW_COMPONENT_SRC} stdin
14 install -m 0755 *.cmake ${S}/${ESW_COMPONENT_SRC} 14 install -m 0755 *.cmake ${S}/${ESW_COMPONENT_SRC}
15 install -m 0755 xuartlite_g.c ${S}/${ESW_COMPONENT_SRC} 15 install -m 0755 xuartlite_g.c ${S}/${ESW_COMPONENT_SRC}
16} 16}
diff --git a/meta-xilinx-standalone-experimental/recipes-drivers/uartns550_git.bb b/meta-xilinx-standalone-experimental/recipes-drivers/uartns550_git.bb
index a1c9b670..8e64457e 100644
--- a/meta-xilinx-standalone-experimental/recipes-drivers/uartns550_git.bb
+++ b/meta-xilinx-standalone-experimental/recipes-drivers/uartns550_git.bb
@@ -10,7 +10,7 @@ ESW_COMPONENT_SRC = "/XilinxProcessorIPLib/drivers/uartns550/src/"
10ESW_COMPONENT_NAME = "libuartns550.a" 10ESW_COMPONENT_NAME = "libuartns550.a"
11 11
12do_configure:prepend() { 12do_configure:prepend() {
13 LOPPER_DTC_FLAGS="-b 0 -@" lopper.py ${DTS_FILE} -- baremetalconfig_xlnx.py ${ESW_MACHINE} ${S}/${ESW_COMPONENT_SRC} stdin 13 LOPPER_DTC_FLAGS="-b 0 -@" lopper ${DTS_FILE} -- baremetalconfig_xlnx.py ${ESW_MACHINE} ${S}/${ESW_COMPONENT_SRC} stdin
14 install -m 0755 *.cmake ${S}/${ESW_COMPONENT_SRC} 14 install -m 0755 *.cmake ${S}/${ESW_COMPONENT_SRC}
15 install -m 0755 xuartns550_g.c ${S}/${ESW_COMPONENT_SRC} 15 install -m 0755 xuartns550_g.c ${S}/${ESW_COMPONENT_SRC}
16} 16}
diff --git a/meta-xilinx-standalone-experimental/recipes-drivers/uartps_git.bb b/meta-xilinx-standalone-experimental/recipes-drivers/uartps_git.bb
index 339450dd..c2247736 100644
--- a/meta-xilinx-standalone-experimental/recipes-drivers/uartps_git.bb
+++ b/meta-xilinx-standalone-experimental/recipes-drivers/uartps_git.bb
@@ -10,7 +10,7 @@ ESW_COMPONENT_SRC = "/XilinxProcessorIPLib/drivers/uartps/src/"
10ESW_COMPONENT_NAME = "libuartps.a" 10ESW_COMPONENT_NAME = "libuartps.a"
11 11
12do_configure:prepend() { 12do_configure:prepend() {
13 LOPPER_DTC_FLAGS="-b 0 -@" lopper.py ${DTS_FILE} -- baremetalconfig_xlnx.py ${ESW_MACHINE} ${S}/${ESW_COMPONENT_SRC} stdin 13 LOPPER_DTC_FLAGS="-b 0 -@" lopper ${DTS_FILE} -- baremetalconfig_xlnx.py ${ESW_MACHINE} ${S}/${ESW_COMPONENT_SRC} stdin
14 install -m 0755 *.cmake ${S}/${ESW_COMPONENT_SRC}/ 14 install -m 0755 *.cmake ${S}/${ESW_COMPONENT_SRC}/
15 install -m 0755 xuartps_g.c ${S}/${ESW_COMPONENT_SRC}/ 15 install -m 0755 xuartps_g.c ${S}/${ESW_COMPONENT_SRC}/
16} 16}
diff --git a/meta-xilinx-standalone-experimental/recipes-drivers/uartpsv_git.bb b/meta-xilinx-standalone-experimental/recipes-drivers/uartpsv_git.bb
index 1b285fd8..266f1db9 100644
--- a/meta-xilinx-standalone-experimental/recipes-drivers/uartpsv_git.bb
+++ b/meta-xilinx-standalone-experimental/recipes-drivers/uartpsv_git.bb
@@ -10,7 +10,7 @@ ESW_COMPONENT_SRC = "/XilinxProcessorIPLib/drivers/uartpsv/src/"
10ESW_COMPONENT_NAME = "libuartpsv.a" 10ESW_COMPONENT_NAME = "libuartpsv.a"
11 11
12do_configure:prepend() { 12do_configure:prepend() {
13 LOPPER_DTC_FLAGS="-b 0 -@" lopper.py ${DTS_FILE} -- baremetalconfig_xlnx.py ${ESW_MACHINE} ${S}/${ESW_COMPONENT_SRC} stdin 13 LOPPER_DTC_FLAGS="-b 0 -@" lopper ${DTS_FILE} -- baremetalconfig_xlnx.py ${ESW_MACHINE} ${S}/${ESW_COMPONENT_SRC} stdin
14 install -m 0755 *.cmake ${S}/${ESW_COMPONENT_SRC}/ 14 install -m 0755 *.cmake ${S}/${ESW_COMPONENT_SRC}/
15 install -m 0755 xuartpsv_g.c ${S}/${ESW_COMPONENT_SRC}/ 15 install -m 0755 xuartpsv_g.c ${S}/${ESW_COMPONENT_SRC}/
16} 16}
diff --git a/meta-xilinx-standalone-experimental/recipes-drivers/v-frmbuf-rd_git.bb b/meta-xilinx-standalone-experimental/recipes-drivers/v-frmbuf-rd_git.bb
index ee100489..da248701 100755
--- a/meta-xilinx-standalone-experimental/recipes-drivers/v-frmbuf-rd_git.bb
+++ b/meta-xilinx-standalone-experimental/recipes-drivers/v-frmbuf-rd_git.bb
@@ -10,7 +10,7 @@ ESW_COMPONENT_SRC = "/XilinxProcessorIPLib/drivers/v_frmbuf_rd/src/"
10ESW_COMPONENT_NAME = "libv_frmbuf_rd.a" 10ESW_COMPONENT_NAME = "libv_frmbuf_rd.a"
11 11
12do_configure:prepend() { 12do_configure:prepend() {
13 LOPPER_DTC_FLAGS="-b 0 -@" lopper.py ${DTS_FILE} -- baremetalconfig_xlnx.py ${ESW_MACHINE} ${S}/${ESW_COMPONENT_SRC} 13 LOPPER_DTC_FLAGS="-b 0 -@" lopper ${DTS_FILE} -- baremetalconfig_xlnx.py ${ESW_MACHINE} ${S}/${ESW_COMPONENT_SRC}
14 install -m 0755 *.cmake ${S}/${ESW_COMPONENT_SRC}/ 14 install -m 0755 *.cmake ${S}/${ESW_COMPONENT_SRC}/
15 install -m 0755 xv_frmbufrd_g.c ${S}/${ESW_COMPONENT_SRC}/ 15 install -m 0755 xv_frmbufrd_g.c ${S}/${ESW_COMPONENT_SRC}/
16} 16}
diff --git a/meta-xilinx-standalone-experimental/recipes-drivers/v-frmbuf-wr_git.bb b/meta-xilinx-standalone-experimental/recipes-drivers/v-frmbuf-wr_git.bb
index 7c4d1230..f2ec3b27 100755
--- a/meta-xilinx-standalone-experimental/recipes-drivers/v-frmbuf-wr_git.bb
+++ b/meta-xilinx-standalone-experimental/recipes-drivers/v-frmbuf-wr_git.bb
@@ -10,7 +10,7 @@ ESW_COMPONENT_SRC = "/XilinxProcessorIPLib/drivers/v_frmbuf_wr/src/"
10ESW_COMPONENT_NAME = "libv_frmbuf_wr.a" 10ESW_COMPONENT_NAME = "libv_frmbuf_wr.a"
11 11
12do_configure:prepend() { 12do_configure:prepend() {
13 LOPPER_DTC_FLAGS="-b 0 -@" lopper.py ${DTS_FILE} -- baremetalconfig_xlnx.py ${ESW_MACHINE} ${S}/${ESW_COMPONENT_SRC} 13 LOPPER_DTC_FLAGS="-b 0 -@" lopper ${DTS_FILE} -- baremetalconfig_xlnx.py ${ESW_MACHINE} ${S}/${ESW_COMPONENT_SRC}
14 install -m 0755 *.cmake ${S}/${ESW_COMPONENT_SRC}/ 14 install -m 0755 *.cmake ${S}/${ESW_COMPONENT_SRC}/
15 install -m 0755 xv_frmbufwr_g.c ${S}/${ESW_COMPONENT_SRC}/ 15 install -m 0755 xv_frmbufwr_g.c ${S}/${ESW_COMPONENT_SRC}/
16} 16}