summaryrefslogtreecommitdiffstats
path: root/meta-xilinx-standalone-experimental/recipes-drivers
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@amd.com>2023-05-24 10:32:39 -0600
committerMark Hatle <mark.hatle@amd.com>2023-05-24 17:37:38 -0500
commita0ff9b1f276979e2b6127828235d02aa873eff60 (patch)
tree8d455d9ff1f3f01d161191a92c1ec7237b267d03 /meta-xilinx-standalone-experimental/recipes-drivers
parenta174f1216b601d84245fbb99468edd7ef1c7071c (diff)
downloadmeta-xilinx-a0ff9b1f276979e2b6127828235d02aa873eff60.tar.gz
meta-xilinx-standalone-experimental: dmaps: Update recipe to fix dependency loop
The recipe has not been updated since originally created. This was triggering a dependency loop since it has not been updated to the current format. Signed-off-by: Mark Hatle <mark.hatle@amd.com>
Diffstat (limited to 'meta-xilinx-standalone-experimental/recipes-drivers')
-rw-r--r--meta-xilinx-standalone-experimental/recipes-drivers/dmaps_git.bb19
1 files changed, 17 insertions, 2 deletions
diff --git a/meta-xilinx-standalone-experimental/recipes-drivers/dmaps_git.bb b/meta-xilinx-standalone-experimental/recipes-drivers/dmaps_git.bb
index 0891fb86..1dcd8404 100644
--- a/meta-xilinx-standalone-experimental/recipes-drivers/dmaps_git.bb
+++ b/meta-xilinx-standalone-experimental/recipes-drivers/dmaps_git.bb
@@ -1,3 +1,18 @@
1inherit esw_examples 1inherit features_check
2 2
3ESW_COMPONENT_SRC = "/XilinxProcessorIPLib/drivers/dmaps/examples/" 3REQUIRED_MACHINE_FEATURES = "dmaps"
4
5inherit esw python3native
6
7DEPENDS += "xilstandalone "
8
9ESW_COMPONENT_SRC = "/XilinxProcessorIPLib/drivers/dmaps/src/"
10ESW_COMPONENT_NAME = "libdmaps.a"
11
12addtask do_generate_driver_data before do_configure after do_prepare_recipe_sysroot
13do_prepare_recipe_sysroot[rdeptask] = "do_unpack"
14
15do_configure:prepend() {
16 LOPPER_DTC_FLAGS="-b 0 -@" lopper ${DTS_FILE} -- baremetal_xparameters_xlnx.py ${ESW_MACHINE} ${S}
17 install -m 0755 xparameters.h ${S}/${ESW_COMPONENT_SRC}/
18}