summaryrefslogtreecommitdiffstats
path: root/meta-xilinx-standalone-experimental/recipes-drivers
diff options
context:
space:
mode:
authorAppana Durga Kedareswara rao <appana.durga.rao@xilinx.com>2021-03-23 13:07:59 +0530
committerSai Hari Chandana Kalluri <chandana.kalluri@xilinx.com>2021-09-27 21:32:02 -0700
commit93a6abca0de42e7e5078e4a38a35915d531ff297 (patch)
tree0bff4d4e0b7f760feb5740441c2e1e2516ad30ee /meta-xilinx-standalone-experimental/recipes-drivers
parentcfb9d64b8494a62b635b831e0201dbbe173434c9 (diff)
downloadmeta-xilinx-93a6abca0de42e7e5078e4a38a35915d531ff297.tar.gz
recipe-drivers: v-frmbuf-wr: Add recipe for compiling v-frmbuf-wr driver
This recipe compiles the v-frmbuf-wr driver. Signed-off-by: Appana Durga Kedareswara rao <appana.durga.rao@xilinx.com>
Diffstat (limited to 'meta-xilinx-standalone-experimental/recipes-drivers')
-rwxr-xr-xmeta-xilinx-standalone-experimental/recipes-drivers/v-frmbuf-wr_git.bb13
1 files changed, 13 insertions, 0 deletions
diff --git a/meta-xilinx-standalone-experimental/recipes-drivers/v-frmbuf-wr_git.bb b/meta-xilinx-standalone-experimental/recipes-drivers/v-frmbuf-wr_git.bb
new file mode 100755
index 00000000..5c509b9a
--- /dev/null
+++ b/meta-xilinx-standalone-experimental/recipes-drivers/v-frmbuf-wr_git.bb
@@ -0,0 +1,13 @@
1inherit distro_features_check
2
3REQUIRED_DISTRO_FEATURES = "v-frmbuf-wr"
4
5inherit esw python3native
6
7DEPENDS += "python3-pyyaml-native xilstandalone lopper python3-dtc-native video-common"
8
9ESW_COMPONENT_SRC = "/XilinxProcessorIPLib/drivers/v_frmbuf_wr/src/"
10ESW_COMPONENT_NAME = "libv_frmbuf_wr.a"
11
12addtask do_generate_driver_data before do_configure after do_prepare_recipe_sysroot
13do_prepare_recipe_sysroot[rdeptask] = "do_unpack"