summaryrefslogtreecommitdiffstats
path: root/meta-xilinx-standalone-experimental/recipes-drivers
diff options
context:
space:
mode:
authorAppana Durga Kedareswara rao <appana.durga.rao@xilinx.com>2021-03-23 13:06:51 +0530
committerSai Hari Chandana Kalluri <chandana.kalluri@xilinx.com>2021-09-27 21:31:05 -0700
commit53c796c60e28c4c53889e1882c56f934e069f44b (patch)
treeae0ee26b7adf3b598caccd83ade9542f96cf8ba3 /meta-xilinx-standalone-experimental/recipes-drivers
parent92984d63825ce490f2734127fadab4122905fcb4 (diff)
downloadmeta-xilinx-53c796c60e28c4c53889e1882c56f934e069f44b.tar.gz
recipe-drivers: v-frmbuf-rd: Add recipe for compiling v-frmbuf-rd driver
This recipe compiles the v-frmbuf-rd driver. Signed-off-by: Appana Durga Kedareswara rao <appana.durga.rao@xilinx.com>
Diffstat (limited to 'meta-xilinx-standalone-experimental/recipes-drivers')
-rwxr-xr-xmeta-xilinx-standalone-experimental/recipes-drivers/v-frmbuf-rd_git.bb13
1 files changed, 13 insertions, 0 deletions
diff --git a/meta-xilinx-standalone-experimental/recipes-drivers/v-frmbuf-rd_git.bb b/meta-xilinx-standalone-experimental/recipes-drivers/v-frmbuf-rd_git.bb
new file mode 100755
index 00000000..fabcc62c
--- /dev/null
+++ b/meta-xilinx-standalone-experimental/recipes-drivers/v-frmbuf-rd_git.bb
@@ -0,0 +1,13 @@
1inherit distro_features_check
2
3REQUIRED_DISTRO_FEATURES = "v-frmbuf-rd"
4
5inherit esw python3native
6
7DEPENDS += "python3-pyyaml-native xilstandalone lopper python3-dtc-native video-common"
8
9ESW_COMPONENT_SRC = "/XilinxProcessorIPLib/drivers/v_frmbuf_rd/src/"
10ESW_COMPONENT_NAME = "libv_frmbuf_rd.a"
11
12addtask do_generate_driver_data before do_configure after do_prepare_recipe_sysroot
13do_prepare_recipe_sysroot[rdeptask] = "do_unpack"