summaryrefslogtreecommitdiffstats
path: root/meta-xilinx-standalone-experimental/recipes-drivers
diff options
context:
space:
mode:
authorMark Hatle <mhatle@xilinx.com>2022-06-08 17:49:49 -0700
committerMark Hatle <mhatle@xilinx.com>2022-06-13 14:17:24 -0700
commit4ce6c2ba61edf64aa3c2b5fca1a2c7ecd003634e (patch)
treed48bf91cccb566ff9f9729dbd74d1ee07cc30753 /meta-xilinx-standalone-experimental/recipes-drivers
parent2f050ece6eda05417e569402b36968a8361d7cd0 (diff)
downloadmeta-xilinx-4ce6c2ba61edf64aa3c2b5fca1a2c7ecd003634e.tar.gz
meta-xilinx-standalone-experimental: Wrap do_configure:prepend
The do_configure prepend steps need to run in the 'S' directory, so wrap the operations to prevent them from changing the working directory for the rest of the do_configure operations. Signed-off-by: Mark Hatle <mhatle@xilinx.com> (cherry picked from commit 7c5519b8b1dc782fd0fa50ac426094f9225de80a) Signed-off-by: Mark Hatle <mhatle@xilinx.com>
Diffstat (limited to 'meta-xilinx-standalone-experimental/recipes-drivers')
-rw-r--r--meta-xilinx-standalone-experimental/recipes-drivers/clockps-example_git.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-xilinx-standalone-experimental/recipes-drivers/clockps-example_git.bb b/meta-xilinx-standalone-experimental/recipes-drivers/clockps-example_git.bb
index 97871326..67fb695e 100644
--- a/meta-xilinx-standalone-experimental/recipes-drivers/clockps-example_git.bb
+++ b/meta-xilinx-standalone-experimental/recipes-drivers/clockps-example_git.bb
@@ -9,10 +9,12 @@ DEPENDS += "libxil xiltimer resetps"
9inherit python3native 9inherit python3native
10 10
11do_configure:prepend() { 11do_configure:prepend() {
12 (
12 cd ${S} 13 cd ${S}
13 lopper ${DTS_FILE} -- baremetallinker_xlnx.py ${ESW_MACHINE} ${S}/${ESW_COMPONENT_SRC} 14 lopper ${DTS_FILE} -- baremetallinker_xlnx.py ${ESW_MACHINE} ${S}/${ESW_COMPONENT_SRC}
14 install -m 0755 memory.ld ${S}/${ESW_COMPONENT_SRC}/ 15 install -m 0755 memory.ld ${S}/${ESW_COMPONENT_SRC}/
15 install -m 0755 *.cmake ${S}/${ESW_COMPONENT_SRC}/ 16 install -m 0755 *.cmake ${S}/${ESW_COMPONENT_SRC}/
17 )
16} 18}
17 19
18CLOCKPS_EX_IMAGE_NAME ??= "${BPN}" 20CLOCKPS_EX_IMAGE_NAME ??= "${BPN}"