diff options
author | Mark Hatle <mark.hatle@xilinx.com> | 2021-06-07 21:19:58 -0700 |
---|---|---|
committer | Sai Hari Chandana Kalluri <chandana.kalluri@xilinx.com> | 2021-09-27 21:34:01 -0700 |
commit | fd4359c8b1604745b1dbf28376fad13666e53d7d (patch) | |
tree | f21f42ed137c7bdc4bd6ee9cf7ae281947699c02 /meta-xilinx-standalone-experimental/recipes-bsp | |
parent | f24875a30fd675ea34ea045f696bbfac1b680103 (diff) | |
download | meta-xilinx-fd4359c8b1604745b1dbf28376fad13666e53d7d.tar.gz |
fsbl-firmware: Update to match current configuration
The fsbl has been renamed to fsbl-firmware, and some adjustments to the
build method are required to match how standalone and xsct version work.
Signed-off-by: Mark Hatle <mark.hatle@xilinx.com>
Diffstat (limited to 'meta-xilinx-standalone-experimental/recipes-bsp')
-rw-r--r-- | meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/fsbl-firmware_git.bbappend | 47 |
1 files changed, 47 insertions, 0 deletions
diff --git a/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/fsbl-firmware_git.bbappend b/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/fsbl-firmware_git.bbappend new file mode 100644 index 00000000..a50ea86c --- /dev/null +++ b/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/fsbl-firmware_git.bbappend | |||
@@ -0,0 +1,47 @@ | |||
1 | # We WANT to default to this version when available | ||
2 | DEFAULT_PREFERENCE = "100" | ||
3 | |||
4 | # Reset this | ||
5 | SRC_URI = "${EMBEDDEDSW_SRCURI}" | ||
6 | |||
7 | inherit esw | ||
8 | |||
9 | # Not compatible with Zynq | ||
10 | COMPATIBLE_MACHINE_zynq = "none" | ||
11 | |||
12 | ESW_COMPONENT_SRC = "/lib/sw_apps/undefined/src" | ||
13 | ESW_COMPONENT_SRC_zynq = "/lib/sw_apps/zynq_fsbl/src" | ||
14 | ESW_COMPONENT_SRC_zynqmp = "/lib/sw_apps/zynqmp_fsbl/src" | ||
15 | |||
16 | DEPENDS += "xilstandalone xiltimer xilffs xilsecure xilpm" | ||
17 | |||
18 | do_copy_psu_init[depends] += "device-tree-lops:do_deploy" | ||
19 | python do_copy_psu_init() { | ||
20 | import glob, subprocess, os | ||
21 | |||
22 | system_dt = d.getVar('SYSTEM_DTFILE') | ||
23 | src_dir = glob.glob(d.getVar('OECMAKE_SOURCEPATH')) | ||
24 | psu_init_src = os.path.dirname(system_dt) | ||
25 | src_file = psu_init_src + str("/psu_init.c") | ||
26 | hdr_file = psu_init_src + str("/psu_init.h") | ||
27 | if os.path.exists(src_file): | ||
28 | command = ["install"] + ["-m"] + ["0755"] + [src_file] + [src_dir[0]] | ||
29 | subprocess.run(command, check = True) | ||
30 | command = ["install"] + ["-m"] + ["0755"] + [hdr_file] + [src_dir[0]] | ||
31 | subprocess.run(command, check = True) | ||
32 | } | ||
33 | addtask do_copy_psu_init before do_configure after do_prepare_recipe_sysroot | ||
34 | do_prepare_recipe_sysroot[rdeptask] = "do_unpack" | ||
35 | |||
36 | do_install() { | ||
37 | : | ||
38 | } | ||
39 | |||
40 | addtask deploy before do_build after do_package | ||
41 | |||
42 | ESW_COMPONENT = "undefined" | ||
43 | ESW_COMPONENT_zynq = "zynq_fsbl.elf" | ||
44 | ESW_COMPONENT_zynqmp = "zynqmp_fsbl.elf" | ||
45 | |||
46 | CFLAGS_append_aarch64 = " -DARMA53_64" | ||
47 | CFLAGS_append_armrm = " -DARMR5" | ||