summaryrefslogtreecommitdiffstats
path: root/meta-xilinx-standalone-experimental/recipes-bsp
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@xilinx.com>2021-06-07 21:19:58 -0700
committerSai Hari Chandana Kalluri <chandana.kalluri@xilinx.com>2021-09-27 21:34:01 -0700
commitfd4359c8b1604745b1dbf28376fad13666e53d7d (patch)
treef21f42ed137c7bdc4bd6ee9cf7ae281947699c02 /meta-xilinx-standalone-experimental/recipes-bsp
parentf24875a30fd675ea34ea045f696bbfac1b680103 (diff)
downloadmeta-xilinx-fd4359c8b1604745b1dbf28376fad13666e53d7d.tar.gz
fsbl-firmware: Update to match current configuration
The fsbl has been renamed to fsbl-firmware, and some adjustments to the build method are required to match how standalone and xsct version work. Signed-off-by: Mark Hatle <mark.hatle@xilinx.com>
Diffstat (limited to 'meta-xilinx-standalone-experimental/recipes-bsp')
-rw-r--r--meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/fsbl-firmware_git.bbappend47
1 files changed, 47 insertions, 0 deletions
diff --git a/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/fsbl-firmware_git.bbappend b/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/fsbl-firmware_git.bbappend
new file mode 100644
index 00000000..a50ea86c
--- /dev/null
+++ b/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/fsbl-firmware_git.bbappend
@@ -0,0 +1,47 @@
1# We WANT to default to this version when available
2DEFAULT_PREFERENCE = "100"
3
4# Reset this
5SRC_URI = "${EMBEDDEDSW_SRCURI}"
6
7inherit esw
8
9# Not compatible with Zynq
10COMPATIBLE_MACHINE_zynq = "none"
11
12ESW_COMPONENT_SRC = "/lib/sw_apps/undefined/src"
13ESW_COMPONENT_SRC_zynq = "/lib/sw_apps/zynq_fsbl/src"
14ESW_COMPONENT_SRC_zynqmp = "/lib/sw_apps/zynqmp_fsbl/src"
15
16DEPENDS += "xilstandalone xiltimer xilffs xilsecure xilpm"
17
18do_copy_psu_init[depends] += "device-tree-lops:do_deploy"
19python do_copy_psu_init() {
20 import glob, subprocess, os
21
22 system_dt = d.getVar('SYSTEM_DTFILE')
23 src_dir = glob.glob(d.getVar('OECMAKE_SOURCEPATH'))
24 psu_init_src = os.path.dirname(system_dt)
25 src_file = psu_init_src + str("/psu_init.c")
26 hdr_file = psu_init_src + str("/psu_init.h")
27 if os.path.exists(src_file):
28 command = ["install"] + ["-m"] + ["0755"] + [src_file] + [src_dir[0]]
29 subprocess.run(command, check = True)
30 command = ["install"] + ["-m"] + ["0755"] + [hdr_file] + [src_dir[0]]
31 subprocess.run(command, check = True)
32}
33addtask do_copy_psu_init before do_configure after do_prepare_recipe_sysroot
34do_prepare_recipe_sysroot[rdeptask] = "do_unpack"
35
36do_install() {
37 :
38}
39
40addtask deploy before do_build after do_package
41
42ESW_COMPONENT = "undefined"
43ESW_COMPONENT_zynq = "zynq_fsbl.elf"
44ESW_COMPONENT_zynqmp = "zynqmp_fsbl.elf"
45
46CFLAGS_append_aarch64 = " -DARMA53_64"
47CFLAGS_append_armrm = " -DARMR5"