summaryrefslogtreecommitdiffstats
path: root/meta-xilinx-standalone-experimental/recipes-bsp
diff options
context:
space:
mode:
authorAppana Durga Kedareswara rao <appana.durga.kedareswara.rao@amd.com>2023-03-02 12:56:21 +0530
committerMark Hatle <mark.hatle@amd.com>2023-03-03 10:44:14 -0600
commitdb506ddde2e220bcb26b4353377e0362333a5436 (patch)
treecedc82acb07e62471f7b35676bd731a319eb17ce /meta-xilinx-standalone-experimental/recipes-bsp
parentd358ec8b093af181a415f073f7991568605660c5 (diff)
downloadmeta-xilinx-db506ddde2e220bcb26b4353377e0362333a5436.tar.gz
meta-xilinx-standalone-experimental: Copy UserConfig.cmake file to application source directory
With the latest changes in the application CMakeLists.txt it's expecting the UserConfig.cmake file to be present at application source folder, update recipes for the same. Signed-off-by: Appana Durga Kedareswara rao <appana.durga.kedareswara.rao@amd.com> Signed-off-by: Mark Hatle <mark.hatle@amd.com>
Diffstat (limited to 'meta-xilinx-standalone-experimental/recipes-bsp')
-rw-r--r--meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/fsbl-firmware_git.bbappend1
-rw-r--r--meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/plm-firmware_git.bbappend7
-rw-r--r--meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/pmu-firmware_git.bbappend8
-rw-r--r--meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/psm-firmware_git.bbappend7
4 files changed, 23 insertions, 0 deletions
diff --git a/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/fsbl-firmware_git.bbappend b/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/fsbl-firmware_git.bbappend
index 43dcc106..d40f3cdb 100644
--- a/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/fsbl-firmware_git.bbappend
+++ b/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/fsbl-firmware_git.bbappend
@@ -49,6 +49,7 @@ do_configure:prepend() {
49 else 49 else
50 bbwarn "Using the default psu_init.h, this may not work correctly." 50 bbwarn "Using the default psu_init.h, this may not work correctly."
51 fi 51 fi
52 install -m 0644 ${S}/cmake/UserConfig.cmake ${S}/${ESW_COMPONENT_SRC}
52} 53}
53 54
54do_install() { 55do_install() {
diff --git a/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/plm-firmware_git.bbappend b/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/plm-firmware_git.bbappend
index 8a72a184..cc6d757f 100644
--- a/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/plm-firmware_git.bbappend
+++ b/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/plm-firmware_git.bbappend
@@ -10,6 +10,13 @@ ESW_COMPONENT_SRC = "/lib/sw_apps/versal_plm/src/"
10 10
11ESW_COMPONENT = "versal_plm.elf" 11ESW_COMPONENT = "versal_plm.elf"
12 12
13do_configure:prepend() {
14 (
15 cd ${S}
16 install -m 0644 ${S}/cmake/UserConfig.cmake ${S}/${ESW_COMPONENT_SRC}
17 )
18}
19
13do_compile:append() { 20do_compile:append() {
14 ${MB_OBJCOPY} -O binary ${B}/${ESW_COMPONENT} ${B}/${ESW_COMPONENT}.bin 21 ${MB_OBJCOPY} -O binary ${B}/${ESW_COMPONENT} ${B}/${ESW_COMPONENT}.bin
15} 22}
diff --git a/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/pmu-firmware_git.bbappend b/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/pmu-firmware_git.bbappend
index d786a5ff..b5908d46 100644
--- a/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/pmu-firmware_git.bbappend
+++ b/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/pmu-firmware_git.bbappend
@@ -10,6 +10,14 @@ ESW_COMPONENT_SRC = "/lib/sw_apps/zynqmp_pmufw/src"
10 10
11ESW_COMPONENT = "zynqmp_pmufw.elf" 11ESW_COMPONENT = "zynqmp_pmufw.elf"
12 12
13
14do_configure:prepend() {
15 (
16 cd ${S}
17 install -m 0644 ${S}/cmake/UserConfig.cmake ${S}/${ESW_COMPONENT_SRC}
18 )
19}
20
13do_compile:append() { 21do_compile:append() {
14 ${MB_OBJCOPY} -O binary ${B}/${ESW_COMPONENT} ${B}/${ESW_COMPONENT}.bin 22 ${MB_OBJCOPY} -O binary ${B}/${ESW_COMPONENT} ${B}/${ESW_COMPONENT}.bin
15} 23}
diff --git a/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/psm-firmware_git.bbappend b/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/psm-firmware_git.bbappend
index 9b3d6475..c4953ce7 100644
--- a/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/psm-firmware_git.bbappend
+++ b/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/psm-firmware_git.bbappend
@@ -10,6 +10,13 @@ ESW_COMPONENT_SRC = "/lib/sw_apps/versal_psmfw/src/"
10 10
11ESW_COMPONENT = "versal_psmfw.elf" 11ESW_COMPONENT = "versal_psmfw.elf"
12 12
13do_configure:prepend() {
14 (
15 cd ${S}
16 install -m 0644 ${S}/cmake/UserConfig.cmake ${S}/${ESW_COMPONENT_SRC}
17 )
18}
19
13do_compile:append() { 20do_compile:append() {
14 ${MB_OBJCOPY} -O binary ${B}/${ESW_COMPONENT} ${B}/${ESW_COMPONENT}.bin 21 ${MB_OBJCOPY} -O binary ${B}/${ESW_COMPONENT} ${B}/${ESW_COMPONENT}.bin
15} 22}