summaryrefslogtreecommitdiffstats
path: root/meta-xilinx-standalone-experimental/recipes-bsp
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@xilinx.com>2021-09-13 12:48:40 -0700
committerSai Hari Chandana Kalluri <chandana.kalluri@xilinx.com>2021-09-28 08:20:16 -0700
commitd1f455cfd8b502a069858b51771bb36c8fbb122a (patch)
tree998f74983fd0891009716bad9d39ccfa085d5139 /meta-xilinx-standalone-experimental/recipes-bsp
parentaba5951e6fb6ddfc37075eb65eafacb54a7b9c3e (diff)
downloadmeta-xilinx-d1f455cfd8b502a069858b51771bb36c8fbb122a.tar.gz
meta-xilinx-standalone-experimental: Move from device-tree-lops to device-tree
The device trees are now generated by the user as part of the configuration steps. As such, we need to simply copy/process these device trees as part of the system build so adjust the various usages to the new variable CONFIG_DTFILE, which is a full path reference to the device tree for a particular configuration. Signed-off-by: Mark Hatle <mark.hatle@xilinx.com>
Diffstat (limited to 'meta-xilinx-standalone-experimental/recipes-bsp')
-rw-r--r--meta-xilinx-standalone-experimental/recipes-bsp/device-tree/device-tree.bbappend13
-rw-r--r--meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/fsbl-firmware_git.bbappend2
2 files changed, 14 insertions, 1 deletions
diff --git a/meta-xilinx-standalone-experimental/recipes-bsp/device-tree/device-tree.bbappend b/meta-xilinx-standalone-experimental/recipes-bsp/device-tree/device-tree.bbappend
new file mode 100644
index 00000000..6aadcb48
--- /dev/null
+++ b/meta-xilinx-standalone-experimental/recipes-bsp/device-tree/device-tree.bbappend
@@ -0,0 +1,13 @@
1CONFIG_DTFILE ?= ""
2
3do_install_append_xilinx-standalone() {
4 for DTB_FILE in ${CONFIG_DTFILE}; do
5 install -Dm 0644 ${DTB_FILE} ${D}/boot/devicetree/$(basename ${DTB_FILE})
6 done
7}
8
9do_deploy_append_xilinx-standalone() {
10 for DTB_FILE in ${CONFIG_DTFILE}; do
11 install -Dm 0644 ${DTB_FILE} ${DEPLOYDIR}/devicetree/$(basename ${DTB_FILE})
12 done
13}
diff --git a/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/fsbl-firmware_git.bbappend b/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/fsbl-firmware_git.bbappend
index a50ea86c..d241df32 100644
--- a/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/fsbl-firmware_git.bbappend
+++ b/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/fsbl-firmware_git.bbappend
@@ -15,7 +15,7 @@ ESW_COMPONENT_SRC_zynqmp = "/lib/sw_apps/zynqmp_fsbl/src"
15 15
16DEPENDS += "xilstandalone xiltimer xilffs xilsecure xilpm" 16DEPENDS += "xilstandalone xiltimer xilffs xilsecure xilpm"
17 17
18do_copy_psu_init[depends] += "device-tree-lops:do_deploy" 18do_copy_psu_init[depends] += "device-tree:do_deploy"
19python do_copy_psu_init() { 19python do_copy_psu_init() {
20 import glob, subprocess, os 20 import glob, subprocess, os
21 21