summaryrefslogtreecommitdiffstats
path: root/meta-xilinx-standalone-experimental/recipes-bsp
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@amd.com>2023-10-12 20:11:17 -0600
committerMark Hatle <mark.hatle@amd.com>2023-10-15 08:13:22 -0600
commit8099d7115acdef832fb2a4db731d3bbce563a2e3 (patch)
treec0e83b55e6aac2f21ec433507f3eafdb39e3cf91 /meta-xilinx-standalone-experimental/recipes-bsp
parent1a2cb511ff20c9de24e973df3b556febb9659df4 (diff)
downloadmeta-xilinx-8099d7115acdef832fb2a4db731d3bbce563a2e3.tar.gz
esw-conf: Move to embeddedsw and use BBCLASSEXTEND
Make sure that we have native and nativesdk versions of esw-conf. Add a dependency on lopper and xilinx-lops, as presumably users of this recipe will need to use lopper to process the configurations. This will allow someone to use oe-run-native with esw-conf-native to use lopper to transform system to domain specific device trees and their associated configurations. Signed-off-by: Mark Hatle <mark.hatle@amd.com>
Diffstat (limited to 'meta-xilinx-standalone-experimental/recipes-bsp')
-rw-r--r--meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/esw-conf_git.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/esw-conf_git.bb b/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/esw-conf_git.bb
new file mode 100644
index 00000000..e6cf1d8b
--- /dev/null
+++ b/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/esw-conf_git.bb
@@ -0,0 +1,34 @@
1# Can't depend on esw since this is needed for setup!
2inherit xlnx-embeddedsw
3
4# We need to override the inherit
5require conf/dtb-embeddedsw.inc
6
7S = "${WORKDIR}/git"
8B = "${WORKDIR}/build"
9
10INHIBIT_DEFAULT_DEPS = "1"
11
12# Installing this recipe should install the lopper tools and such
13DEPENDS = "lopper xilinx-lops"
14
15COMPATIBLE_HOST:forcevariable = ".*"
16
17ESW_COMPONENT_SRC = "/XilinxProcessorIPLib/drivers/"
18
19do_configure[noexec] = '1'
20do_compile[noexec] = '1'
21
22do_install() {
23 # The configuration step requires only the yaml files, make them
24 # available to the SDK
25 cd ${S}${ESW_COMPONENT_SRC}
26 for each in `find . -name *.yaml` ; do
27 mkdir -p $(dirname ${D}/${datadir}/embeddedsw${ESW_COMPONENT_SRC}$each)
28 install -m 0644 $each ${D}/${datadir}/embeddedsw${ESW_COMPONENT_SRC}$each
29 done
30}
31
32FILES:${PN} += "${datadir}/embeddedsw"
33
34BBCLASSEXTEND = "native nativesdk"