summaryrefslogtreecommitdiffstats
path: root/meta-xilinx-standalone-experimental/recipes-bsp
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@xilinx.com>2022-04-01 10:16:52 -0700
committerMark Hatle <mark.hatle@kernel.crashing.org>2022-07-23 15:59:49 -0500
commit763e678b45734b3eaf00f55fbb236112360bc816 (patch)
tree1931788f5bfac43e108cef3acdf46eb3a4fd995d /meta-xilinx-standalone-experimental/recipes-bsp
parent868d4704c5eac5f37557062c5f51d00a3e3186a2 (diff)
downloadmeta-xilinx-763e678b45734b3eaf00f55fbb236112360bc816.tar.gz
meta-xilinx-standalone-experimental: recipes-bsp: embeddedsw: fsbl-firmware: properly copy the psu_init* files
The files are copied into ${WORKDIR} and need to be made available to be used by the sources. Signed-off-by: Mark Hatle <mark.hatle@xilinx.com> (cherry picked from commit eb060e678f792000872dbf9b32fa9b5686f3a127) Signed-off-by: Mark Hatle <mhatle@xilinx.com>
Diffstat (limited to 'meta-xilinx-standalone-experimental/recipes-bsp')
-rw-r--r--meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/fsbl-firmware_git.bbappend10
1 files changed, 10 insertions, 0 deletions
diff --git a/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/fsbl-firmware_git.bbappend b/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/fsbl-firmware_git.bbappend
index 056ad990..439f47f4 100644
--- a/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/fsbl-firmware_git.bbappend
+++ b/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/fsbl-firmware_git.bbappend
@@ -33,6 +33,16 @@ python() {
33 bb.warn("Unable to find %s, using default version" % psu_init_h) 33 bb.warn("Unable to find %s, using default version" % psu_init_h)
34} 34}
35 35
36do_compile:prepend() {
37 if [ -e ${WORKDIR}/psu_init.c ]; then
38 install -m 0644 ${WORKDIR}/psu_init.c ${S}/${ESW_COMPONENT_SRC}
39 fi
40
41 if [ -e ${WORKDIR}/psu_init.h ]; then
42 install -m 0644 ${WORKDIR}/psu_init.h ${S}/${ESW_COMPONENT_SRC}
43 fi
44}
45
36do_install() { 46do_install() {
37 : 47 :
38} 48}