summaryrefslogtreecommitdiffstats
path: root/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/pmu-firmware_git.bbappend
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@xilinx.com>2021-03-16 13:11:46 -0700
committerSai Hari Chandana Kalluri <chandana.kalluri@xilinx.com>2021-09-27 21:30:10 -0700
commit58c8191477d70802bf0a88180a0f731f8179731f (patch)
tree2ad028a94bd5bd236d6c0d6725597bd53ff719b9 /meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/pmu-firmware_git.bbappend
parent425f0647a717ea1e94744711881075c5229e2c9d (diff)
downloadmeta-xilinx-58c8191477d70802bf0a88180a0f731f8179731f.tar.gz
Move from plm/pmu/psm .bb to .bbappend files
Use the mechanisms already in place from meta-xilinx-standalone to config and build the three core firmware pieces. This unifies the standalone, xsct, and experimental versions. Signed-off-by: Mark Hatle <mark.hatle@xilinx.com>
Diffstat (limited to 'meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/pmu-firmware_git.bbappend')
-rw-r--r--meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/pmu-firmware_git.bbappend20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/pmu-firmware_git.bbappend b/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/pmu-firmware_git.bbappend
new file mode 100644
index 00000000..086689f0
--- /dev/null
+++ b/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/pmu-firmware_git.bbappend
@@ -0,0 +1,20 @@
1# Reset this
2SRC_URI = "${EMBEDDEDSW_SRCURI}"
3SRC_URI += "file://0001-zynqmp_pmufw-Fix-reset-ops-for-assert.patch"
4SRC_URI += "file://0001-zynqmp_pmufw-Correct-structure-header-of-PmResetOps.patch"
5
6inherit esw
7
8ESW_COMPONENT_SRC = "/lib/sw_apps/zynqmp_pmufw/src"
9
10ESW_COMPONENT = "pmufw.elf"
11
12do_compile() {
13 ${MB_OBJCOPY} -O binary ${B}/${ESW_COMPONENT} ${B}/executable.bin
14}
15
16do_install() {
17 :
18}
19
20DEPENDS += "xilstandalone xiltimer xilfpga xilskey"