summaryrefslogtreecommitdiffstats
path: root/meta-xilinx-standalone-experimental/recipes-applications
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@xilinx.com>2021-03-16 13:09:26 -0700
committerSai Hari Chandana Kalluri <chandana.kalluri@xilinx.com>2021-09-27 21:30:10 -0700
commit425f0647a717ea1e94744711881075c5229e2c9d (patch)
treec39cfeea867c8a925b0d971edd90b570be5ce8d4 /meta-xilinx-standalone-experimental/recipes-applications
parentae0615d61ba321acb179004837b1c86d711d9f7e (diff)
downloadmeta-xilinx-425f0647a717ea1e94744711881075c5229e2c9d.tar.gz
Move experimental plm/pmu/psm to match standalone recipe names
Signed-off-by: Mark Hatle <mark.hatle@xilinx.com>
Diffstat (limited to 'meta-xilinx-standalone-experimental/recipes-applications')
-rw-r--r--meta-xilinx-standalone-experimental/recipes-applications/pmufw/pmufw_git.bb30
1 files changed, 0 insertions, 30 deletions
diff --git a/meta-xilinx-standalone-experimental/recipes-applications/pmufw/pmufw_git.bb b/meta-xilinx-standalone-experimental/recipes-applications/pmufw/pmufw_git.bb
deleted file mode 100644
index 19238f97..00000000
--- a/meta-xilinx-standalone-experimental/recipes-applications/pmufw/pmufw_git.bb
+++ /dev/null
@@ -1,30 +0,0 @@
1inherit esw deploy
2
3COMPATIBLE_MACHINE = "microblaze-pmu"
4
5ESW_COMPONENT_SRC = "/lib/sw_apps/zynqmp_pmufw/src"
6
7DEPENDS += "xilstandalone xiltimer xilfpga xilskey"
8
9do_install() {
10 install -d ${D}/${base_libdir}/firmware
11 # Note that we have to make the ELF executable for it to be stripped
12 install -m 0755 ${B}/pmufw* ${D}/${base_libdir}/firmware
13}
14
15PMU_FIRMWARE_BASE_NAME ?= "${BPN}-${PKGE}-${PKGV}-${PKGR}-${MACHINE}-${DATETIME}"
16PMU_FIRMWARE_BASE_NAME[vardepsexclude] = "DATETIME"
17
18do_deploy() {
19
20 # We need to deploy the stripped elf, hence why not doing it from ${D}
21 install -Dm 0644 ${WORKDIR}/package/${base_libdir}/firmware/pmufw.elf ${DEPLOYDIR}/${PMU_FIRMWARE_BASE_NAME}.elf
22 ln -sf ${PMU_FIRMWARE_BASE_NAME}.elf ${DEPLOYDIR}/${BPN}-${MACHINE}.elf
23 ${OBJCOPY} -O binary ${WORKDIR}/package/${base_libdir}/firmware/pmufw.elf ${WORKDIR}/package/${base_libdir}/firmware/pmufw.bin
24 install -m 0644 ${WORKDIR}/package/${base_libdir}/firmware/pmufw.bin ${DEPLOYDIR}/${PMU_FIRMWARE_BASE_NAME}.bin
25 ln -sf ${PMU_FIRMWARE_BASE_NAME}.bin ${DEPLOYDIR}/${BPN}-${MACHINE}.bin
26}
27
28addtask deploy before do_build after do_package
29
30FILES_${PN} = "${base_libdir}/firmware/pmufw*"