diff options
author | John Toomey <john.toomey@amd.com> | 2024-05-15 14:16:28 +0100 |
---|---|---|
committer | Mark Hatle <mark.hatle@amd.com> | 2024-11-21 10:43:43 -0600 |
commit | 661ee988c5cf2073d277c56aa98f55f7baf56c63 (patch) | |
tree | 2a6d05e3010e1476c974ecfe64339bf3118331a3 /meta-xilinx-mali400/recipes-devtools | |
parent | 32bffbb8498f0297ed1e6deaca72ff8a5c500a39 (diff) | |
download | meta-xilinx-661ee988c5cf2073d277c56aa98f55f7baf56c63.tar.gz |
meta-xilinx-mali400: Create new Mali400 layer
Create a new layer containing all code related to the Mali400 graphics
stack and software. This includes the Mali kernel module / patches,
libglu/libgles code, mesa, wayland, kernel recipe and udev rules. This
layer also includes a dynamic layer for the qt5 bbappends and patches.
Signed-off-by: Mark Hatle <mark.hatle@amd.com>
Diffstat (limited to 'meta-xilinx-mali400/recipes-devtools')
-rw-r--r-- | meta-xilinx-mali400/recipes-devtools/qemu/qemu-xilinx_8.1.0.bbappend | 6 | ||||
-rw-r--r-- | meta-xilinx-mali400/recipes-devtools/qemu/qemu_%.bbappend | 6 |
2 files changed, 12 insertions, 0 deletions
diff --git a/meta-xilinx-mali400/recipes-devtools/qemu/qemu-xilinx_8.1.0.bbappend b/meta-xilinx-mali400/recipes-devtools/qemu/qemu-xilinx_8.1.0.bbappend new file mode 100644 index 00000000..514cacaa --- /dev/null +++ b/meta-xilinx-mali400/recipes-devtools/qemu/qemu-xilinx_8.1.0.bbappend | |||
@@ -0,0 +1,6 @@ | |||
1 | # Links to libmali-xlnx, so it becomes MACHINE_ARCH specific | ||
2 | DEFAULT_PACKAGE_ARCH := "${PACKAGE_ARCH}" | ||
3 | MALI_PACKAGE_ARCH[vardepsexclude] = "MACHINE_ARCH" | ||
4 | MALI_PACKAGE_ARCH = "${@'${MACHINE_ARCH}' if d.getVar('PREFERRED_PROVIDER_virtual/libgles1') == 'libmali-xlnx' else '${DEFAULT_PACKAGE_ARCH}'}" | ||
5 | PACKAGE_ARCH[vardepsexclude] = "MALI_PACKAGE_ARCH" | ||
6 | PACKAGE_ARCH:class-target = "${@bb.utils.contains_any('DEPENDS', 'libepoxy virglrenderer', '${MALI_PACKAGE_ARCH}', '${DEFAULT_PACKAGE_ARCH}', d)}" | ||
diff --git a/meta-xilinx-mali400/recipes-devtools/qemu/qemu_%.bbappend b/meta-xilinx-mali400/recipes-devtools/qemu/qemu_%.bbappend new file mode 100644 index 00000000..514cacaa --- /dev/null +++ b/meta-xilinx-mali400/recipes-devtools/qemu/qemu_%.bbappend | |||
@@ -0,0 +1,6 @@ | |||
1 | # Links to libmali-xlnx, so it becomes MACHINE_ARCH specific | ||
2 | DEFAULT_PACKAGE_ARCH := "${PACKAGE_ARCH}" | ||
3 | MALI_PACKAGE_ARCH[vardepsexclude] = "MACHINE_ARCH" | ||
4 | MALI_PACKAGE_ARCH = "${@'${MACHINE_ARCH}' if d.getVar('PREFERRED_PROVIDER_virtual/libgles1') == 'libmali-xlnx' else '${DEFAULT_PACKAGE_ARCH}'}" | ||
5 | PACKAGE_ARCH[vardepsexclude] = "MALI_PACKAGE_ARCH" | ||
6 | PACKAGE_ARCH:class-target = "${@bb.utils.contains_any('DEPENDS', 'libepoxy virglrenderer', '${MALI_PACKAGE_ARCH}', '${DEFAULT_PACKAGE_ARCH}', d)}" | ||