summaryrefslogtreecommitdiffstats
path: root/meta-xilinx-core
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@amd.com>2023-01-10 09:28:30 -0800
committerMark Hatle <mark.hatle@amd.com>2023-01-11 12:23:20 -0600
commitcb1d5159773f41b9778ad9631573e6fdb912c3eb (patch)
tree650ba6676d8f35278fa1e2286772e07e53b697ac /meta-xilinx-core
parentb776c70a2f5c38ea9e54f4004977465a00cd5bab (diff)
downloadmeta-xilinx-cb1d5159773f41b9778ad9631573e6fdb912c3eb.tar.gz
u-boot-xlnx: Update 2023.1 version
Add u-boot-tools-xlnx as well. Update the PREFERRED VERSION to select the new u-boot version, add preferred provider for u-boot-tools to be u-boot-tools-xlnx. Needed to split the microblaze configs to older and newer versions as well. Signed-off-by: Mark Hatle <mark.hatle@amd.com>
Diffstat (limited to 'meta-xilinx-core')
-rw-r--r--meta-xilinx-core/conf/layer.conf3
-rw-r--r--meta-xilinx-core/conf/machine/include/machine-xilinx-default.inc3
-rw-r--r--meta-xilinx-core/recipes-bsp/u-boot/u-boot-tools%.bbappend23
-rw-r--r--meta-xilinx-core/recipes-bsp/u-boot/u-boot-tools-xlnx.inc7
-rw-r--r--meta-xilinx-core/recipes-bsp/u-boot/u-boot-tools-xlnx_2023.1.bb6
-rw-r--r--meta-xilinx-core/recipes-bsp/u-boot/u-boot-v2021.01/microblaze-generic-top.h (renamed from meta-xilinx-core/recipes-bsp/u-boot/u-boot/microblaze-generic-top.h)0
-rw-r--r--meta-xilinx-core/recipes-bsp/u-boot/u-boot-v2021.01/microblaze-generic.cfg (renamed from meta-xilinx-core/recipes-bsp/u-boot/u-boot/microblaze-generic.cfg)0
-rw-r--r--meta-xilinx-core/recipes-bsp/u-boot/u-boot-v2023.01/microblaze-generic-top.h8
-rw-r--r--meta-xilinx-core/recipes-bsp/u-boot/u-boot-v2023.01/microblaze-generic.cfg83
-rw-r--r--meta-xilinx-core/recipes-bsp/u-boot/u-boot-xlnx-2023.1.inc17
-rw-r--r--meta-xilinx-core/recipes-bsp/u-boot/u-boot-xlnx-common.inc19
-rw-r--r--meta-xilinx-core/recipes-bsp/u-boot/u-boot-xlnx.inc22
-rw-r--r--meta-xilinx-core/recipes-bsp/u-boot/u-boot-xlnx_2023.1.bb21
13 files changed, 174 insertions, 38 deletions
diff --git a/meta-xilinx-core/conf/layer.conf b/meta-xilinx-core/conf/layer.conf
index 6c1c2423..a2c9438d 100644
--- a/meta-xilinx-core/conf/layer.conf
+++ b/meta-xilinx-core/conf/layer.conf
@@ -63,9 +63,10 @@ PREFERRED_VERSION_arm-trusted-firmware ?= "${@d.getVarFlag('XILINX_ATF_VERSION',
63 63
64XILINX_UBOOT_VERSION[v2022.1] = "v2021.01-xilinx-v2022.1%" 64XILINX_UBOOT_VERSION[v2022.1] = "v2021.01-xilinx-v2022.1%"
65XILINX_UBOOT_VERSION[v2022.2] = "v2021.01-xilinx-v2022.2%" 65XILINX_UBOOT_VERSION[v2022.2] = "v2021.01-xilinx-v2022.2%"
66XILINX_UBOOT_VERSION[v2023.1] = "v2021.01-xilinx-v2023.1%" 66XILINX_UBOOT_VERSION[v2023.1] = "v2023.01-xilinx-v2023.1%"
67 67
68PREFERRED_VERSION_u-boot-xlnx ?= "${@d.getVarFlag('XILINX_UBOOT_VERSION', d.getVar('XILINX_RELEASE_VERSION')) or 'undefined'}" 68PREFERRED_VERSION_u-boot-xlnx ?= "${@d.getVarFlag('XILINX_UBOOT_VERSION', d.getVar('XILINX_RELEASE_VERSION')) or 'undefined'}"
69PREFERRED_VERSION_u-boot-tools-xlnx ?= "${@d.getVarFlag('XILINX_UBOOT_VERSION', d.getVar('XILINX_RELEASE_VERSION')) or 'undefined'}"
69 70
70XILINX_LINUX_VERSION[v2022.1] = "5.15.19-xilinx-v2022.1%" 71XILINX_LINUX_VERSION[v2022.1] = "5.15.19-xilinx-v2022.1%"
71XILINX_LINUX_VERSION[v2022.2] = "5.15.36-xilinx-v2022.2%" 72XILINX_LINUX_VERSION[v2022.2] = "5.15.36-xilinx-v2022.2%"
diff --git a/meta-xilinx-core/conf/machine/include/machine-xilinx-default.inc b/meta-xilinx-core/conf/machine/include/machine-xilinx-default.inc
index dc6ab05c..0cbd4249 100644
--- a/meta-xilinx-core/conf/machine/include/machine-xilinx-default.inc
+++ b/meta-xilinx-core/conf/machine/include/machine-xilinx-default.inc
@@ -16,6 +16,9 @@ PREFERRED_PROVIDER_virtual/kernel ??= "linux-xlnx"
16# U-Boot Configuration 16# U-Boot Configuration
17PREFERRED_PROVIDER_virtual/bootloader ??= "u-boot-xlnx" 17PREFERRED_PROVIDER_virtual/bootloader ??= "u-boot-xlnx"
18PREFERRED_PROVIDER_virtual/boot-bin ??= "xilinx-bootbin" 18PREFERRED_PROVIDER_virtual/boot-bin ??= "xilinx-bootbin"
19PREFERRED_PROVIDER_u-boot-tools ??= "u-boot-tools-xlnx"
20PREFERRED_PROVIDER_u-boot-tools-native ??= "u-boot-tools-xlnx-native"
21PREFERRED_PROVIDER_nativesdk-u-boot-tools ??= "nativesdk-u-boot-tools-xlnx"
19 22
20do_image_wic[depends] += "${@' '.join('%s:do_deploy' % r for r in (d.getVar('WIC_DEPENDS') or "").split())}" 23do_image_wic[depends] += "${@' '.join('%s:do_deploy' % r for r in (d.getVar('WIC_DEPENDS') or "").split())}"
21 24
diff --git a/meta-xilinx-core/recipes-bsp/u-boot/u-boot-tools%.bbappend b/meta-xilinx-core/recipes-bsp/u-boot/u-boot-tools%.bbappend
new file mode 100644
index 00000000..65b6ad9d
--- /dev/null
+++ b/meta-xilinx-core/recipes-bsp/u-boot/u-boot-tools%.bbappend
@@ -0,0 +1,23 @@
1# Skip processing of this recipe if it is not explicitly specified as the
2# PREFERRED_PROVIDER for libmetal. This avoids network access required by
3# the use of AUTOREV SRCREVs, which may be the default for some recipes.
4python () {
5 if bb.data.inherits_class('native', d):
6 if (not d.getVar("PREFERRED_PROVIDER_u-boot-tools-native") and "u-boot-tools-native" != d.getVar("PN")) or \
7 (d.getVar("PREFERRED_PROVIDER_u-boot-tools-native") and d.getVar("PREFERRED_PROVIDER_u-boot-tools-native") != d.getVar("PN")):
8 d.delVar("BB_DONT_CACHE")
9 raise bb.parse.SkipRecipe("Set PREFERRED_PROVIDER_u-boot-tools-native to %s to enable it" % (d.getVar("PN")))
10
11 elif bb.data.inherits_class('nativesdk', d):
12 if (not d.getVar("PREFERRED_PROVIDER_nativesdk-u-boot-tools") and "nativesdk-u-boot-tools" != d.getVar("PN")) or \
13 (d.getVar("PREFERRED_PROVIDER_nativesdk-u-boot-tools") and d.getVar("PREFERRED_PROVIDER_nativesdk-u-boot-tools") != d.getVar("PN")):
14 d.delVar("BB_DONT_CACHE")
15 raise bb.parse.SkipRecipe("Set PREFERRED_PROVIDER_nativesdk-u-boot-tools to %s to enable it" % (d.getVar("PN")))
16
17 else:
18 if (not d.getVar("PREFERRED_PROVIDER_u-boot-tools") and "u-boot-tools" != d.getVar("PN")) or \
19 (d.getVar("PREFERRED_PROVIDER_u-boot-tools") and d.getVar("PREFERRED_PROVIDER_u-boot-tools") != d.getVar("PN")):
20 d.delVar("BB_DONT_CACHE")
21 raise bb.parse.SkipRecipe("Set PREFERRED_PROVIDER_u-boot-tools to %s to enable it" % (d.getVar("PN")))
22}
23
diff --git a/meta-xilinx-core/recipes-bsp/u-boot/u-boot-tools-xlnx.inc b/meta-xilinx-core/recipes-bsp/u-boot/u-boot-tools-xlnx.inc
new file mode 100644
index 00000000..af26594c
--- /dev/null
+++ b/meta-xilinx-core/recipes-bsp/u-boot/u-boot-tools-xlnx.inc
@@ -0,0 +1,7 @@
1require recipes-bsp/u-boot/u-boot-common.inc
2require recipes-bsp/u-boot/u-boot-tools.inc
3
4require u-boot-xlnx-common.inc
5
6PROVIDES:append = " u-boot-tools"
7RPROVIDES:${PN}:append = " u-boot-tools"
diff --git a/meta-xilinx-core/recipes-bsp/u-boot/u-boot-tools-xlnx_2023.1.bb b/meta-xilinx-core/recipes-bsp/u-boot/u-boot-tools-xlnx_2023.1.bb
new file mode 100644
index 00000000..95f73164
--- /dev/null
+++ b/meta-xilinx-core/recipes-bsp/u-boot/u-boot-tools-xlnx_2023.1.bb
@@ -0,0 +1,6 @@
1require u-boot-tools-xlnx.inc
2require u-boot-xlnx-2023.1.inc
3
4# MUST clear CONFIG_VIDEO to avoid a compilation failure trying to construct
5# bmp_logo.h
6SED_CONFIG_EFI:append = ' -e "s/CONFIG_VIDEO=.*/# CONFIG_VIDEO is not set/"'
diff --git a/meta-xilinx-core/recipes-bsp/u-boot/u-boot/microblaze-generic-top.h b/meta-xilinx-core/recipes-bsp/u-boot/u-boot-v2021.01/microblaze-generic-top.h
index 08c1c16c..08c1c16c 100644
--- a/meta-xilinx-core/recipes-bsp/u-boot/u-boot/microblaze-generic-top.h
+++ b/meta-xilinx-core/recipes-bsp/u-boot/u-boot-v2021.01/microblaze-generic-top.h
diff --git a/meta-xilinx-core/recipes-bsp/u-boot/u-boot/microblaze-generic.cfg b/meta-xilinx-core/recipes-bsp/u-boot/u-boot-v2021.01/microblaze-generic.cfg
index 0f784f73..0f784f73 100644
--- a/meta-xilinx-core/recipes-bsp/u-boot/u-boot/microblaze-generic.cfg
+++ b/meta-xilinx-core/recipes-bsp/u-boot/u-boot-v2021.01/microblaze-generic.cfg
diff --git a/meta-xilinx-core/recipes-bsp/u-boot/u-boot-v2023.01/microblaze-generic-top.h b/meta-xilinx-core/recipes-bsp/u-boot/u-boot-v2023.01/microblaze-generic-top.h
new file mode 100644
index 00000000..be823421
--- /dev/null
+++ b/meta-xilinx-core/recipes-bsp/u-boot/u-boot-v2023.01/microblaze-generic-top.h
@@ -0,0 +1,8 @@
1/*
2 * This file is use for addition u-boot configurations for microblaze.
3 */
4#include <configs/microblaze-generic.h>
5
6/* Core microblaze boot configurations */
7#define XILINX_USE_ICACHE 1
8#define XILINX_USE_DCACHE 1
diff --git a/meta-xilinx-core/recipes-bsp/u-boot/u-boot-v2023.01/microblaze-generic.cfg b/meta-xilinx-core/recipes-bsp/u-boot/u-boot-v2023.01/microblaze-generic.cfg
new file mode 100644
index 00000000..a2ab516b
--- /dev/null
+++ b/meta-xilinx-core/recipes-bsp/u-boot/u-boot-v2023.01/microblaze-generic.cfg
@@ -0,0 +1,83 @@
1# SPDX-License-Identifier: MIT
2
3#........................................................................
4# WARNING
5#
6# This file is a u-boot configuration fragment, and not a full u-boot
7# configuration file. The final u-boot configuration is made up of
8# an assembly of processed fragments, each of which is designed to
9# capture a specific part of the final configuration (e.g. platform
10# configuration, feature configuration, and board specific hardware
11# configuration). For more information on u-boot configuration, please
12# refer the product documentation.
13#
14#.......................................................................
15
16#
17# Definitions for Generic Microbalze machine.
18#
19CONFIG_BOOTDELAY=4
20CONFIG_SYS_TEXT_BASE=0x80100000
21CONFIG_SYS_PROMPT="U-Boot>"
22CONFIG_SYS_CONFIG_NAME="microblaze-generic-top"
23CONFIG_BOOT_SCRIPT_OFFSET=0x1F00000
24# CONFIG_SYS_NS16550 is not set
25# CONFIG_SYS_FLASH_USE_BUFFER_WRITE is not set
26# CONFIG_SYS_FLASH_CFI is not set
27# CONFIG_FLASH_CFI_DRIVER is not set
28# CONFIG_CMD_FLASH is not set
29# CONFIG_CMD_IMLS is not set
30# CONFIG_MTD_NOR_FLASH is not set
31# CONFIG_MTD_DEVICE is not set
32# CONFIG_SYS_FLASH_PROTECTION is not set
33# CONFIG_SPI_FLASH_SST is not set
34# CONFIG_XILINX_EMACLITE is not set
35# CONFIG_PHY_VITESSE is not set
36# CONFIG_CMD_EXT2 is not set
37# CONFIG_CMD_EXT4 is not set
38# CONFIG_CMD_EXT4_WRITE is not set
39# CONFIG_CMD_FAT is not set
40# CONFIG_DOS_PARTITION is not set
41# CONFIG_FAT_WRITE is not set
42CONFIG_DM=y
43CONFIG_SYS_MALLOC_F=y
44CONFIG_XILINX_UARTLITE=y
45CONFIG_XILINX_AXIEMAC=y
46CONFIG_PHY_XILINX=y
47CONFIG_PHY_TI=y
48CONFIG_NET=y
49CONFIG_PHY_GIGE=y
50CONFIG_NETDEVICES=y
51CONFIG_CMD_NET=y
52CONFIG_DM_ETH=y
53CONFIG_CMD_PING=y
54CONFIG_CMD_DHCP=y
55CONFIG_PHYLIB=y
56CONFIG_CMD_TFTPPUT=y
57CONFIG_CMD_NFS=y
58CONFIG_CMD_MII=y
59CONFIG_PHY_MARVELL=y
60CONFIG_PHY_REALTEK=y
61CONFIG_PHY_NATSEMI=y
62CONFIG_XILINX_SPI=y
63CONFIG_CMD_SPI=y
64CONFIG_CMD_SF=y
65CONFIG_SPI_FLASH=y
66CONFIG_SPI_FLASH_BAR=y
67CONFIG_DM_SPI_FLASH=y
68CONFIG_DM_SPI=y
69CONFIG_SPI_FLASH_SPANSION=y
70CONFIG_SPI_FLASH_STMICRO=y
71CONFIG_SPI_FLASH_WINBOND=y
72CONFIG_SPI_FLASH_MACRONIX=y
73CONFIG_SPI=y
74CONFIG_SPI_FLASH_ISSI=y
75# CONFIG_BOOTARGS is not set
76# CONFIG_USE_BOOTARGS is not set
77# CONFIG_SPL is not set
78# CONFIG_I2C_EEPROM is not set
79# CONFIG_CMD_EEPROM is not set
80# CONFIG_SYS_I2C_EEPROM_ADDR is not set
81# CONFIG_SYS_I2C_EEPROM_ADDR_OVERFLOW is not set
82CONFIG_DCACHE=y
83CONFIG_ICACHE=y
diff --git a/meta-xilinx-core/recipes-bsp/u-boot/u-boot-xlnx-2023.1.inc b/meta-xilinx-core/recipes-bsp/u-boot/u-boot-xlnx-2023.1.inc
new file mode 100644
index 00000000..6ff4243f
--- /dev/null
+++ b/meta-xilinx-core/recipes-bsp/u-boot/u-boot-xlnx-2023.1.inc
@@ -0,0 +1,17 @@
1UBOOT_VERSION = "v2023.01"
2
3UBRANCH ?= "xlnx_rebase_v2023.01-next"
4
5SRCREV = "1fe11bde7b765024eb7a49584e7c65015ae90bac"
6
7LICENSE = "GPL-2.0-or-later"
8LIC_FILES_CHKSUM = "file://README;beginline=1;endline=4;md5=744e7e3bb0c94b4b9f6b3db3bf893897"
9
10# u-boot-xlnx has support for these
11HAS_PLATFORM_INIT ?= " \
12 xilinx_zynqmp_virt_config \
13 xilinx_zynq_virt_defconfig \
14 xilinx_versal_vc_p_a2197_revA_x_prc_01_revA \
15 "
16
17DEPENDS += "bc-native dtc-native python3-setuptools-native gnutls-native"
diff --git a/meta-xilinx-core/recipes-bsp/u-boot/u-boot-xlnx-common.inc b/meta-xilinx-core/recipes-bsp/u-boot/u-boot-xlnx-common.inc
new file mode 100644
index 00000000..b447c92a
--- /dev/null
+++ b/meta-xilinx-core/recipes-bsp/u-boot/u-boot-xlnx-common.inc
@@ -0,0 +1,19 @@
1# Use the name of the .bb for the extension
2UBOOT_VERSION_EXTENSION ?= "-xilinx-v${@bb.parse.vars_from_file(d.getVar('FILE', False),d)[1] or ''}"
3PV = "${UBOOT_VERSION}${UBOOT_VERSION_EXTENSION}+git${SRCPV}"
4
5UBOOTURI ?= "git://github.com/Xilinx/u-boot-xlnx.git;protocol=https"
6UBRANCH ?= ""
7UBRANCHARG = "${@['nobranch=1', 'branch=${UBRANCH}'][d.getVar('UBRANCH', True) != '']}"
8
9SRC_URI = "${UBOOTURI};${UBRANCHARG}"
10
11S = "${WORKDIR}/git"
12B = "${WORKDIR}/build"
13
14FILESEXTRAPATHS:prepend := "${THISDIR}/u-boot-${UBOOT_VERSION}:"
15
16UBOOT_MB_INC = ""
17UBOOT_MB_INC:microblaze = "u-boot-xlnx-microblaze.inc"
18require ${UBOOT_MB_INC}
19
diff --git a/meta-xilinx-core/recipes-bsp/u-boot/u-boot-xlnx.inc b/meta-xilinx-core/recipes-bsp/u-boot/u-boot-xlnx.inc
index 183ebe31..38d8e492 100644
--- a/meta-xilinx-core/recipes-bsp/u-boot/u-boot-xlnx.inc
+++ b/meta-xilinx-core/recipes-bsp/u-boot/u-boot-xlnx.inc
@@ -1,25 +1,9 @@
1require recipes-bsp/u-boot/u-boot-common.inc
1require recipes-bsp/u-boot/u-boot.inc 2require recipes-bsp/u-boot/u-boot.inc
2 3
3DEPENDS += "bc-native dtc-native bison-native xxd-native" 4DEPENDS += "bc-native dtc-native python3-setuptools-native bison-native xxd-native"
4 5
5# Use the name of the .bb for the extension 6require u-boot-xlnx-common.inc
6UBOOT_VERSION_EXTENSION ?= "-xilinx-v${@bb.parse.vars_from_file(d.getVar('FILE', False),d)[1] or ''}"
7PV = "${UBOOT_VERSION}${UBOOT_VERSION_EXTENSION}+git${SRCPV}"
8
9UBOOTURI ?= "git://github.com/Xilinx/u-boot-xlnx.git;protocol=https"
10UBRANCH ?= ""
11UBRANCHARG = "${@['nobranch=1', 'branch=${UBRANCH}'][d.getVar('UBRANCH', True) != '']}"
12
13SRC_URI = "${UBOOTURI};${UBRANCHARG}"
14
15S = "${WORKDIR}/git"
16B = "${WORKDIR}/build"
17
18FILESEXTRAPATHS:prepend := "${THISDIR}/u-boot:"
19
20UBOOT_MB_INC = ""
21UBOOT_MB_INC:microblaze = "u-boot-xlnx-microblaze.inc"
22require ${UBOOT_MB_INC}
23 7
24SYSROOT_DIRS += "/boot" 8SYSROOT_DIRS += "/boot"
25 9
diff --git a/meta-xilinx-core/recipes-bsp/u-boot/u-boot-xlnx_2023.1.bb b/meta-xilinx-core/recipes-bsp/u-boot/u-boot-xlnx_2023.1.bb
index 9f2592d5..fd76bc51 100644
--- a/meta-xilinx-core/recipes-bsp/u-boot/u-boot-xlnx_2023.1.bb
+++ b/meta-xilinx-core/recipes-bsp/u-boot/u-boot-xlnx_2023.1.bb
@@ -1,19 +1,4 @@
1UBOOT_VERSION = "v2021.01"
2
3UBRANCH ?= "master"
4
5SRCREV = "d706060b431d6799d0564be6053f896cd6778ddb"
6
7include u-boot-xlnx.inc
8include u-boot-spl-zynq-init.inc
9
10LICENSE = "GPL-2.0-or-later"
11LIC_FILES_CHKSUM = "file://README;beginline=1;endline=4;md5=744e7e3bb0c94b4b9f6b3db3bf893897"
12
13# u-boot-xlnx has support for these
14HAS_PLATFORM_INIT ?= " \
15 xilinx_zynqmp_virt_config \
16 xilinx_zynq_virt_defconfig \
17 xilinx_versal_vc_p_a2197_revA_x_prc_01_revA \
18 "
19 1
2require u-boot-xlnx.inc
3require u-boot-spl-zynq-init.inc
4require u-boot-xlnx-2023.1.inc