summaryrefslogtreecommitdiffstats
path: root/meta-xilinx-core
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@amd.com>2023-01-17 15:07:58 -0800
committerMark Hatle <mark.hatle@amd.com>2023-01-19 10:00:28 -0600
commit3a9c474548b05e72406b423e1bba0040aa79704b (patch)
treee2f230fc9d3703aa0b0958b69ba69bb09f8dc3f8 /meta-xilinx-core
parent6b4c0a9506da98261fe3f64cf0223e9e6adf6bfb (diff)
downloadmeta-xilinx-3a9c474548b05e72406b423e1bba0040aa79704b.tar.gz
u-boot-tools-xlnx: Avoid YP do_compile workaround
do_compile workaround in YP can result in: | error: object directory ../git2/github.com.Xilinx.u-boot-xlnx.git/objects does not exist; check .git/objects/info/alternates. | fatal: unable to read 9e43f9c6c6c446128d036038e53c2d107d04edc8 Signed-off-by: Mark Hatle <mark.hatle@amd.com>
Diffstat (limited to 'meta-xilinx-core')
-rw-r--r--meta-xilinx-core/recipes-bsp/u-boot/u-boot-tools-xlnx_2023.1.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-xilinx-core/recipes-bsp/u-boot/u-boot-tools-xlnx_2023.1.bb b/meta-xilinx-core/recipes-bsp/u-boot/u-boot-tools-xlnx_2023.1.bb
index 95f73164..fe5ecf79 100644
--- a/meta-xilinx-core/recipes-bsp/u-boot/u-boot-tools-xlnx_2023.1.bb
+++ b/meta-xilinx-core/recipes-bsp/u-boot/u-boot-tools-xlnx_2023.1.bb
@@ -4,3 +4,18 @@ require u-boot-xlnx-2023.1.inc
4# MUST clear CONFIG_VIDEO to avoid a compilation failure trying to construct 4# MUST clear CONFIG_VIDEO to avoid a compilation failure trying to construct
5# bmp_logo.h 5# bmp_logo.h
6SED_CONFIG_EFI:append = ' -e "s/CONFIG_VIDEO=.*/# CONFIG_VIDEO is not set/"' 6SED_CONFIG_EFI:append = ' -e "s/CONFIG_VIDEO=.*/# CONFIG_VIDEO is not set/"'
7
8# Default do_compile fails with:
9# | error: object directory ../downloads/git2/github.com.Xilinx.u-boot-xlnx.git/objects does not exist; check .git/objects/info/alternates.
10# The regular workaround of calling 'git diff' seems to be problematic.
11do_compile () {
12 oe_runmake -C ${S} tools-only_defconfig O=${B}
13
14 # Disable CONFIG_CMD_LICENSE, license.h is not used by tools and
15 # generating it requires bin2header tool, which for target build
16 # is built with target tools and thus cannot be executed on host.
17 sed -i -e "s/CONFIG_CMD_LICENSE=.*/# CONFIG_CMD_LICENSE is not set/" ${SED_CONFIG_EFI} ${B}/.config
18
19 oe_runmake -C ${S} cross_tools NO_SDL=1 O=${B}
20}
21