summaryrefslogtreecommitdiffstats
path: root/meta-xilinx-core/recipes-xrt
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@amd.com>2024-11-24 09:32:52 -0700
committerMark Hatle <mark.hatle@amd.com>2024-11-24 16:55:01 -0700
commitfc651966ac5add0bd5d4e2612c02368ff715621b (patch)
tree9070dd61d789ea083b8ab40fc9c61114d894e25a /meta-xilinx-core/recipes-xrt
parentd6ba64599f6f84a33d7c106eace03dc0a24ea02f (diff)
downloadmeta-xilinx-fc651966ac5add0bd5d4e2612c02368ff715621b.tar.gz
various: Remove 2022.x versions
Signed-off-by: Mark Hatle <mark.hatle@amd.com>
Diffstat (limited to 'meta-xilinx-core/recipes-xrt')
-rw-r--r--meta-xilinx-core/recipes-xrt/xrt/xrt-202210.2.13.479.inc6
-rw-r--r--meta-xilinx-core/recipes-xrt/xrt/xrt-202210.2.13.479/xrt-cstdint.patch145
-rw-r--r--meta-xilinx-core/recipes-xrt/xrt/xrt-202220.2.14.0.inc7
-rw-r--r--meta-xilinx-core/recipes-xrt/xrt/xrt-202220.2.14.0/xrt-cstdint.patch146
-rw-r--r--meta-xilinx-core/recipes-xrt/xrt/xrt_202210.2.13.479.bb53
-rw-r--r--meta-xilinx-core/recipes-xrt/xrt/xrt_202220.2.14.0.bb53
-rw-r--r--meta-xilinx-core/recipes-xrt/zocl/zocl_202210.2.13.479.bb24
-rw-r--r--meta-xilinx-core/recipes-xrt/zocl/zocl_202220.2.14.0.bb21
8 files changed, 0 insertions, 455 deletions
diff --git a/meta-xilinx-core/recipes-xrt/xrt/xrt-202210.2.13.479.inc b/meta-xilinx-core/recipes-xrt/xrt/xrt-202210.2.13.479.inc
deleted file mode 100644
index 38fbd162..00000000
--- a/meta-xilinx-core/recipes-xrt/xrt/xrt-202210.2.13.479.inc
+++ /dev/null
@@ -1,6 +0,0 @@
1REPO ?= "git://github.com/Xilinx/XRT.git;protocol=https"
2BRANCHARG = "${@['nobranch=1', 'branch=${BRANCH}'][d.getVar('BRANCH', True) != '']}"
3SRC_URI = "${REPO};${BRANCHARG}"
4
5BRANCH= "2022.1"
6SRCREV= "5e92a513c6950e79638b1a879ddb882da34fc683"
diff --git a/meta-xilinx-core/recipes-xrt/xrt/xrt-202210.2.13.479/xrt-cstdint.patch b/meta-xilinx-core/recipes-xrt/xrt/xrt-202210.2.13.479/xrt-cstdint.patch
deleted file mode 100644
index 58c3736a..00000000
--- a/meta-xilinx-core/recipes-xrt/xrt/xrt-202210.2.13.479/xrt-cstdint.patch
+++ /dev/null
@@ -1,145 +0,0 @@
1From e60fd92415bc849293944dd8fb7a72241df6055f Mon Sep 17 00:00:00 2001
2From: Mark Hatle <mark.hatle@amd.com>
3Date: Mon, 20 May 2024 19:38:06 -0600
4Subject: [PATCH] Add cstdint as necessary
5
6In GCC 13.1 usage of uint64 and similar will result in an error without
7 #include <cstdint>
8
9Signed-off-by: Mark Hatle <mark.hatle@amd.com>
10---
11 src/runtime_src/core/common/time.h | 1 +
12 src/runtime_src/core/edge/common/aie_parser.h | 1 +
13 src/runtime_src/core/edge/user/aie/common_layer/adf_api_config.h | 1 +
14 src/runtime_src/core/edge/user/zynq_dev.h | 1 +
15 src/runtime_src/tools/xclbinutil/CBOR.h | 1 +
16 src/runtime_src/tools/xclbinutil/DTCStringsBlock.h | 1 +
17 src/runtime_src/tools/xclbinutil/XclBinSignature.h | 1 +
18 src/runtime_src/xdp/profile/database/events/vtf_event.h | 1 +
19 src/runtime_src/xdp/profile/device/aie_trace/aie_trace_logger.h | 1 +
20 src/runtime_src/xdp/profile/writer/vp_base/vp_writer.h | 1 +
21 10 files changed, 10 insertions(+)
22
23diff --git a/src/runtime_src/core/common/time.h b/src/runtime_src/core/common/time.h
24index a4a96b11d..585d38756 100644
25--- a/src/runtime_src/core/common/time.h
26+++ b/src/runtime_src/core/common/time.h
27@@ -19,6 +19,7 @@
28
29 #include "core/common/config.h"
30 #include <string>
31+#include <cstdint>
32
33 namespace xrt_core {
34
35diff --git a/src/runtime_src/core/edge/common/aie_parser.h b/src/runtime_src/core/edge/common/aie_parser.h
36index 5bc32a36a..f35e97ecd 100644
37--- a/src/runtime_src/core/edge/common/aie_parser.h
38+++ b/src/runtime_src/core/edge/common/aie_parser.h
39@@ -20,6 +20,7 @@
40 #include <string>
41 #include <vector>
42 #include <unordered_map>
43+#include <cstdint>
44 #include "../user/aie/common_layer/adf_api_config.h"
45
46 namespace xrt_core {
47diff --git a/src/runtime_src/core/edge/user/aie/common_layer/adf_api_config.h b/src/runtime_src/core/edge/user/aie/common_layer/adf_api_config.h
48index 196304765..36ce35e80
49--- a/src/runtime_src/core/edge/user/aie/common_layer/adf_api_config.h
50+++ b/src/runtime_src/core/edge/user/aie/common_layer/adf_api_config.h
51@@ -18,6 +18,7 @@
52
53 #include <string>
54 #include <vector>
55+#include <cstdint>
56
57 namespace adf
58 {
59diff --git a/src/runtime_src/core/edge/user/zynq_dev.h b/src/runtime_src/core/edge/user/zynq_dev.h
60index 6fe36c615..2abd7473b 100644
61--- a/src/runtime_src/core/edge/user/zynq_dev.h
62+++ b/src/runtime_src/core/edge/user/zynq_dev.h
63@@ -19,6 +19,7 @@
64 #include <fstream>
65 #include <string>
66 #include <vector>
67+#include <cstdint>
68
69 class zynq_device {
70 public:
71diff --git a/src/runtime_src/tools/xclbinutil/CBOR.h b/src/runtime_src/tools/xclbinutil/CBOR.h
72index e0f1175cd..d8c97ceb4 100644
73--- a/src/runtime_src/tools/xclbinutil/CBOR.h
74+++ b/src/runtime_src/tools/xclbinutil/CBOR.h
75@@ -22,6 +22,7 @@
76 // #includes here - please keep these to a bare minimum!
77 #include <string>
78 #include <sstream>
79+#include <cstdint>
80
81 // ------------ F O R W A R D - D E C L A R A T I O N S ----------------------
82 // Forward declarations - use these instead whenever possible...
83diff --git a/src/runtime_src/tools/xclbinutil/DTCStringsBlock.h b/src/runtime_src/tools/xclbinutil/DTCStringsBlock.h
84index 1ccd7ffc3..e20ae034a 100644
85--- a/src/runtime_src/tools/xclbinutil/DTCStringsBlock.h
86+++ b/src/runtime_src/tools/xclbinutil/DTCStringsBlock.h
87@@ -22,6 +22,7 @@
88 // #includes here - please keep these to a bare minimum!
89 #include <string>
90 #include <sstream>
91+#include <cstdint>
92
93 // ------------ F O R W A R D - D E C L A R A T I O N S ----------------------
94 // Forward declarations - use these instead whenever possible...
95diff --git a/src/runtime_src/tools/xclbinutil/XclBinSignature.h b/src/runtime_src/tools/xclbinutil/XclBinSignature.h
96index b19ab56a4..f1b72d4d2 100644
97--- a/src/runtime_src/tools/xclbinutil/XclBinSignature.h
98+++ b/src/runtime_src/tools/xclbinutil/XclBinSignature.h
99@@ -18,6 +18,7 @@
100 #define __XclBinSignature_h_
101
102 #include <string>
103+#include <cstdint>
104
105 // ----------------------- I N C L U D E S -----------------------------------
106
107diff --git a/src/runtime_src/xdp/profile/database/events/vtf_event.h b/src/runtime_src/xdp/profile/database/events/vtf_event.h
108index 24a755a9a..a46a43e9d 100644
109--- a/src/runtime_src/xdp/profile/database/events/vtf_event.h
110+++ b/src/runtime_src/xdp/profile/database/events/vtf_event.h
111@@ -18,6 +18,7 @@
112 #define VTF_EVENT_DOT_H
113
114 #include <fstream>
115+#include <cstdint>
116
117 #include "xdp/config.h"
118
119diff --git a/src/runtime_src/xdp/profile/device/aie_trace/aie_trace_logger.h b/src/runtime_src/xdp/profile/device/aie_trace/aie_trace_logger.h
120index f1369fe02..1f7486c7e 100644
121--- a/src/runtime_src/xdp/profile/device/aie_trace/aie_trace_logger.h
122+++ b/src/runtime_src/xdp/profile/device/aie_trace/aie_trace_logger.h
123@@ -18,6 +18,7 @@
124 #define XDP_PROFILE_AIE_TRACE_LOGGER_H
125
126 #include<iostream>
127+#include<cstdint>
128
129 namespace xdp {
130
131diff --git a/src/runtime_src/xdp/profile/writer/vp_base/vp_writer.h b/src/runtime_src/xdp/profile/writer/vp_base/vp_writer.h
132index a88597464..f392ec0e6 100644
133--- a/src/runtime_src/xdp/profile/writer/vp_base/vp_writer.h
134+++ b/src/runtime_src/xdp/profile/writer/vp_base/vp_writer.h
135@@ -19,6 +19,7 @@
136
137 #include <fstream>
138 #include <string>
139+#include <cstdint>
140
141 #include "xdp/config.h"
142
143--
1442.34.1
145
diff --git a/meta-xilinx-core/recipes-xrt/xrt/xrt-202220.2.14.0.inc b/meta-xilinx-core/recipes-xrt/xrt/xrt-202220.2.14.0.inc
deleted file mode 100644
index e4bb423c..00000000
--- a/meta-xilinx-core/recipes-xrt/xrt/xrt-202220.2.14.0.inc
+++ /dev/null
@@ -1,7 +0,0 @@
1REPO ?= "git://github.com/Xilinx/XRT.git;protocol=https"
2BRANCHARG = "${@['nobranch=1', 'branch=${BRANCH}'][d.getVar('BRANCH', True) != '']}"
3SRC_URI = "${REPO};${BRANCHARG}"
4
5BRANCH= "2022.2"
6SRCREV= "43926231f7183688add2dccfd391b36a1f000bea"
7
diff --git a/meta-xilinx-core/recipes-xrt/xrt/xrt-202220.2.14.0/xrt-cstdint.patch b/meta-xilinx-core/recipes-xrt/xrt/xrt-202220.2.14.0/xrt-cstdint.patch
deleted file mode 100644
index 5546e0a4..00000000
--- a/meta-xilinx-core/recipes-xrt/xrt/xrt-202220.2.14.0/xrt-cstdint.patch
+++ /dev/null
@@ -1,146 +0,0 @@
1Signed-off-by: Mark Hatle <mark.hatle@amd.com>
2From f97ca31fc1b9aa973a2970e9248bc19f44b6a42f Mon Sep 17 00:00:00 2001
3From: Mark Hatle <mark.hatle@amd.com>
4Date: Mon, 20 May 2024 20:32:42 -0600
5Subject: [PATCH] Add cstdint as necessary
6
7In GCC 13.1 usage of uint64 and similar will result in an error without
8 #include <cstdint>
9
10Signed-off-by: Mark Hatle <mark.hatle@amd.com>
11---
12 src/runtime_src/core/common/time.h | 1 +
13 src/runtime_src/core/edge/common/aie_parser.h | 1 +
14 src/runtime_src/core/edge/user/aie/common_layer/adf_api_config.h | 1 +
15 src/runtime_src/core/edge/user/zynq_dev.h | 1 +
16 src/runtime_src/tools/xclbinutil/CBOR.h | 1 +
17 src/runtime_src/tools/xclbinutil/DTCStringsBlock.h | 1 +
18 src/runtime_src/tools/xclbinutil/XclBinSignature.h | 1 +
19 src/runtime_src/xdp/profile/database/events/vtf_event.h | 1 +
20 src/runtime_src/xdp/profile/device/aie_trace/aie_trace_logger.h | 1 +
21 src/runtime_src/xdp/profile/writer/vp_base/vp_writer.h | 1 +
22 10 files changed, 10 insertions(+)
23
24diff --git a/src/runtime_src/core/common/time.h b/src/runtime_src/core/common/time.h
25index a4a96b11d..585d38756 100644
26--- a/src/runtime_src/core/common/time.h
27+++ b/src/runtime_src/core/common/time.h
28@@ -19,6 +19,7 @@
29
30 #include "core/common/config.h"
31 #include <string>
32+#include <cstdint>
33
34 namespace xrt_core {
35
36diff --git a/src/runtime_src/core/edge/common/aie_parser.h b/src/runtime_src/core/edge/common/aie_parser.h
37index 5bc32a36a..f35e97ecd 100644
38--- a/src/runtime_src/core/edge/common/aie_parser.h
39+++ b/src/runtime_src/core/edge/common/aie_parser.h
40@@ -20,6 +20,7 @@
41 #include <string>
42 #include <vector>
43 #include <unordered_map>
44+#include <cstdint>
45 #include "../user/aie/common_layer/adf_api_config.h"
46
47 namespace xrt_core {
48diff --git a/src/runtime_src/core/edge/user/aie/common_layer/adf_api_config.h b/src/runtime_src/core/edge/user/aie/common_layer/adf_api_config.h
49index 196304765..36ce35e80 100755
50--- a/src/runtime_src/core/edge/user/aie/common_layer/adf_api_config.h
51+++ b/src/runtime_src/core/edge/user/aie/common_layer/adf_api_config.h
52@@ -18,6 +18,7 @@
53
54 #include <string>
55 #include <vector>
56+#include <cstdint>
57
58 namespace adf
59 {
60diff --git a/src/runtime_src/core/edge/user/zynq_dev.h b/src/runtime_src/core/edge/user/zynq_dev.h
61index 6fe36c615..2abd7473b 100644
62--- a/src/runtime_src/core/edge/user/zynq_dev.h
63+++ b/src/runtime_src/core/edge/user/zynq_dev.h
64@@ -19,6 +19,7 @@
65 #include <fstream>
66 #include <string>
67 #include <vector>
68+#include <cstdint>
69
70 class zynq_device {
71 public:
72diff --git a/src/runtime_src/tools/xclbinutil/CBOR.h b/src/runtime_src/tools/xclbinutil/CBOR.h
73index 368459f59..acbf6ebae 100644
74--- a/src/runtime_src/tools/xclbinutil/CBOR.h
75+++ b/src/runtime_src/tools/xclbinutil/CBOR.h
76@@ -22,6 +22,7 @@
77 // #includes here - please keep these to a bare minimum!
78 #include <string>
79 #include <sstream>
80+#include <cstdint>
81
82 // ------------ F O R W A R D - D E C L A R A T I O N S ----------------------
83 // Forward declarations - use these instead whenever possible...
84diff --git a/src/runtime_src/tools/xclbinutil/DTCStringsBlock.h b/src/runtime_src/tools/xclbinutil/DTCStringsBlock.h
85index 361015962..2ec16360d 100644
86--- a/src/runtime_src/tools/xclbinutil/DTCStringsBlock.h
87+++ b/src/runtime_src/tools/xclbinutil/DTCStringsBlock.h
88@@ -20,6 +20,7 @@
89 // ----------------------- I N C L U D E S -----------------------------------
90 #include <sstream>
91 #include <string>
92+#include <cstdint>
93
94 // ----------- C L A S S : D T C S t r i n g s B l o c k -------------------
95
96diff --git a/src/runtime_src/tools/xclbinutil/XclBinSignature.h b/src/runtime_src/tools/xclbinutil/XclBinSignature.h
97index b19ab56a4..f1b72d4d2 100644
98--- a/src/runtime_src/tools/xclbinutil/XclBinSignature.h
99+++ b/src/runtime_src/tools/xclbinutil/XclBinSignature.h
100@@ -18,6 +18,7 @@
101 #define __XclBinSignature_h_
102
103 #include <string>
104+#include <cstdint>
105
106 // ----------------------- I N C L U D E S -----------------------------------
107
108diff --git a/src/runtime_src/xdp/profile/database/events/vtf_event.h b/src/runtime_src/xdp/profile/database/events/vtf_event.h
109index 24a755a9a..a46a43e9d 100644
110--- a/src/runtime_src/xdp/profile/database/events/vtf_event.h
111+++ b/src/runtime_src/xdp/profile/database/events/vtf_event.h
112@@ -18,6 +18,7 @@
113 #define VTF_EVENT_DOT_H
114
115 #include <fstream>
116+#include <cstdint>
117
118 #include "xdp/config.h"
119
120diff --git a/src/runtime_src/xdp/profile/device/aie_trace/aie_trace_logger.h b/src/runtime_src/xdp/profile/device/aie_trace/aie_trace_logger.h
121index 98c57de2e..6f67c43df 100644
122--- a/src/runtime_src/xdp/profile/device/aie_trace/aie_trace_logger.h
123+++ b/src/runtime_src/xdp/profile/device/aie_trace/aie_trace_logger.h
124@@ -18,6 +18,7 @@
125 #define XDP_PROFILE_AIE_TRACE_LOGGER_H
126
127 #include<iostream>
128+#include<cstdint>
129
130 namespace xdp {
131
132diff --git a/src/runtime_src/xdp/profile/writer/vp_base/vp_writer.h b/src/runtime_src/xdp/profile/writer/vp_base/vp_writer.h
133index a88597464..f392ec0e6 100644
134--- a/src/runtime_src/xdp/profile/writer/vp_base/vp_writer.h
135+++ b/src/runtime_src/xdp/profile/writer/vp_base/vp_writer.h
136@@ -19,6 +19,7 @@
137
138 #include <fstream>
139 #include <string>
140+#include <cstdint>
141
142 #include "xdp/config.h"
143
144--
1452.34.1
146
diff --git a/meta-xilinx-core/recipes-xrt/xrt/xrt_202210.2.13.479.bb b/meta-xilinx-core/recipes-xrt/xrt/xrt_202210.2.13.479.bb
deleted file mode 100644
index 49cfa228..00000000
--- a/meta-xilinx-core/recipes-xrt/xrt/xrt_202210.2.13.479.bb
+++ /dev/null
@@ -1,53 +0,0 @@
1SUMMARY = "Xilinx Runtime(XRT) libraries"
2DESCRIPTION = "Xilinx Runtime User Space Libraries and headers"
3
4require xrt-${PV}.inc
5
6SRC_URI += "file://xrt-cstdint.patch;striplevel=2"
7
8LICENSE = "GPL-2.0-or-later & Apache-2.0"
9LIC_FILES_CHKSUM = "file://../LICENSE;md5=da5408f748bce8a9851dac18e66f4bcf \
10 file://runtime_src/core/edge/drm/zocl/LICENSE;md5=7d040f51aae6ac6208de74e88a3795f8 \
11 file://runtime_src/core/pcie/driver/linux/xocl/LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
12 file://runtime_src/core/pcie/linux/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
13 file://runtime_src/core/pcie/tools/xbutil/LICENSE;md5=d273d63619c9aeaf15cdaf76422c4f87 \
14 file://runtime_src/core/edge/tools/xbutil/LICENSE;md5=d273d63619c9aeaf15cdaf76422c4f87 "
15
16S = "${UNPACKDIR}/git/src"
17
18inherit cmake pkgconfig
19
20BBCLASSEXTEND = "native nativesdk"
21
22# util-linux is for libuuid-dev.
23DEPENDS = "libdrm opencl-headers ocl-icd opencl-clhpp boost util-linux git-replacement-native protobuf-native protobuf elfutils libffi rapidjson"
24RDEPENDS:${PN} = "bash ocl-icd boost-system boost-filesystem zocl (= ${PV})"
25
26EXTRA_OECMAKE += " \
27 -DCMAKE_BUILD_TYPE=Release \
28 -DCMAKE_EXPORT_COMPILE_COMANDS=ON \
29 "
30# Systems with AIE also require libmetal, this is implemented in the dynamic-layers
31# See: meta-xilinx-core/dynamic-layers/openamp-layer/recipes-xrt/xrt_gt.bbappend
32# Note: If meta-openamp is not available, AIE will not be enabled.
33
34EXTRA_OECMAKE:append:aarch64 = " -DXRT_LIBDFX=true"
35DEPENDS:append:aarch64 = " libdfx"
36
37FILES_SOLIBSDEV = ""
38FILES:${PN} += "\
39 ${libdir}/lib*.so \
40 ${libdir}/lib*.so.* \
41 ${libdir}/ps_kernels_lib \
42 /lib/*.so* "
43INSANE_SKIP:${PN} += "dev-so"
44
45pkg_postinst_ontarget:${PN}() {
46 #!/bin/sh
47 if [ ! -e /etc/OpenCL/vendors/xilinx.icd ]; then
48 echo "INFO: Creating ICD entry for Xilinx Platform"
49 mkdir -p /etc/OpenCL/vendors
50 echo "libxilinxopencl.so" > /etc/OpenCL/vendors/xilinx.icd
51 chmod -R 755 /etc/OpenCL
52 fi
53}
diff --git a/meta-xilinx-core/recipes-xrt/xrt/xrt_202220.2.14.0.bb b/meta-xilinx-core/recipes-xrt/xrt/xrt_202220.2.14.0.bb
deleted file mode 100644
index f686a746..00000000
--- a/meta-xilinx-core/recipes-xrt/xrt/xrt_202220.2.14.0.bb
+++ /dev/null
@@ -1,53 +0,0 @@
1SUMMARY = "Xilinx Runtime(XRT) libraries"
2DESCRIPTION = "Xilinx Runtime User Space Libraries and headers"
3
4require xrt-${PV}.inc
5
6SRC_URI += "file://xrt-cstdint.patch;striplevel=2"
7
8LICENSE = "GPL-2.0-or-later & Apache-2.0"
9LIC_FILES_CHKSUM = "file://../LICENSE;md5=da5408f748bce8a9851dac18e66f4bcf \
10 file://runtime_src/core/edge/drm/zocl/LICENSE;md5=7d040f51aae6ac6208de74e88a3795f8 \
11 file://runtime_src/core/pcie/driver/linux/xocl/LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
12 file://runtime_src/core/pcie/linux/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
13 file://runtime_src/core/tools/xbutil2/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 "
14
15S = "${UNPACKDIR}/git/src"
16
17inherit cmake pkgconfig
18
19BBCLASSEXTEND = "native nativesdk"
20
21# util-linux is for libuuid-dev.
22DEPENDS = "libdrm opencl-headers ocl-icd opencl-clhpp boost util-linux git-replacement-native protobuf-native protobuf elfutils libffi rapidjson"
23RDEPENDS:${PN} = "bash ocl-icd boost-system boost-filesystem zocl (= ${PV})"
24
25EXTRA_OECMAKE += " \
26 -DCMAKE_BUILD_TYPE=Release \
27 -DCMAKE_EXPORT_COMPILE_COMANDS=ON \
28 "
29# Systems with AIE also require libmetal, this is implemented in the dynamic-layers
30# See: meta-xilinx-core/dynamic-layers/openamp-layer/recipes-xrt/xrt_gt.bbappend
31# Note: If meta-openamp is not available, AIE will not be enabled.
32
33EXTRA_OECMAKE:append:aarch64 = " -DXRT_LIBDFX=true"
34DEPENDS:append:aarch64 = " libdfx"
35
36FILES_SOLIBSDEV = ""
37FILES:${PN} += "\
38 ${libdir}/lib*.so \
39 ${libdir}/lib*.so.* \
40 ${libdir}/ps_kernels_lib \
41 /lib/*.so* \
42 ${datadir}"
43INSANE_SKIP:${PN} += "dev-so"
44
45pkg_postinst_ontarget:${PN}() {
46 #!/bin/sh
47 if [ ! -e /etc/OpenCL/vendors/xilinx.icd ]; then
48 echo "INFO: Creating ICD entry for Xilinx Platform"
49 mkdir -p /etc/OpenCL/vendors
50 echo "libxilinxopencl.so" > /etc/OpenCL/vendors/xilinx.icd
51 chmod -R 755 /etc/OpenCL
52 fi
53}
diff --git a/meta-xilinx-core/recipes-xrt/zocl/zocl_202210.2.13.479.bb b/meta-xilinx-core/recipes-xrt/zocl/zocl_202210.2.13.479.bb
deleted file mode 100644
index 464b96fd..00000000
--- a/meta-xilinx-core/recipes-xrt/zocl/zocl_202210.2.13.479.bb
+++ /dev/null
@@ -1,24 +0,0 @@
1SUMMARY = "Xilinx Runtime(XRT) driver module"
2DESCRIPTION = "Xilinx Runtime driver module provides memory management and compute unit schedule"
3
4
5require recipes-xrt/xrt/xrt-${PV}.inc
6
7LIC_FILES_CHKSUM = "file://LICENSE;md5=7d040f51aae6ac6208de74e88a3795f8"
8LICENSE = "GPLv2 & Apache-2.0"
9
10# Temporary fix
11# Patch is applied as -p 4 to the src/runtime_src/core/edge directory
12SRC_URI += "file://0001-Fixed-ZOCL-dtbo-path-len-issue-6966.patch;striplevel=5;patchdir=./../../"
13
14S = "${UNPACKDIR}/git/src/runtime_src/core/edge/drm/zocl"
15
16inherit module
17
18pkg_postinst_ontarget:${PN}() {
19 #!/bin/sh
20 echo "Unloading old XRT Linux kernel modules"
21 ( rmmod zocl || true ) > /dev/null 2>&1
22 echo "Loading new XRT Linux kernel modules"
23 modprobe zocl
24}
diff --git a/meta-xilinx-core/recipes-xrt/zocl/zocl_202220.2.14.0.bb b/meta-xilinx-core/recipes-xrt/zocl/zocl_202220.2.14.0.bb
deleted file mode 100644
index 7643b42a..00000000
--- a/meta-xilinx-core/recipes-xrt/zocl/zocl_202220.2.14.0.bb
+++ /dev/null
@@ -1,21 +0,0 @@
1SUMMARY = "Xilinx Runtime(XRT) driver module"
2DESCRIPTION = "Xilinx Runtime driver module provides memory management and compute unit schedule"
3
4COMPATIBLE_MACHINE:microblaze = "none"
5
6require recipes-xrt/xrt/xrt-${PV}.inc
7
8LIC_FILES_CHKSUM = "file://LICENSE;md5=7d040f51aae6ac6208de74e88a3795f8"
9LICENSE = "GPL-2.0-or-later & Apache-2.0"
10
11S = "${UNPACKDIR}/git/src/runtime_src/core/edge/drm/zocl"
12
13inherit module
14
15pkg_postinst_ontarget:${PN}() {
16 #!/bin/sh
17 echo "Unloading old XRT Linux kernel modules"
18 ( rmmod zocl || true ) > /dev/null 2>&1
19 echo "Loading new XRT Linux kernel modules"
20 modprobe zocl
21}