diff options
author | Mark Hatle <mark.hatle@amd.com> | 2024-04-18 13:25:13 -0600 |
---|---|---|
committer | Mark Hatle <mark.hatle@amd.com> | 2024-04-19 10:03:07 -0600 |
commit | bc42ff18ab35854b7d92c5f1ae2dda8b311fa6f5 (patch) | |
tree | 30d29521dd6dba4e715fcb92033e882a5aa0c893 /meta-xilinx-core/recipes-xrt/xrt | |
parent | c1c1476d27e663feb24701e53342861cce6ab573 (diff) | |
download | meta-xilinx-bc42ff18ab35854b7d92c5f1ae2dda8b311fa6f5.tar.gz |
xrt: Fix older versions for Scarthgap
Add in necessary libmetal dependency (dynamic)
Patch the sources using the xrt-cstdint.patch where applicable.
Signed-off-by: Mark Hatle <mark.hatle@amd.com>
Diffstat (limited to 'meta-xilinx-core/recipes-xrt/xrt')
-rw-r--r-- | meta-xilinx-core/recipes-xrt/xrt/xrt-202310.2.15.0/xrt-cstdint.patch | 117 | ||||
-rw-r--r-- | meta-xilinx-core/recipes-xrt/xrt/xrt_202310.2.15.0.bb | 2 |
2 files changed, 119 insertions, 0 deletions
diff --git a/meta-xilinx-core/recipes-xrt/xrt/xrt-202310.2.15.0/xrt-cstdint.patch b/meta-xilinx-core/recipes-xrt/xrt/xrt-202310.2.15.0/xrt-cstdint.patch new file mode 100644 index 00000000..67ca68c6 --- /dev/null +++ b/meta-xilinx-core/recipes-xrt/xrt/xrt-202310.2.15.0/xrt-cstdint.patch | |||
@@ -0,0 +1,117 @@ | |||
1 | Add cstdint as necessary | ||
2 | |||
3 | In GCC 13.1 usage of uint64 and similar will result in an error without | ||
4 | #include <cstdint> | ||
5 | |||
6 | Signed-off-by: Mark Hatle <mark.hatle@amd.com> | ||
7 | |||
8 | diff --git a/src/runtime_src/core/common/time.h b/src/runtime_src/core/common/time.h | ||
9 | index a4a96b11d..585d38756 100644 | ||
10 | --- a/src/runtime_src/core/common/time.h | ||
11 | +++ b/src/runtime_src/core/common/time.h | ||
12 | @@ -19,6 +19,7 @@ | ||
13 | |||
14 | #include "core/common/config.h" | ||
15 | #include <string> | ||
16 | +#include <cstdint> | ||
17 | |||
18 | namespace xrt_core { | ||
19 | |||
20 | diff --git a/src/runtime_src/core/edge/user/aie/common_layer/adf_api_config.h b/src/runtime_src/core/edge/user/aie/common_layer/adf_api_config.h | ||
21 | index 196304765..36ce35e80 | ||
22 | --- a/src/runtime_src/core/edge/user/aie/common_layer/adf_api_config.h | ||
23 | +++ b/src/runtime_src/core/edge/user/aie/common_layer/adf_api_config.h | ||
24 | @@ -18,6 +18,7 @@ | ||
25 | |||
26 | #include <string> | ||
27 | #include <vector> | ||
28 | +#include <cstdint> | ||
29 | |||
30 | namespace adf | ||
31 | { | ||
32 | diff --git a/src/runtime_src/core/edge/user/zynq_dev.h b/src/runtime_src/core/edge/user/zynq_dev.h | ||
33 | index 6fe36c615..2abd7473b 100644 | ||
34 | --- a/src/runtime_src/core/edge/user/zynq_dev.h | ||
35 | +++ b/src/runtime_src/core/edge/user/zynq_dev.h | ||
36 | @@ -19,6 +19,7 @@ | ||
37 | #include <fstream> | ||
38 | #include <string> | ||
39 | #include <vector> | ||
40 | +#include <cstdint> | ||
41 | |||
42 | class zynq_device { | ||
43 | public: | ||
44 | diff --git a/src/runtime_src/tools/xclbinutil/CBOR.h b/src/runtime_src/tools/xclbinutil/CBOR.h | ||
45 | index 368459f59..acbf6ebae 100644 | ||
46 | --- a/src/runtime_src/tools/xclbinutil/CBOR.h | ||
47 | +++ b/src/runtime_src/tools/xclbinutil/CBOR.h | ||
48 | @@ -22,6 +22,7 @@ | ||
49 | // #includes here - please keep these to a bare minimum! | ||
50 | #include <string> | ||
51 | #include <sstream> | ||
52 | +#include <cstdint> | ||
53 | |||
54 | // ------------ F O R W A R D - D E C L A R A T I O N S ---------------------- | ||
55 | // Forward declarations - use these instead whenever possible... | ||
56 | diff --git a/src/runtime_src/tools/xclbinutil/DTCStringsBlock.h b/src/runtime_src/tools/xclbinutil/DTCStringsBlock.h | ||
57 | index 361015962..1c3bca18d 100644 | ||
58 | --- a/src/runtime_src/tools/xclbinutil/DTCStringsBlock.h | ||
59 | +++ b/src/runtime_src/tools/xclbinutil/DTCStringsBlock.h | ||
60 | @@ -19,6 +19,7 @@ | ||
61 | |||
62 | // ----------------------- I N C L U D E S ----------------------------------- | ||
63 | #include <sstream> | ||
64 | +#include <cstdint> | ||
65 | #include <string> | ||
66 | |||
67 | // ----------- C L A S S : D T C S t r i n g s B l o c k ------------------- | ||
68 | diff --git a/src/runtime_src/tools/xclbinutil/XclBinSignature.h b/src/runtime_src/tools/xclbinutil/XclBinSignature.h | ||
69 | index b19ab56a4..f1b72d4d2 100644 | ||
70 | --- a/src/runtime_src/tools/xclbinutil/XclBinSignature.h | ||
71 | +++ b/src/runtime_src/tools/xclbinutil/XclBinSignature.h | ||
72 | @@ -18,6 +18,7 @@ | ||
73 | #define __XclBinSignature_h_ | ||
74 | |||
75 | #include <string> | ||
76 | +#include <cstdint> | ||
77 | |||
78 | // ----------------------- I N C L U D E S ----------------------------------- | ||
79 | |||
80 | diff --git a/src/runtime_src/xdp/profile/database/events/vtf_event.h b/src/runtime_src/xdp/profile/database/events/vtf_event.h | ||
81 | index f8d0121db..b5f36554c 100644 | ||
82 | --- a/src/runtime_src/xdp/profile/database/events/vtf_event.h | ||
83 | +++ b/src/runtime_src/xdp/profile/database/events/vtf_event.h | ||
84 | @@ -19,6 +19,7 @@ | ||
85 | #define VTF_EVENT_DOT_H | ||
86 | |||
87 | #include <fstream> | ||
88 | +#include <cstdint> | ||
89 | |||
90 | #include "xdp/config.h" | ||
91 | |||
92 | diff --git a/src/runtime_src/xdp/profile/device/aie_trace/aie_trace_logger.h b/src/runtime_src/xdp/profile/device/aie_trace/aie_trace_logger.h | ||
93 | index 98c57de2e..6077bd247 100644 | ||
94 | --- a/src/runtime_src/xdp/profile/device/aie_trace/aie_trace_logger.h | ||
95 | +++ b/src/runtime_src/xdp/profile/device/aie_trace/aie_trace_logger.h | ||
96 | @@ -17,7 +17,8 @@ | ||
97 | #ifndef XDP_PROFILE_AIE_TRACE_LOGGER_H | ||
98 | #define XDP_PROFILE_AIE_TRACE_LOGGER_H | ||
99 | |||
100 | -#include<iostream> | ||
101 | +#include <iostream> | ||
102 | +#include <cstdint> | ||
103 | |||
104 | namespace xdp { | ||
105 | |||
106 | diff --git a/src/runtime_src/xdp/profile/writer/vp_base/vp_writer.h b/src/runtime_src/xdp/profile/writer/vp_base/vp_writer.h | ||
107 | index a88597464..f392ec0e6 100644 | ||
108 | --- a/src/runtime_src/xdp/profile/writer/vp_base/vp_writer.h | ||
109 | +++ b/src/runtime_src/xdp/profile/writer/vp_base/vp_writer.h | ||
110 | @@ -19,6 +19,7 @@ | ||
111 | |||
112 | #include <fstream> | ||
113 | #include <string> | ||
114 | +#include <cstdint> | ||
115 | |||
116 | #include "xdp/config.h" | ||
117 | |||
diff --git a/meta-xilinx-core/recipes-xrt/xrt/xrt_202310.2.15.0.bb b/meta-xilinx-core/recipes-xrt/xrt/xrt_202310.2.15.0.bb index 7bb0d05a..cad8ccee 100644 --- a/meta-xilinx-core/recipes-xrt/xrt/xrt_202310.2.15.0.bb +++ b/meta-xilinx-core/recipes-xrt/xrt/xrt_202310.2.15.0.bb | |||
@@ -3,6 +3,8 @@ DESCRIPTION = "Xilinx Runtime User Space Libraries and headers" | |||
3 | 3 | ||
4 | require xrt-${PV}.inc | 4 | require xrt-${PV}.inc |
5 | 5 | ||
6 | SRC_URI += "file://xrt-cstdint.patch;striplevel=2" | ||
7 | |||
6 | LICENSE = "GPL-2.0-or-later & Apache-2.0" | 8 | LICENSE = "GPL-2.0-or-later & Apache-2.0" |
7 | LIC_FILES_CHKSUM = "file://../LICENSE;md5=da5408f748bce8a9851dac18e66f4bcf \ | 9 | LIC_FILES_CHKSUM = "file://../LICENSE;md5=da5408f748bce8a9851dac18e66f4bcf \ |
8 | file://runtime_src/core/edge/drm/zocl/LICENSE;md5=7d040f51aae6ac6208de74e88a3795f8 \ | 10 | file://runtime_src/core/edge/drm/zocl/LICENSE;md5=7d040f51aae6ac6208de74e88a3795f8 \ |