summaryrefslogtreecommitdiffstats
path: root/meta-xilinx-core/recipes-multimedia/vcu
diff options
context:
space:
mode:
authorSandeep Gundlupet Raju <sandeep.gundlupet-raju@xilinx.com>2022-03-01 16:38:11 -0700
committerMark Hatle <mark.hatle@xilinx.com>2022-03-02 17:28:09 -0800
commit71ca272cf8c96ddd6a7182729a225adf19f933c0 (patch)
tree924b40af9a09bda8e057ce83cc58e8dff87ec793 /meta-xilinx-core/recipes-multimedia/vcu
parent55e47ae13bdfc94e95ec0d7edb01d3df4cd09e90 (diff)
downloadmeta-xilinx-71ca272cf8c96ddd6a7182729a225adf19f933c0.tar.gz
kernel-module-vcu: Add vcu rules to video group
Adding vcu rules file changing permissions and ownership group to video so that any new user added to video groups can run allegro vcu encoder and decoder devices. Signed-off-by: Sandeep Gundlupet Raju <sandeep.gundlupet-raju@xilinx.com> Signed-off-by: Mark Hatle <mark.hatle@xilinx.com>
Diffstat (limited to 'meta-xilinx-core/recipes-multimedia/vcu')
-rw-r--r--meta-xilinx-core/recipes-multimedia/vcu/files/99-vcu-enc-dec.rules7
-rw-r--r--meta-xilinx-core/recipes-multimedia/vcu/kernel-module-vcu.bb14
2 files changed, 20 insertions, 1 deletions
diff --git a/meta-xilinx-core/recipes-multimedia/vcu/files/99-vcu-enc-dec.rules b/meta-xilinx-core/recipes-multimedia/vcu/files/99-vcu-enc-dec.rules
new file mode 100644
index 00000000..4643ad37
--- /dev/null
+++ b/meta-xilinx-core/recipes-multimedia/vcu/files/99-vcu-enc-dec.rules
@@ -0,0 +1,7 @@
1# Allegro VCU Encode, Decoder module drivers
2SUBSYSTEM=="allegro_encode_class", KERNEL=="allegroIP", MODE="0660", GROUP="video"
3SUBSYSTEM=="allegro_decode_class", KERNEL=="allegroDecodeIP", MODE="0660", GROUP="video"
4
5# Xilinx Video DMA driver
6SUBSYSTEM=="char", KERNEL=="dmaproxy", MODE="0660", GROUP="video"
7
diff --git a/meta-xilinx-core/recipes-multimedia/vcu/kernel-module-vcu.bb b/meta-xilinx-core/recipes-multimedia/vcu/kernel-module-vcu.bb
index 816b7517..505b54db 100644
--- a/meta-xilinx-core/recipes-multimedia/vcu/kernel-module-vcu.bb
+++ b/meta-xilinx-core/recipes-multimedia/vcu/kernel-module-vcu.bb
@@ -9,12 +9,17 @@ PV = "${XILINX_VCU_VERSION}-xilinx-${XILINX_RELEASE_VERSION}+git${SRCPV}"
9 9
10S = "${WORKDIR}/git" 10S = "${WORKDIR}/git"
11 11
12FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
13
12BRANCH = "master" 14BRANCH = "master"
13REPO = "git://github.com/Xilinx/vcu-modules.git;protocol=https" 15REPO = "git://github.com/Xilinx/vcu-modules.git;protocol=https"
14SRCREV = "9d2657550eccebccce08cacfcdd369367b9f6be4" 16SRCREV = "9d2657550eccebccce08cacfcdd369367b9f6be4"
15 17
16BRANCHARG = "${@['nobranch=1', 'branch=${BRANCH}'][d.getVar('BRANCH', True) != '']}" 18BRANCHARG = "${@['nobranch=1', 'branch=${BRANCH}'][d.getVar('BRANCH', True) != '']}"
17SRC_URI = "${REPO};${BRANCHARG}" 19SRC_URI = " \
20 ${REPO};${BRANCHARG} \
21 file://99-vcu-enc-dec.rules \
22 "
18 23
19inherit module 24inherit module
20 25
@@ -26,3 +31,10 @@ COMPATIBLE_MACHINE = "^$"
26COMPATIBLE_MACHINE:zynqmp = "zynqmp" 31COMPATIBLE_MACHINE:zynqmp = "zynqmp"
27 32
28KERNEL_MODULE_AUTOLOAD += "dmaproxy" 33KERNEL_MODULE_AUTOLOAD += "dmaproxy"
34
35do_install:append() {
36 install -d ${D}${sysconfdir}/udev/rules.d
37 install -m 0644 ${WORKDIR}/99-vcu-enc-dec.rules ${D}${sysconfdir}/udev/rules.d/
38}
39
40FILES:${PN} = "${sysconfdir}/udev/rules.d/*"