summaryrefslogtreecommitdiffstats
path: root/meta-xilinx-core/recipes-graphics
diff options
context:
space:
mode:
authorQuanyang Wang <quanyang.wang@windriver.com>2022-03-04 12:20:50 +0800
committerMark Hatle <mark.hatle@amd.com>2023-01-25 07:24:20 -0800
commitffe207686dd1036f5fa1306517a57f83c010349a (patch)
tree7ae11c007fce5479ecd260986c7b43e1b149c1cb /meta-xilinx-core/recipes-graphics
parenteeefde3b1e83fd46578fba01ea499edff47920d3 (diff)
downloadmeta-xilinx-ffe207686dd1036f5fa1306517a57f83c010349a.tar.gz
cairo: add trace to PACKAGECONFIG to fix do_package error while enabling multilib
Issue: LINCD-8359 In cairo_1.16.0.bb, the macro MULTILIB_SCRIPTS is set to be "${PN}-perf-utils:${bindir}/cairo-trace" which indicates that the script cairo-trace will be handled using update-alternatives with multilib. But in the bbappend meta-xilinx-bsp/recipes-graphics/cairo/cairo_%.bbappend, the "trace" is removed from PACKAGECONFIG and this will cause that the class multilib_script can't find the cairo-trace script. The error log is as below: ERROR: cairo-1.16.0-r0 do_package: Error executing a python function in exec_python_func() autogenerated: ...... Exception: bb.process.ExecutionError: Execution of 'build/tmp-glibc/work/cortexa53-wrs-linux/cairo/1.16.0-r0/temp/run.multilibscript_rename.22582' failed with exit code 1: mv: cannot stat 'build/tmp-glibc/work/cortexa53-wrs-linux/cairo/1.16.0-r0/package/usr/bin/cairo-trace': No such file or directory WARNING: exit code 1 from a shell command. So add "trace" back to PACKAGECONFIG to fix the do_package error. Signed-off-by: Quanyang Wang <quanyang.wang@windriver.com> Signed-off-by: Mark Hatle <mark.hatle@amd.com>
Diffstat (limited to 'meta-xilinx-core/recipes-graphics')
-rw-r--r--meta-xilinx-core/recipes-graphics/cairo/cairo_%.bbappend1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta-xilinx-core/recipes-graphics/cairo/cairo_%.bbappend b/meta-xilinx-core/recipes-graphics/cairo/cairo_%.bbappend
index c46e8550..4b8d9935 100644
--- a/meta-xilinx-core/recipes-graphics/cairo/cairo_%.bbappend
+++ b/meta-xilinx-core/recipes-graphics/cairo/cairo_%.bbappend
@@ -5,6 +5,7 @@ DEFAULT_PACKAGECONFIG := "${PACKAGECONFIG}"
5PACKAGECONFIG_LIBMALI = " \ 5PACKAGECONFIG_LIBMALI = " \
6 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11 xcb', '', d)} \ 6 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11 xcb', '', d)} \
7 egl glesv2 \ 7 egl glesv2 \
8 trace \
8" 9"
9 10
10PACKAGECONFIG = "${@'${PACKAGECONFIG_LIBMALI}' if d.getVar('PREFERRED_PROVIDER_virtual/libgles1') == 'libmali-xlnx' else '${DEFAULT_PACKAGECONFIG}'}" 11PACKAGECONFIG = "${@'${PACKAGECONFIG_LIBMALI}' if d.getVar('PREFERRED_PROVIDER_virtual/libgles1') == 'libmali-xlnx' else '${DEFAULT_PACKAGECONFIG}'}"