summaryrefslogtreecommitdiffstats
path: root/meta-xilinx-core/recipes-graphics
diff options
context:
space:
mode:
authorChristian Kohn <chris.kohn@amd.com>2022-12-21 16:27:08 -0800
committerMark Hatle <mark.hatle@amd.com>2023-01-06 10:58:21 -0800
commit02695fde93b2df91cb6e4b1d1f7d8368231c8464 (patch)
treebeafeff91b9131d4d517d339a200f794b76722f5 /meta-xilinx-core/recipes-graphics
parentda5a9093faf0779af9a19c06420fcd6af7544523 (diff)
downloadmeta-xilinx-02695fde93b2df91cb6e4b1d1f7d8368231c8464.tar.gz
weston-init: Don't replace weston.ini
Instead of replacing the template weston.ini from the original recipe, augment it as needed: 1. There is a PACKAGECONFIG option to set idle-time=0. Use it. 2. For zynqmp device enablement, set gbm-format=rgb565. This keeps the template weston.ini intact so the user can easily uncomment the desired options while running on the target. Signed-off-by: Christian Kohn <chris.kohn@amd.com> Signed-off-by: Mark Hatle <mark.hatle@amd.com>
Diffstat (limited to 'meta-xilinx-core/recipes-graphics')
-rw-r--r--meta-xilinx-core/recipes-graphics/wayland/files/weston.ini6
-rw-r--r--meta-xilinx-core/recipes-graphics/wayland/weston-init.bbappend6
2 files changed, 2 insertions, 10 deletions
diff --git a/meta-xilinx-core/recipes-graphics/wayland/files/weston.ini b/meta-xilinx-core/recipes-graphics/wayland/files/weston.ini
deleted file mode 100644
index 2ff81795..00000000
--- a/meta-xilinx-core/recipes-graphics/wayland/files/weston.ini
+++ /dev/null
@@ -1,6 +0,0 @@
1[core]
2idle-time=0
3
4gbm-format=rgb565
5
6require-input=false
diff --git a/meta-xilinx-core/recipes-graphics/wayland/weston-init.bbappend b/meta-xilinx-core/recipes-graphics/wayland/weston-init.bbappend
index 3b2b17fd..f0d64e27 100644
--- a/meta-xilinx-core/recipes-graphics/wayland/weston-init.bbappend
+++ b/meta-xilinx-core/recipes-graphics/wayland/weston-init.bbappend
@@ -1,7 +1,5 @@
1FILESEXTRAPATHS:prepend:zynqmp := "${THISDIR}/files:" 1PACKAGECONFIG += "no-idle-timeout"
2
3SRC_URI:append:zynqmp = " file://weston.ini"
4 2
5do_install:append:zynqmp() { 3do_install:append:zynqmp() {
6 install -D -p -m0644 ${WORKDIR}/weston.ini ${D}/${sysconfdir}/xdg/weston/weston.ini 4 sed -i -e "/^\[core\]/a gbm-format=rgb565" ${D}${sysconfdir}/xdg/weston/weston.ini
7} 5}