summaryrefslogtreecommitdiffstats
path: root/meta-xilinx-core/recipes-devtools
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@amd.com>2023-08-20 09:37:34 -0600
committerMark Hatle <mark.hatle@amd.com>2023-08-24 16:04:25 -0600
commitdc7b83b753e2213bd15d35432e5d2e95578ee980 (patch)
treedf2a940c92657968db8823e43cf14433cdf3eb6d /meta-xilinx-core/recipes-devtools
parent06e1a7ec3fd41b33f7243f03b8b2018f484c5c46 (diff)
downloadmeta-xilinx-dc7b83b753e2213bd15d35432e5d2e95578ee980.tar.gz
qemu-xilinx-system-native: Rework pmu-rom dependency
The previous implementation did not follow the recommended usage of bb.utils.contains. Additionally we need to exclude the LICENSE_FLAGS_ACCEPTED variable, otherwise unrelated items will affect our recipe hash. This can cause problems with an eSDK where a user may enable or disable unrelated commercial or other licensed software. Signed-off-by: Mark Hatle <mark.hatle@amd.com>
Diffstat (limited to 'meta-xilinx-core/recipes-devtools')
-rw-r--r--meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-system-native_%.bbappend7
1 files changed, 5 insertions, 2 deletions
diff --git a/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-system-native_%.bbappend b/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-system-native_%.bbappend
index 91b223b9..7c152d60 100644
--- a/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-system-native_%.bbappend
+++ b/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-system-native_%.bbappend
@@ -1,2 +1,5 @@
1# Automatically enable pmu-rom-native for ZynqMP support, or warn the user 1# Automatically enable pmu-rom-native for ZynqMP support
2DEPENDS .= "${@' pmu-rom-native' if 'xilinx' in (d.getVar('LICENSE_FLAGS_ACCEPTED') or '').split() else ''}" 2PMU_ROM_DEP[vardepsexclude] = "LICENSE_FLAGS_ACCEPTED"
3PMU_ROM_DEP = "${@bb.utils.contains("LICENSE_FLAGS_ACCEPTED", "xilinx", " pmu-rom-native", "", d)}"
4
5DEPENDS .= "${PMU_ROM_DEP}"