summaryrefslogtreecommitdiffstats
path: root/meta-xilinx-core/recipes-devtools
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@amd.com>2022-09-12 17:07:09 -0700
committerMark Hatle <mark.hatle@amd.com>2022-09-12 17:07:09 -0700
commitc350c58a84391ed52a370010b2edf9853d67cf64 (patch)
treef35e9b47989646085c613627691124f609212065 /meta-xilinx-core/recipes-devtools
parent359451278d48e4c3149bd026b978d29e77a25592 (diff)
downloadmeta-xilinx-c350c58a84391ed52a370010b2edf9853d67cf64.tar.gz
qemu-*: Use recipe version in the extended PV
Signed-off-by: Mark Hatle <mark.hatle@amd.com>
Diffstat (limited to 'meta-xilinx-core/recipes-devtools')
-rw-r--r--meta-xilinx-core/recipes-devtools/qemu/qemu-devicetrees.inc2
-rw-r--r--meta-xilinx-core/recipes-devtools/qemu/qemu-devicetrees/0001-Makefile-Use-python3-instead-of-python.patch37
-rw-r--r--meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx.inc2
3 files changed, 39 insertions, 2 deletions
diff --git a/meta-xilinx-core/recipes-devtools/qemu/qemu-devicetrees.inc b/meta-xilinx-core/recipes-devtools/qemu/qemu-devicetrees.inc
index 9ee8174a..3be623ac 100644
--- a/meta-xilinx-core/recipes-devtools/qemu/qemu-devicetrees.inc
+++ b/meta-xilinx-core/recipes-devtools/qemu/qemu-devicetrees.inc
@@ -7,7 +7,7 @@ inherit deploy
7 7
8LIC_FILES_CHKSUM = "file://Makefile;beginline=1;endline=27;md5=7348b6cbcae69912cb1dee68d6c68d99" 8LIC_FILES_CHKSUM = "file://Makefile;beginline=1;endline=27;md5=7348b6cbcae69912cb1dee68d6c68d99"
9 9
10PV = "xilinx-${XILINX_RELEASE_VERSION}+git${SRCPV}" 10PV = "xilinx-v${@bb.parse.vars_from_file(d.getVar('FILE', False),d)[1] or ''}+git${SRCPV}"
11 11
12REPO ?= "git://github.com/Xilinx/qemu-devicetrees.git;protocol=https" 12REPO ?= "git://github.com/Xilinx/qemu-devicetrees.git;protocol=https"
13 13
diff --git a/meta-xilinx-core/recipes-devtools/qemu/qemu-devicetrees/0001-Makefile-Use-python3-instead-of-python.patch b/meta-xilinx-core/recipes-devtools/qemu/qemu-devicetrees/0001-Makefile-Use-python3-instead-of-python.patch
new file mode 100644
index 00000000..425145d0
--- /dev/null
+++ b/meta-xilinx-core/recipes-devtools/qemu/qemu-devicetrees/0001-Makefile-Use-python3-instead-of-python.patch
@@ -0,0 +1,37 @@
1From e80324e3497e5768c9fdbde3c0660a03d0dcc3ee Mon Sep 17 00:00:00 2001
2From: Sai Hari Chandana Kalluri <chandana.kalluri@xilinx.com>
3Date: Mon, 8 Feb 2021 16:32:34 -0800
4Subject: [PATCH] Makefile:Use python3 instead of python
5
6Signed-off-by: Sai Hari Chandana Kalluri <chandana.kalluri@xilinx.com>
7---
8 Makefile | 12 ++++++------
9 1 file changed, 6 insertions(+), 6 deletions(-)
10
11diff --git a/Makefile b/Makefile
12index a110483..fd8868c 100644
13--- a/Makefile
14+++ b/Makefile
15@@ -91,13 +91,13 @@ $(LQSPI_XIP_OUTDIR)/%.dts: %.dts $(DTSI_FILES) $(HEADER_FILES)
16 # TODO: Add support for auto-generated dependency list
17 versal-pmc-npi.dtsi: versal-pmc-npi-nxx.dtsi versal-h10-pmc-npi-nxx.dtsi
18 versal-pmc-npi-nxx.dtsi: Makefile
19- @python -c 'for a in range(0, 54): print("\tGEN_NMU(" + str(a) + ")")' > $@
20- @python -c 'for a in range(0, 50): print("\tGEN_NSU(" + str(a) + ")")' >> $@
21- @python -c 'for a in range(0, 146): print("\tGEN_NPS(" + str(a) + ")")' >> $@
22+ @python3 -c 'for a in range(0, 54): print("\tGEN_NMU(" + str(a) + ")")' > $@
23+ @python3 -c 'for a in range(0, 50): print("\tGEN_NSU(" + str(a) + ")")' >> $@
24+ @python3 -c 'for a in range(0, 146): print("\tGEN_NPS(" + str(a) + ")")' >> $@
25 versal-h10-pmc-npi-nxx.dtsi: Makefile
26- @python -c 'for a in range(0, 37): print("\tGEN_NMU(" + str(a) + ")")' > $@
27- @python -c 'for a in range(0, 33): print("\tGEN_NSU(" + str(a) + ")")' >> $@
28- @python -c 'for a in range(0, 135): print("\tGEN_NPS(" + str(a) + ")")' >> $@
29+ @python3 -c 'for a in range(0, 37): print("\tGEN_NMU(" + str(a) + ")")' > $@
30+ @python3 -c 'for a in range(0, 33): print("\tGEN_NSU(" + str(a) + ")")' >> $@
31+ @python3 -c 'for a in range(0, 135): print("\tGEN_NPS(" + str(a) + ")")' >> $@
32
33 clean:
34 $(RM) versal-pmc-npi-nxx.dtsi
35--
362.7.4
37
diff --git a/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx.inc b/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx.inc
index 555f18f9..a5557959 100644
--- a/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx.inc
+++ b/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx.inc
@@ -16,7 +16,7 @@ SRCREV = "fbcb55665e9f5f91110ba2a44f62be9bc72752ee"
16 16
17FILESEXTRAPATHS:prepend := "${THISDIR}/files:" 17FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
18 18
19PV = "${XILINX_QEMU_VERSION}-xilinx-${XILINX_RELEASE_VERSION}+git${SRCPV}" 19PV = "${XILINX_QEMU_VERSION}-xilinx-v${@bb.parse.vars_from_file(d.getVar('FILE', False),d)[1] or ''}+git${SRCPV}"
20REPO ?= "gitsm://github.com/Xilinx/qemu.git;protocol=https" 20REPO ?= "gitsm://github.com/Xilinx/qemu.git;protocol=https"
21 21
22BRANCHARG = "${@['nobranch=1', 'branch=${BRANCH}'][d.getVar('BRANCH', True) != '']}" 22BRANCHARG = "${@['nobranch=1', 'branch=${BRANCH}'][d.getVar('BRANCH', True) != '']}"