summaryrefslogtreecommitdiffstats
path: root/meta-xilinx-core/recipes-devtools
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@amd.com>2023-08-16 13:56:51 -0600
committerMark Hatle <mark.hatle@amd.com>2023-08-24 16:04:25 -0600
commit42b2b9ea8f6203c8117bcc7f3f70024e65c5e55e (patch)
tree570796376884e34cac4a63e70e534d972875412e /meta-xilinx-core/recipes-devtools
parent52e51056ac0e7b705f9e8ae6b2ccb9fa2f3f7520 (diff)
downloadmeta-xilinx-42b2b9ea8f6203c8117bcc7f3f70024e65c5e55e.tar.gz
Various: Update mali support to ignore recipe hash changes
MALI_PACKAGE_ARCH depends MACHINE_ARCH depends on MACHINE We can ignore MACHINE_ARCH, as only the resulting value matters, otherwise the package now depends on MACHINE PACKAGE_ARCH can ignore MALI_PACKAGE_ARCH, again only the resulting value of PACKAGE_ARCH matters. Otherwise the value of MALI_PACKAGE_ARCH will be used in the hash, even if the condition is not true. Signed-off-by: Mark Hatle <mark.hatle@amd.com>
Diffstat (limited to 'meta-xilinx-core/recipes-devtools')
-rw-r--r--meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx_2022.1.bb2
-rw-r--r--meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx_2023.1.bb2
-rw-r--r--meta-xilinx-core/recipes-devtools/qemu/qemu_%.bbappend2
3 files changed, 6 insertions, 0 deletions
diff --git a/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx_2022.1.bb b/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx_2022.1.bb
index 04b0efe4..1622a919 100644
--- a/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx_2022.1.bb
+++ b/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx_2022.1.bb
@@ -5,7 +5,9 @@ require qemu-alt.inc
5 5
6# Links to libmali-xlnx, so it becomes MACHINE_ARCH specific 6# Links to libmali-xlnx, so it becomes MACHINE_ARCH specific
7DEFAULT_PACKAGE_ARCH := "${PACKAGE_ARCH}" 7DEFAULT_PACKAGE_ARCH := "${PACKAGE_ARCH}"
8MALI_PACKAGE_ARCH[vardepsexclude] = "MACHINE_ARCH"
8MALI_PACKAGE_ARCH = "${@'${MACHINE_ARCH}' if d.getVar('PREFERRED_PROVIDER_virtual/libgles1') == 'libmali-xlnx' else '${DEFAULT_PACKAGE_ARCH}'}" 9MALI_PACKAGE_ARCH = "${@'${MACHINE_ARCH}' if d.getVar('PREFERRED_PROVIDER_virtual/libgles1') == 'libmali-xlnx' else '${DEFAULT_PACKAGE_ARCH}'}"
10PACKAGE_ARCH[vardepsexclude] = "MALI_PACKAGE_ARCH"
9PACKAGE_ARCH:class-target = "${@bb.utils.contains_any('DEPENDS', 'libepoxy virglrenderer', '${MALI_PACKAGE_ARCH}', '${DEFAULT_PACKAGE_ARCH}', d)}" 11PACKAGE_ARCH:class-target = "${@bb.utils.contains_any('DEPENDS', 'libepoxy virglrenderer', '${MALI_PACKAGE_ARCH}', '${DEFAULT_PACKAGE_ARCH}', d)}"
10 12
11BBCLASSEXTEND = "nativesdk" 13BBCLASSEXTEND = "nativesdk"
diff --git a/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx_2023.1.bb b/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx_2023.1.bb
index 6c1851ba..3b12d161 100644
--- a/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx_2023.1.bb
+++ b/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx_2023.1.bb
@@ -5,7 +5,9 @@ require qemu-alt.inc
5 5
6# Links to libmali-xlnx, so it becomes MACHINE_ARCH specific 6# Links to libmali-xlnx, so it becomes MACHINE_ARCH specific
7DEFAULT_PACKAGE_ARCH := "${PACKAGE_ARCH}" 7DEFAULT_PACKAGE_ARCH := "${PACKAGE_ARCH}"
8MALI_PACKAGE_ARCH[vardepsexclude] = "MACHINE_ARCH"
8MALI_PACKAGE_ARCH = "${@'${MACHINE_ARCH}' if d.getVar('PREFERRED_PROVIDER_virtual/libgles1') == 'libmali-xlnx' else '${DEFAULT_PACKAGE_ARCH}'}" 9MALI_PACKAGE_ARCH = "${@'${MACHINE_ARCH}' if d.getVar('PREFERRED_PROVIDER_virtual/libgles1') == 'libmali-xlnx' else '${DEFAULT_PACKAGE_ARCH}'}"
10PACKAGE_ARCH[vardepsexclude] = "MALI_PACKAGE_ARCH"
9PACKAGE_ARCH:class-target = "${@bb.utils.contains_any('DEPENDS', 'libepoxy virglrenderer', '${MALI_PACKAGE_ARCH}', '${DEFAULT_PACKAGE_ARCH}', d)}" 11PACKAGE_ARCH:class-target = "${@bb.utils.contains_any('DEPENDS', 'libepoxy virglrenderer', '${MALI_PACKAGE_ARCH}', '${DEFAULT_PACKAGE_ARCH}', d)}"
10 12
11BBCLASSEXTEND = "nativesdk" 13BBCLASSEXTEND = "nativesdk"
diff --git a/meta-xilinx-core/recipes-devtools/qemu/qemu_%.bbappend b/meta-xilinx-core/recipes-devtools/qemu/qemu_%.bbappend
index 83768622..04c89b83 100644
--- a/meta-xilinx-core/recipes-devtools/qemu/qemu_%.bbappend
+++ b/meta-xilinx-core/recipes-devtools/qemu/qemu_%.bbappend
@@ -2,5 +2,7 @@ require qemu-alt.inc
2 2
3# Links to libmali-xlnx, so it becomes MACHINE_ARCH specific 3# Links to libmali-xlnx, so it becomes MACHINE_ARCH specific
4DEFAULT_PACKAGE_ARCH := "${PACKAGE_ARCH}" 4DEFAULT_PACKAGE_ARCH := "${PACKAGE_ARCH}"
5MALI_PACKAGE_ARCH[vardepsexclude] = "MACHINE_ARCH"
5MALI_PACKAGE_ARCH = "${@'${MACHINE_ARCH}' if d.getVar('PREFERRED_PROVIDER_virtual/libgles1') == 'libmali-xlnx' else '${DEFAULT_PACKAGE_ARCH}'}" 6MALI_PACKAGE_ARCH = "${@'${MACHINE_ARCH}' if d.getVar('PREFERRED_PROVIDER_virtual/libgles1') == 'libmali-xlnx' else '${DEFAULT_PACKAGE_ARCH}'}"
7PACKAGE_ARCH[vardepsexclude] = "MALI_PACKAGE_ARCH"
6PACKAGE_ARCH:class-target = "${@bb.utils.contains_any('DEPENDS', 'libepoxy virglrenderer', '${MALI_PACKAGE_ARCH}', '${DEFAULT_PACKAGE_ARCH}', d)}" 8PACKAGE_ARCH:class-target = "${@bb.utils.contains_any('DEPENDS', 'libepoxy virglrenderer', '${MALI_PACKAGE_ARCH}', '${DEFAULT_PACKAGE_ARCH}', d)}"