summaryrefslogtreecommitdiffstats
path: root/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-system-native_2022.2.bb
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@amd.com>2022-09-01 17:06:58 -0700
committerMark Hatle <mark.hatle@amd.com>2022-09-01 17:07:30 -0700
commit91f9854aec7329863297258beabb7ae3b69a985c (patch)
tree16e3d05e72b36100531e7b84e449af44ce669994 /meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-system-native_2022.2.bb
parentb6b4360c410fe4f8b8c29d00324a59e0456c06c4 (diff)
parent188fe2561b7dc8563f15fb06a75a8fe1bf8840cd (diff)
downloadmeta-xilinx-91f9854aec7329863297258beabb7ae3b69a985c.tar.gz
Merge remote-tracking branch 'origin/rel-v2022.2' into honister
Diffstat (limited to 'meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-system-native_2022.2.bb')
-rw-r--r--meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-system-native_2022.2.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-system-native_2022.2.bb b/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-system-native_2022.2.bb
new file mode 100644
index 00000000..f177872a
--- /dev/null
+++ b/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-system-native_2022.2.bb
@@ -0,0 +1,20 @@
1require qemu-xilinx-native.inc
2
3PROVIDES = "qemu-system-native"
4
5EXTRA_OECONF:append = " --target-list=${@get_qemu_system_target_list(d)}"
6
7PACKAGECONFIG ??= "fdt alsa kvm pie"
8
9PACKAGECONFIG:remove = "${@'kvm' if not os.path.exists('/usr/include/linux/kvm.h') else ''}"
10
11DEPENDS += "pixman-native qemu-xilinx-native bison-native ninja-native meson-native"
12
13do_install:append() {
14 # The following is also installed by qemu-native
15 rm -f ${D}${datadir}/qemu/trace-events-all
16 rm -rf ${D}${datadir}/qemu/keymaps
17 rm -rf ${D}${datadir}/icons
18 rm -rf ${D}${includedir}/qemu-plugin.h
19}
20