summaryrefslogtreecommitdiffstats
path: root/meta-xilinx-core/recipes-bsp/libdfx
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@amd.com>2023-03-07 07:31:23 -0800
committerMark Hatle <mark.hatle@amd.com>2023-03-08 07:31:02 -0800
commit7c0f00df2c4d364635c57f2ed7c9b3a67d76ef1c (patch)
treeef4c5872bfcaaee306a0c50c1134b7b4377f61c1 /meta-xilinx-core/recipes-bsp/libdfx
parentd707343791423fad74ce0a3478829e6674d8c9a3 (diff)
downloadmeta-xilinx-7c0f00df2c4d364635c57f2ed7c9b3a67d76ef1c.tar.gz
Start 2023.2 development
Signed-off-by: Mark Hatle <mark.hatle@amd.com>
Diffstat (limited to 'meta-xilinx-core/recipes-bsp/libdfx')
-rw-r--r--meta-xilinx-core/recipes-bsp/libdfx/libdfx_2023.2.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-xilinx-core/recipes-bsp/libdfx/libdfx_2023.2.bb b/meta-xilinx-core/recipes-bsp/libdfx/libdfx_2023.2.bb
new file mode 100644
index 00000000..11ad0268
--- /dev/null
+++ b/meta-xilinx-core/recipes-bsp/libdfx/libdfx_2023.2.bb
@@ -0,0 +1,23 @@
1SUMMARY = "Xilinx libdfx library"
2DESCRIPTION = "Xilinx libdfx Library and headers"
3
4LICENSE = "MIT & GPL-2.0-or-later"
5LIC_FILES_CHKSUM = "file://LICENSE.md;md5=94aba86aec117f003b958a52f019f1a7"
6
7BRANCH ?= "master"
8REPO ?= "git://github.com/Xilinx/libdfx.git;protocol=https"
9BRANCHARG = "${@['nobranch=1', 'branch=${BRANCH}'][d.getVar('BRANCH', True) != '']}"
10SRC_URI = "${REPO};${BRANCHARG}"
11SRCREV = "52c1d83c72a2b2e85d256411a199ed1baed12ae1"
12
13COMPATIBLE_MACHINE = "^$"
14COMPATIBLE_MACHINE:zynqmp = "zynqmp"
15COMPATIBLE_MACHINE:versal = "versal"
16
17S = "${WORKDIR}/git"
18
19inherit cmake
20
21# Due to an update where the soname/version was defined, we need to use an RREPLACES
22# so updates will work properly.
23RREPLACES:${PN} = "libdfx"