diff options
author | Mark Hatle <mark.hatle@amd.com> | 2022-11-02 16:26:18 -0500 |
---|---|---|
committer | Mark Hatle <mark.hatle@amd.com> | 2022-11-02 17:25:45 -0700 |
commit | 0dd855e2bb21108d0d2f61ac357e712a23412f88 (patch) | |
tree | 3b21b6f66bda849213cbb4d8b65e96ce57839c56 /meta-xilinx-core/recipes-bsp/dfx-mgr/dfx-mgr_2023.1.bb | |
parent | cc0d2533c1f3e5e5f92b8a5f173027c2bf79a142 (diff) | |
download | meta-xilinx-0dd855e2bb21108d0d2f61ac357e712a23412f88.tar.gz |
dfx-mgr: Add initial 2023.1 branch
Signed-off-by: Mark Hatle <mark.hatle@amd.com>
Diffstat (limited to 'meta-xilinx-core/recipes-bsp/dfx-mgr/dfx-mgr_2023.1.bb')
-rw-r--r-- | meta-xilinx-core/recipes-bsp/dfx-mgr/dfx-mgr_2023.1.bb | 78 |
1 files changed, 78 insertions, 0 deletions
diff --git a/meta-xilinx-core/recipes-bsp/dfx-mgr/dfx-mgr_2023.1.bb b/meta-xilinx-core/recipes-bsp/dfx-mgr/dfx-mgr_2023.1.bb new file mode 100644 index 00000000..7fb3f4dc --- /dev/null +++ b/meta-xilinx-core/recipes-bsp/dfx-mgr/dfx-mgr_2023.1.bb | |||
@@ -0,0 +1,78 @@ | |||
1 | SUMMARY = "Xilinx dfx-mgr libraries" | ||
2 | DESCRIPTION = "Xilinx Runtime User Space Libraries and Binaries" | ||
3 | |||
4 | LICENSE = "MIT" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=d67bcef754e935bf77b6d7051bd62b5e" | ||
6 | |||
7 | REPO ?= "git://github.com/Xilinx/dfx-mgr.git;protocol=https" | ||
8 | BRANCHARG = "${@['nobranch=1', 'branch=${BRANCH}'][d.getVar('BRANCH', True) != '']}" | ||
9 | SRC_URI = "${REPO};${BRANCHARG}" | ||
10 | |||
11 | BRANCH = "master" | ||
12 | SRCREV = "bc06691eb35d7f0acb7c2508b6d050d77b0264a0" | ||
13 | SOMAJOR = "1" | ||
14 | SOMINOR = "0" | ||
15 | SOVERSION = "${SOMAJOR}.${SOMINOR}" | ||
16 | |||
17 | COMPATIBLE_MACHINE = "^$" | ||
18 | COMPATIBLE_MACHINE:zynqmp = "zynqmp" | ||
19 | COMPATIBLE_MACHINE:versal = "versal" | ||
20 | |||
21 | S = "${WORKDIR}/git" | ||
22 | |||
23 | inherit cmake update-rc.d systemd | ||
24 | |||
25 | DEPENDS += " libwebsockets inotify-tools libdfx zocl libdrm" | ||
26 | RDEPENDS:${PN} += " fru-print" | ||
27 | EXTRA_OECMAKE += " \ | ||
28 | -DCMAKE_SYSROOT:PATH=${RECIPE_SYSROOT} \ | ||
29 | " | ||
30 | |||
31 | # Workaround for: the comparison will always evaluate as 'true' for the address of 'defaul_accel_name' will never be NULL [-Werror=address] | ||
32 | CFLAGS += "-Wno-address" | ||
33 | |||
34 | # Workaround for: '__builtin_strncpy' specified bound depends on the length of the source argument [-Werror=stringop-truncation] | ||
35 | CFLAGS += "-Wno-stringop-truncation" | ||
36 | |||
37 | INITSCRIPT_NAME = "dfx-mgr.sh" | ||
38 | INITSCRIPT_PARAMS = "start 99 S ." | ||
39 | |||
40 | SYSTEMD_PACKAGES="${PN}" | ||
41 | SYSTEMD_SERVICE:${PN}="dfx-mgr.service" | ||
42 | SYSTEMD_AUTO_ENABLE:${PN}="enable" | ||
43 | |||
44 | |||
45 | do_install(){ | ||
46 | install -d ${D}${bindir} | ||
47 | install -d ${D}${libdir} | ||
48 | install -d ${D}${includedir} | ||
49 | install -d ${D}${base_libdir}/firmware/xilinx | ||
50 | install -d ${D}${sysconfdir}/dfx-mgrd | ||
51 | |||
52 | cp ${B}/example/sys/linux/dfx-mgrd-static ${D}${bindir}/dfx-mgrd | ||
53 | cp ${B}/example/sys/linux/dfx-mgr-client-static ${D}${bindir}/dfx-mgr-client | ||
54 | chrpath -d ${D}${bindir}/dfx-mgrd | ||
55 | chrpath -d ${D}${bindir}/dfx-mgr-client | ||
56 | install -m 0644 ${S}/src/dfxmgr_client.h ${D}${includedir} | ||
57 | |||
58 | oe_soinstall ${B}/src/libdfx-mgr.so.${SOVERSION} ${D}${libdir} | ||
59 | |||
60 | install -m 0755 ${S}/src/daemon.conf ${D}${sysconfdir}/dfx-mgrd/ | ||
61 | |||
62 | if ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then | ||
63 | install -d ${D}${sysconfdir}/init.d/ | ||
64 | install -m 0755 ${S}/src/dfx-mgr.sh ${D}${sysconfdir}/init.d/ | ||
65 | fi | ||
66 | |||
67 | install -m 0755 ${S}/src/dfx-mgr.sh ${D}${bindir} | ||
68 | install -m 0755 ${S}/src/scripts/xlnx-firmware-detect ${D}${bindir} | ||
69 | |||
70 | install -d ${D}${systemd_system_unitdir} | ||
71 | install -m 0644 ${S}/src/dfx-mgr.service ${D}${systemd_system_unitdir} | ||
72 | } | ||
73 | |||
74 | PACKAGES =+ "libdfx-mgr" | ||
75 | |||
76 | FILES:${PN} += "${base_libdir}/firmware/xilinx" | ||
77 | FILES:${PN} += "${@bb.utils.contains('DISTRO_FEATURES','sysvinit','${sysconfdir}/init.d/dfx-mgr.sh', '', d)} ${systemd_system_unitdir}" | ||
78 | FILES:libdfx-mgr = "${libdir}/libdfx-mgr.so.${SOVERSION} ${libdir}/libdfx-mgr.so.${SOMAJOR}" | ||