summaryrefslogtreecommitdiffstats
path: root/meta-xilinx-core/recipes-bsp/cdo
diff options
context:
space:
mode:
authorCorey Thompson <cthompso@ciena.com>2022-05-02 13:56:52 -0400
committerMark Hatle <mark.hatle@kernel.crashing.org>2022-05-03 11:48:13 -0500
commit4017b1fb18dc59d108e880315c28f10d93058f8c (patch)
tree3fb62cd18836a4d9f7bac1130bdbba5b11543743 /meta-xilinx-core/recipes-bsp/cdo
parent68b28eb679c843ba0334f9b6c551f1253d189c56 (diff)
downloadmeta-xilinx-4017b1fb18dc59d108e880315c28f10d93058f8c.tar.gz
extract-cdo: Avoid directly populating ${DEPLOY_DIR_IMAGE}
This creates problems when images are deployed from sstate cache. Avoid it by extracting the xilinx-bootbin boot.bin file into the extract-cdo build dir ${B}. Then deploy from the output from ${B}. (Original commit submitted by Corey Thompson <ctompso@ciena.com>) Commit adjusted to change extraction directory vs copying the boot.bin. Update the summary to better reflect what this is doing, as well as the do_compile comment. Disable (noexec) the do_install as this isn't a target package. Signed-off-by: Mark Hatle <mark.hatle@kernel.crashing.org>
Diffstat (limited to 'meta-xilinx-core/recipes-bsp/cdo')
-rw-r--r--meta-xilinx-core/recipes-bsp/cdo/extract-cdo_1.0.bb15
1 files changed, 10 insertions, 5 deletions
diff --git a/meta-xilinx-core/recipes-bsp/cdo/extract-cdo_1.0.bb b/meta-xilinx-core/recipes-bsp/cdo/extract-cdo_1.0.bb
index 37c284ad..8b1e52ac 100644
--- a/meta-xilinx-core/recipes-bsp/cdo/extract-cdo_1.0.bb
+++ b/meta-xilinx-core/recipes-bsp/cdo/extract-cdo_1.0.bb
@@ -1,4 +1,4 @@
1DESCRIPTION = "Recipe to copy external cdos" 1DESCRIPTION = "Recipe to extract pmc_cdo for qemu usage"
2 2
3LICENSE = "CLOSED" 3LICENSE = "CLOSED"
4 4
@@ -21,14 +21,19 @@ BOOTGEN_CMD ?= "bootgen"
21BOOTGEN_ARGS ?= "-arch versal" 21BOOTGEN_ARGS ?= "-arch versal"
22BOOTGEN_OUTFILE ?= "${DEPLOY_DIR_IMAGE}/boot.bin" 22BOOTGEN_OUTFILE ?= "${DEPLOY_DIR_IMAGE}/boot.bin"
23 23
24#The following line creates the pmc_cdo.bin file at the same dir as the boot.bin which is DEPLOY_DIR_IMAGE 24# bootgen extracts the pmc_cdo file from the boot.bin. By default this
25# happens in the same directory as the boot.bin. We need to move it to
26# this directory, as do_compile should never write into a deploy dir
25do_compile() { 27do_compile() {
26 ${BOOTGEN_CMD} ${BOOTGEN_ARGS} -dump ${BOOTGEN_OUTFILE} pmc_cdo 28 ${BOOTGEN_CMD} ${BOOTGEN_ARGS} -dump_dir ${B} -dump ${BOOTGEN_OUTFILE} pmc_cdo
27} 29}
28 30
31do_install[noexec] = '1'
32
29do_deploy() { 33do_deploy() {
30 install -d ${DEPLOYDIR}/CDO 34 install -d ${DEPLOYDIR}/CDO
31 install -m 0644 ${DEPLOY_DIR_IMAGE}/pmc_cdo.bin ${DEPLOYDIR}/CDO/pmc_cdo.bin 35 install -m 0644 ${B}/pmc_cdo.bin ${DEPLOYDIR}/CDO/pmc_cdo.bin
36 install -m 0644 ${B}/pmc_cdo.bin ${DEPLOYDIR}/pmc_cdo.bin
32} 37}
33 38
34addtask do_deploy after do_install 39addtask do_deploy after do_compile