summaryrefslogtreecommitdiffstats
path: root/meta-xilinx-core/dynamic-layers
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@amd.com>2023-04-10 09:13:26 -0700
committerMark Hatle <mark.hatle@amd.com>2023-04-11 09:19:31 -0500
commit8b04c8844436cd0d19aa232d7cff20a593346957 (patch)
treec52b8bf1f48cf6da52c320520030a3cbac5bd0a1 /meta-xilinx-core/dynamic-layers
parenta21f1c537b1df82cc6a3f524a2cc3ecbb45fb8b3 (diff)
downloadmeta-xilinx-8b04c8844436cd0d19aa232d7cff20a593346957.tar.gz
xrt: Move aie config libmetal dependency to dynamic layer
Signed-off-by: Mark Hatle <mark.hatle@amd.com>
Diffstat (limited to 'meta-xilinx-core/dynamic-layers')
-rw-r--r--meta-xilinx-core/dynamic-layers/openamp-layer/recipes-xrt/xrt_git.bbappend14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta-xilinx-core/dynamic-layers/openamp-layer/recipes-xrt/xrt_git.bbappend b/meta-xilinx-core/dynamic-layers/openamp-layer/recipes-xrt/xrt_git.bbappend
new file mode 100644
index 00000000..2b96f152
--- /dev/null
+++ b/meta-xilinx-core/dynamic-layers/openamp-layer/recipes-xrt/xrt_git.bbappend
@@ -0,0 +1,14 @@
1# Use libmetal for systems with AIE
2# For vck190 kind of devices
3PACKAGE_ARCH:versal-ai-core = "${SOC_VARIANT_ARCH}"
4EXTRA_OECMAKE:append:versal-ai-core = " -DXRT_AIE_BUILD=true"
5TARGET_CXXFLAGS:append:versal-ai-core = " -DXRT_ENABLE_AIE"
6DEPENDS:append:versal-ai-core = " libmetal libxaiengine aiefal"
7RDEPENDS:${PN}:append:versal-ai-core = " libxaiengine aiefal"
8
9# For vek280 kind of devices
10PACKAGE_ARCH:versal-ai-edge = "${SOC_VARIANT_ARCH}"
11EXTRA_OECMAKE:append:versal-ai-edge = " -DXRT_AIE_BUILD=true"
12TARGET_CXXFLAGS:append:versal-ai-edge = " -DXRT_ENABLE_AIE"
13DEPENDS:append:versal-ai-edge = " libmetal libxaiengine aiefal"
14RDEPENDS:${PN}:append:versal-ai-edge = " libxaiengine aiefal"