summaryrefslogtreecommitdiffstats
path: root/meta-xilinx-bsp
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@xilinx.com>2021-05-07 10:47:51 -0700
committerSai Hari Chandana Kalluri <chandana.kalluri@xilinx.com>2021-07-14 15:01:47 -0700
commit3f755ee3c33702f8ecdff91571c573d974e3122b (patch)
tree3aa3337a6438eb903331b6a86b51db7e984cb61d /meta-xilinx-bsp
parent9143707e95038f11a9695ab4e6094a13e4d78844 (diff)
downloadmeta-xilinx-3f755ee3c33702f8ecdff91571c573d974e3122b.tar.gz
uboot: These recipes are machine or board specific
Issue: CR-1096936 It's possible that the user is NOT using a machine that defines a board, so we need to either use the board(board_variant) or MACHINE outselves. Signed-off-by: Mark Hatle <mark.hatle@xilinx.com>
Diffstat (limited to 'meta-xilinx-bsp')
-rw-r--r--meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-zynq-scr.bb12
-rw-r--r--meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-zynq-uenv.bb4
2 files changed, 14 insertions, 2 deletions
diff --git a/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-zynq-scr.bb b/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-zynq-scr.bb
index bc4eb04a..b121be5e 100644
--- a/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-zynq-scr.bb
+++ b/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-zynq-scr.bb
@@ -46,7 +46,17 @@ SRC_URI = " \
46 file://boot.cmd.ubifs \ 46 file://boot.cmd.ubifs \
47 file://pxeboot.pxe \ 47 file://pxeboot.pxe \
48 " 48 "
49PACKAGE_ARCH = "${MACHINE_ARCH}" 49
50# We fall back to MACHINE_ARCH in most cases
51FALLBACK_ARCH = "${MACHINE_ARCH}"
52
53# Except on zynqmp-dr, where we need to fall back to SOC_VARIANT_ARCH, which
54# falls back to MACHINE_ARCH if necessary
55SOC_VARIANT_ARCH ??= "${MACHINE_ARCH}"
56FALLBACK_ARCH_zynqmp-dr = "${SOC_VARIANT_ARCH}"
57
58BOARDVARIANT_ARCH ??= "${FALLBACK_ARCH}"
59PACKAGE_ARCH = "${BOARDVARIANT_ARCH}"
50 60
51inherit image-artifact-names 61inherit image-artifact-names
52UENV_TEXTFILE ?= "uEnv.txt" 62UENV_TEXTFILE ?= "uEnv.txt"
diff --git a/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-zynq-uenv.bb b/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-zynq-uenv.bb
index 6e4c3c0b..9d3abe77 100644
--- a/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-zynq-uenv.bb
+++ b/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-zynq-uenv.bb
@@ -3,7 +3,9 @@ LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302" 3LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
4 4
5INHIBIT_DEFAULT_DEPS = "1" 5INHIBIT_DEFAULT_DEPS = "1"
6PACKAGE_ARCH = "${MACHINE_ARCH}" 6
7BOARDVARIANT_ARCH ??= "${MACHINE_ARCH}"
8PACKAGE_ARCH = "${BOARDVARIANT_ARCH}"
7 9
8python () { 10python () {
9 # The device trees must be populated in the deploy directory to correctly 11 # The device trees must be populated in the deploy directory to correctly