summaryrefslogtreecommitdiffstats
path: root/meta-xilinx-bsp
diff options
context:
space:
mode:
authorJoerg Hofrichter <joerg.hofrichter@ni.com>2020-01-17 14:48:47 +0100
committerSai Hari Chandana Kalluri <chandana.kalluri@xilinx.com>2020-09-30 11:33:07 -0700
commit2107679d97c2cdab31c5bb8360548a17435d32f4 (patch)
treeefd220fbaeac01bbb61e94add8d5e2abbf81acfc /meta-xilinx-bsp
parenta029d5a075e0ed576a4836de4a6325f470e2d32a (diff)
downloadmeta-xilinx-2107679d97c2cdab31c5bb8360548a17435d32f4.tar.gz
u-boot-zynq-scr.bb: use IMAGE_VERSION_SUFFIX instead of DATETIME
Use variable IMAGE_VERSION_SUFFIX variable instead of DATETIME. Using IMAGE_VERSION_SUFFIX allows easier and more direct changes. The variable is available since Yocto 2.6 and it is used also for other name variables, e.g. IMAGE_NAME. It is set to "-${DATETIME}" per default, so the naming does not change as long as IMAGE_VERSION_SUFFIX is not overridden. For more details, see: https://www.yoctoproject.org/docs/latest/ref-manual/ref-manual.html#migration-2.6-image-kernel-artifact-naming-changes Signed-off-by: Joerg Hofrichter <joerg.hofrichter@ni.com> Signed-off-by: Sai Hari Chandana Kalluri <chandana.kalluri@xilinx.com>
Diffstat (limited to 'meta-xilinx-bsp')
-rw-r--r--meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-zynq-scr.bb6
1 files changed, 2 insertions, 4 deletions
diff --git a/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-zynq-scr.bb b/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-zynq-scr.bb
index 7ce8fc07..45a2e2c8 100644
--- a/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-zynq-scr.bb
+++ b/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-zynq-scr.bb
@@ -34,11 +34,9 @@ SRC_URI = " \
34 " 34 "
35PACKAGE_ARCH = "${MACHINE_ARCH}" 35PACKAGE_ARCH = "${MACHINE_ARCH}"
36 36
37UBOOTSCR_BASE_NAME ?= "${PN}-${PKGE}-${PKGV}-${PKGR}-${DATETIME}" 37UBOOTSCR_BASE_NAME ?= "${PN}-${PKGE}-${PKGV}-${PKGR}${IMAGE_VERSION_SUFFIX}"
38UBOOTSCR_BASE_NAME[vardepsexclude] = "DATETIME"
39UBOOTPXE_CONFIG ?= "pxelinux.cfg" 38UBOOTPXE_CONFIG ?= "pxelinux.cfg"
40UBOOTPXE_CONFIG_NAME = "${UBOOTPXE_CONFIG}-${DATETIME}" 39UBOOTPXE_CONFIG_NAME = "${UBOOTPXE_CONFIG}${IMAGE_VERSION_SUFFIX}"
41UBOOTPXE_CONFIG_NAME[vardepsexclude] = "DATETIME"
42 40
43DEVICETREE_ADDRESS_zynqmp ?= "0x100000" 41DEVICETREE_ADDRESS_zynqmp ?= "0x100000"
44DEVICETREE_ADDRESS_zynq ?= "0x2000000" 42DEVICETREE_ADDRESS_zynq ?= "0x2000000"