diff options
author | Swagath Gadde <swagath.gadde@xilinx.com> | 2019-12-11 15:13:53 +0530 |
---|---|---|
committer | Jaewon Lee <jaewon.lee@xilinx.com> | 2019-12-17 16:36:45 -0800 |
commit | 046f0f9397bee1f5dff200ad18e09ef11ea71989 (patch) | |
tree | 58a19f739dd43bea5e0cddaaae7136d7af8119ad /meta-xilinx-bsp | |
parent | 54b62ac3945aabc39ee3afb03a2e03a9c81964f9 (diff) | |
download | meta-xilinx-046f0f9397bee1f5dff200ad18e09ef11ea71989.tar.gz |
u-boot-zynq-scr:Add initrd label to pxe config
This patch adds the initrd label command to pxe config file
which is required to boot linux in pxeboot with initrd image.
initrd <path> - if this label is chosen, use tftp to retrieve the initrd
at <path>. it will be stored at the address indicated in
the initrd_addr_r environment variable, and that address
will be passed to bootm
Signed-off-by: Swagath Gadde <swagathg@xilinx.com>
Diffstat (limited to 'meta-xilinx-bsp')
-rw-r--r-- | meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-zynq-scr.bb | 1 | ||||
-rw-r--r-- | meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-zynq-scr/pxeboot.pxe | 1 |
2 files changed, 2 insertions, 0 deletions
diff --git a/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-zynq-scr.bb b/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-zynq-scr.bb index 584089ae..14642442 100644 --- a/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-zynq-scr.bb +++ b/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-zynq-scr.bb | |||
@@ -65,6 +65,7 @@ do_compile() { | |||
65 | mkimage -A arm -T script -C none -n "Boot script" -d "${WORKDIR}/boot.cmd" boot.scr | 65 | mkimage -A arm -T script -C none -n "Boot script" -d "${WORKDIR}/boot.cmd" boot.scr |
66 | sed -e 's/@@KERNEL_IMAGETYPE@@/${KERNEL_IMAGETYPE}/' \ | 66 | sed -e 's/@@KERNEL_IMAGETYPE@@/${KERNEL_IMAGETYPE}/' \ |
67 | -e 's/@@DEVICE_TREE_NAME@@/${DEVICE_TREE_NAME}/' \ | 67 | -e 's/@@DEVICE_TREE_NAME@@/${DEVICE_TREE_NAME}/' \ |
68 | -e 's/@@RAMDISK_IMAGE@@/${RAMDISK_IMAGE}/' \ | ||
68 | "${WORKDIR}/pxeboot.pxe" > "pxeboot.pxe" | 69 | "${WORKDIR}/pxeboot.pxe" > "pxeboot.pxe" |
69 | } | 70 | } |
70 | 71 | ||
diff --git a/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-zynq-scr/pxeboot.pxe b/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-zynq-scr/pxeboot.pxe index 6d7a0a94..40796545 100644 --- a/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-zynq-scr/pxeboot.pxe +++ b/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-zynq-scr/pxeboot.pxe | |||
@@ -1,3 +1,4 @@ | |||
1 | LABEL Linux | 1 | LABEL Linux |
2 | KERNEL @@KERNEL_IMAGETYPE@@ | 2 | KERNEL @@KERNEL_IMAGETYPE@@ |
3 | FDT @@DEVICE_TREE_NAME@@ | 3 | FDT @@DEVICE_TREE_NAME@@ |
4 | INITRD @@RAMDISK_IMAGE@@ | ||