summaryrefslogtreecommitdiffstats
path: root/meta-xilinx-bsp/recipes-kernel
diff options
context:
space:
mode:
authorSai Hari Chandana Kalluri <chandana.kalluri@xilinx.com>2021-09-28 22:12:04 -0700
committerSai Hari Chandana Kalluri <chandana.kalluri@xilinx.com>2021-09-28 22:12:06 -0700
commit6921a88182ce51763fcf61273972df99dc2faee5 (patch)
tree6505b60113f6192f347991a3a82b8bc6fb02b8d9 /meta-xilinx-bsp/recipes-kernel
parent1d2c0f073d3102c3f8ff043d2c3039e6d360118f (diff)
downloadmeta-xilinx-6921a88182ce51763fcf61273972df99dc2faee5.tar.gz
Convert to new override syntax
This is the result of automated script (0.9.0) conversion: oe-core/scripts/contrib/convert-overrides.py . converting the metadata to use ":" as the override character instead of "_". Signed-off-by: Sai Hari Chandana Kalluri <chandana.kalluri@xilinx.com>
Diffstat (limited to 'meta-xilinx-bsp/recipes-kernel')
-rwxr-xr-xmeta-xilinx-bsp/recipes-kernel/dp/kernel-module-dp_git.bb4
-rw-r--r--meta-xilinx-bsp/recipes-kernel/dtc/python3-dtc_1.6.0.bb2
-rw-r--r--meta-xilinx-bsp/recipes-kernel/hdmi/kernel-module-hdmi_git.bb4
-rw-r--r--meta-xilinx-bsp/recipes-kernel/linux-firmware/linux-firmware-ti-bt.bb8
-rw-r--r--meta-xilinx-bsp/recipes-kernel/linux/linux-xlnx.inc32
-rw-r--r--meta-xilinx-bsp/recipes-kernel/linux/linux-xlnx_2021.2.bb2
-rw-r--r--meta-xilinx-bsp/recipes-kernel/linux/linux-yocto-xilinx.inc16
-rw-r--r--meta-xilinx-bsp/recipes-kernel/lopper/lopper.bb2
-rw-r--r--meta-xilinx-bsp/recipes-kernel/lopper/xilinx-lops.bb4
-rw-r--r--meta-xilinx-bsp/recipes-kernel/lopper/xilinx-lops/lop-microblaze-yocto.dts6
10 files changed, 40 insertions, 40 deletions
diff --git a/meta-xilinx-bsp/recipes-kernel/dp/kernel-module-dp_git.bb b/meta-xilinx-bsp/recipes-kernel/dp/kernel-module-dp_git.bb
index 42daadf7..3bc136da 100755
--- a/meta-xilinx-bsp/recipes-kernel/dp/kernel-module-dp_git.bb
+++ b/meta-xilinx-bsp/recipes-kernel/dp/kernel-module-dp_git.bb
@@ -20,5 +20,5 @@ inherit module
20 20
21EXTRA_OEMAKE += "O=${STAGING_KERNEL_BUILDDIR}" 21EXTRA_OEMAKE += "O=${STAGING_KERNEL_BUILDDIR}"
22COMPATIBLE_MACHINE = "^$" 22COMPATIBLE_MACHINE = "^$"
23COMPATIBLE_MACHINE_zynqmp = "zynqmp" 23COMPATIBLE_MACHINE:zynqmp = "zynqmp"
24COMPATIBLE_MACHINE_versal = "versal" 24COMPATIBLE_MACHINE:versal = "versal"
diff --git a/meta-xilinx-bsp/recipes-kernel/dtc/python3-dtc_1.6.0.bb b/meta-xilinx-bsp/recipes-kernel/dtc/python3-dtc_1.6.0.bb
index ed2652e3..f57b2b19 100644
--- a/meta-xilinx-bsp/recipes-kernel/dtc/python3-dtc_1.6.0.bb
+++ b/meta-xilinx-bsp/recipes-kernel/dtc/python3-dtc_1.6.0.bb
@@ -19,7 +19,7 @@ DEPENDS += "libyaml dtc"
19 19
20inherit distutils3 20inherit distutils3
21 21
22do_configure_prepend() { 22do_configure:prepend() {
23 (cd ${S}/../ ; make version_gen.h ) 23 (cd ${S}/../ ; make version_gen.h )
24} 24}
25 25
diff --git a/meta-xilinx-bsp/recipes-kernel/hdmi/kernel-module-hdmi_git.bb b/meta-xilinx-bsp/recipes-kernel/hdmi/kernel-module-hdmi_git.bb
index 9c70fe7f..65484fca 100644
--- a/meta-xilinx-bsp/recipes-kernel/hdmi/kernel-module-hdmi_git.bb
+++ b/meta-xilinx-bsp/recipes-kernel/hdmi/kernel-module-hdmi_git.bb
@@ -20,5 +20,5 @@ inherit module
20 20
21EXTRA_OEMAKE += "O=${STAGING_KERNEL_BUILDDIR}" 21EXTRA_OEMAKE += "O=${STAGING_KERNEL_BUILDDIR}"
22COMPATIBLE_MACHINE = "^$" 22COMPATIBLE_MACHINE = "^$"
23COMPATIBLE_MACHINE_zynqmp = "zynqmp" 23COMPATIBLE_MACHINE:zynqmp = "zynqmp"
24COMPATIBLE_MACHINE_versal = "versal" 24COMPATIBLE_MACHINE:versal = "versal"
diff --git a/meta-xilinx-bsp/recipes-kernel/linux-firmware/linux-firmware-ti-bt.bb b/meta-xilinx-bsp/recipes-kernel/linux-firmware/linux-firmware-ti-bt.bb
index c3adcf58..1ad8ae2e 100644
--- a/meta-xilinx-bsp/recipes-kernel/linux-firmware/linux-firmware-ti-bt.bb
+++ b/meta-xilinx-bsp/recipes-kernel/linux-firmware/linux-firmware-ti-bt.bb
@@ -53,13 +53,13 @@ do_install() {
53# 11.8.32 = WL180x, WL183x, WL185x PG2.1 or PG2.2, 8.32 ROM Version 53# 11.8.32 = WL180x, WL183x, WL185x PG2.1 or PG2.2, 8.32 ROM Version
54PACKAGES =+ "${PN}-wl180x ${PN}-license" 54PACKAGES =+ "${PN}-wl180x ${PN}-license"
55 55
56FILES_${PN}-license = "${nonarch_base_libdir}/firmware/License.ti-bt" 56FILES:${PN}-license = "${nonarch_base_libdir}/firmware/License.ti-bt"
57 57
58FILES_${PN}-wl180x = "${nonarch_base_libdir}/firmware/TIInit_11.8.32.bts \ 58FILES:${PN}-wl180x = "${nonarch_base_libdir}/firmware/TIInit_11.8.32.bts \
59 ${nonarch_base_libdir}/firmware/ti-connectivity/TIInit_11.8.32.bts" 59 ${nonarch_base_libdir}/firmware/ti-connectivity/TIInit_11.8.32.bts"
60 60
61RDEPENDS_${PN}-wl180x = "${PN}-license linux-firmware-wl18xx" 61RDEPENDS:${PN}-wl180x = "${PN}-license linux-firmware-wl18xx"
62 62
63LICENSE_${PN}-wl180x = "Firmware-ti-bt" 63LICENSE:${PN}-wl180x = "Firmware-ti-bt"
64 64
65INSANE_SKIP = "arch" 65INSANE_SKIP = "arch"
diff --git a/meta-xilinx-bsp/recipes-kernel/linux/linux-xlnx.inc b/meta-xilinx-bsp/recipes-kernel/linux/linux-xlnx.inc
index b4928fba..49f96865 100644
--- a/meta-xilinx-bsp/recipes-kernel/linux/linux-xlnx.inc
+++ b/meta-xilinx-bsp/recipes-kernel/linux/linux-xlnx.inc
@@ -7,7 +7,7 @@ PV = "${LINUX_VERSION}+git${SRCPV}"
7KBRANCH ?= "xlnx_rebase_v5.10" 7KBRANCH ?= "xlnx_rebase_v5.10"
8SRCBRANCHARG = "${@['nobranch=1', 'branch=${KBRANCH}'][d.getVar('KBRANCH', True) != '']}" 8SRCBRANCHARG = "${@['nobranch=1', 'branch=${KBRANCH}'][d.getVar('KBRANCH', True) != '']}"
9 9
10FILESOVERRIDES_append = ":${XILINX_RELEASE_VERSION}" 10FILESOVERRIDES:append = ":${XILINX_RELEASE_VERSION}"
11KERNELURI ?= "git://github.com/Xilinx/linux-xlnx.git;protocol=https;name=machine" 11KERNELURI ?= "git://github.com/Xilinx/linux-xlnx.git;protocol=https;name=machine"
12YOCTO_META ?= "git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-5.10;destsuffix=yocto-kmeta" 12YOCTO_META ?= "git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-5.10;destsuffix=yocto-kmeta"
13SRC_URI = "${KERNELURI};${SRCBRANCHARG} ${YOCTO_META}" 13SRC_URI = "${KERNELURI};${SRCBRANCHARG} ${YOCTO_META}"
@@ -25,11 +25,11 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
25EXTKERNELSRC = "${@'1' if d.getVar('EXTERNALSRC') else ''}" 25EXTKERNELSRC = "${@'1' if d.getVar('EXTERNALSRC') else ''}"
26 26
27# Force the use of the KBUILD_DEFCONFIG even if some other defconfig was generated in the ${WORKDIR} 27# Force the use of the KBUILD_DEFCONFIG even if some other defconfig was generated in the ${WORKDIR}
28do_kernel_metadata_prepend () { 28do_kernel_metadata:prepend () {
29 [ -n "${KBUILD_DEFCONFIG}" ] && [ -e ${WORKDIR}/defconfig ] && rm ${WORKDIR}/defconfig 29 [ -n "${KBUILD_DEFCONFIG}" ] && [ -e ${WORKDIR}/defconfig ] && rm ${WORKDIR}/defconfig
30} 30}
31 31
32do_configure_prepend () { 32do_configure:prepend () {
33 if [ -n "${KBUILD_DEFCONFIG}" ] && [ -n "${EXTKERNELSRC}" ]; then 33 if [ -n "${KBUILD_DEFCONFIG}" ] && [ -n "${EXTKERNELSRC}" ]; then
34 cp ${S}/arch/${ARCH}/configs/${KBUILD_DEFCONFIG} ${WORKDIR}/defconfig 34 cp ${S}/arch/${ARCH}/configs/${KBUILD_DEFCONFIG} ${WORKDIR}/defconfig
35 fi 35 fi
@@ -39,27 +39,27 @@ inherit kernel-simpleimage
39 39
40# Default to be only compatible with specific machines or soc families 40# Default to be only compatible with specific machines or soc families
41COMPATIBLE_MACHINE ?= "^$" 41COMPATIBLE_MACHINE ?= "^$"
42COMPATIBLE_MACHINE_zynq = ".*" 42COMPATIBLE_MACHINE:zynq = ".*"
43COMPATIBLE_MACHINE_zynqmp = ".*" 43COMPATIBLE_MACHINE:zynqmp = ".*"
44COMPATIBLE_MACHINE_microblaze = ".*" 44COMPATIBLE_MACHINE:microblaze = ".*"
45COMPATIBLE_MACHINE_versal = ".*" 45COMPATIBLE_MACHINE:versal = ".*"
46 46
47# Use DEFCONFIGs for configuring linux-xlnx kernels 47# Use DEFCONFIGs for configuring linux-xlnx kernels
48KCONFIG_MODE ?= "alldefconfig" 48KCONFIG_MODE ?= "alldefconfig"
49KBUILD_DEFCONFIG_zynqmp ?= "xilinx_defconfig" 49KBUILD_DEFCONFIG:zynqmp ?= "xilinx_defconfig"
50KBUILD_DEFCONFIG_zynq ?= "xilinx_zynq_defconfig" 50KBUILD_DEFCONFIG:zynq ?= "xilinx:zynq_defconfig"
51KBUILD_DEFCONFIG_microblaze ?= "mmu_defconfig" 51KBUILD_DEFCONFIG:microblaze ?= "mmu_defconfig"
52KBUILD_DEFCONFIG_versal ?= "xilinx_defconfig" 52KBUILD_DEFCONFIG:versal ?= "xilinx_defconfig"
53 53
54KERNEL_MODULE_AUTOLOAD_k26 += "usb5744" 54KERNEL_MODULE_AUTOLOAD_k26 += "usb5744"
55 55
56# MicroBlaze BSP fragments 56# MicroBlaze BSP fragments
57KERNEL_FEATURES_append_kc705-microblazeel = " bsp/xilinx/kc705-microblazeel-features/kc705-microblazeel-features.scc" 57KERNEL_FEATURES:append_kc705-microblazeel = " bsp/xilinx/kc705-microblazeel-features/kc705-microblazeel-features.scc"
58 58
59KERNEL_FEATURES_append_zynqmp = "${@bb.utils.contains('DISTRO_FEATURES', 'xen', ' features/xen/xen.scc', '', d)}" 59KERNEL_FEATURES:append:zynqmp = "${@bb.utils.contains('DISTRO_FEATURES', 'xen', ' features/xen/xen.scc', '', d)}"
60 60
61KERNEL_FEATURES_append_zynqmp = "${@' features/xilinx/overlay_of/overlay_of.scc' if d.getVar('FPGA_MNGR_RECONFIG_ENABLE') == '1' else ''}" 61KERNEL_FEATURES:append:zynqmp = "${@' features/xilinx/overlay_of/overlay_of.scc' if d.getVar('FPGA_MNGR_RECONFIG_ENABLE') == '1' else ''}"
62 62
63KERNEL_FEATURES_append_versal = "${@bb.utils.contains('DISTRO_FEATURES', 'xen', ' features/xen/xen.scc', '', d)} features/xilinx/hdmi-module/hdmi-module.scc" 63KERNEL_FEATURES:append:versal = "${@bb.utils.contains('DISTRO_FEATURES', 'xen', ' features/xen/xen.scc', '', d)} features/xilinx/hdmi-module/hdmi-module.scc"
64 64
65KERNEL_FEATURES_append = " ${@bb.utils.contains('DISTRO_FEATURES', 'virtualization', ' features/ocicontainer/ocicontainer.scc', '', d)}" 65KERNEL_FEATURES:append = " ${@bb.utils.contains('DISTRO_FEATURES', 'virtualization', ' features/ocicontainer/ocicontainer.scc', '', d)}"
diff --git a/meta-xilinx-bsp/recipes-kernel/linux/linux-xlnx_2021.2.bb b/meta-xilinx-bsp/recipes-kernel/linux/linux-xlnx_2021.2.bb
index 24f7551e..79fde54f 100644
--- a/meta-xilinx-bsp/recipes-kernel/linux/linux-xlnx_2021.2.bb
+++ b/meta-xilinx-bsp/recipes-kernel/linux/linux-xlnx_2021.2.bb
@@ -6,4 +6,4 @@ KCONF_AUDIT_LEVEL="0"
6 6
7include linux-xlnx.inc 7include linux-xlnx.inc
8 8
9FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 9FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
diff --git a/meta-xilinx-bsp/recipes-kernel/linux/linux-yocto-xilinx.inc b/meta-xilinx-bsp/recipes-kernel/linux/linux-yocto-xilinx.inc
index e99785d1..51eab948 100644
--- a/meta-xilinx-bsp/recipes-kernel/linux/linux-yocto-xilinx.inc
+++ b/meta-xilinx-bsp/recipes-kernel/linux/linux-yocto-xilinx.inc
@@ -1,23 +1,23 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/linux-xlnx:" 1FILESEXTRAPATHS:prepend := "${THISDIR}/linux-xlnx:"
2 2
3require linux-microblaze.inc 3require linux-microblaze.inc
4 4
5# Zynq default generic KMACHINE 5# Zynq default generic KMACHINE
6COMPATIBLE_MACHINE_zynq = "zynq" 6COMPATIBLE_MACHINE:zynq = "zynq"
7KMACHINE_zynq = "zynq" 7KMACHINE:zynq = "zynq"
8 8
9# ZynqMP default generic KMACHINE 9# ZynqMP default generic KMACHINE
10COMPATIBLE_MACHINE_zynqmp = "zynqmp" 10COMPATIBLE_MACHINE:zynqmp = "zynqmp"
11KMACHINE_zynqmp = "zynqmp" 11KMACHINE:zynqmp = "zynqmp"
12 12
13# MicroBlaze KMACHINEs 13# MicroBlaze KMACHINEs
14KMACHINE_ml605-qemu-microblazeel = "qemumicroblazeel" 14KMACHINE_ml605-qemu-microblazeel = "qemumicroblazeel"
15KMACHINE_s3adsp1800-qemu-microblazeeb = "qemumicroblazeeb" 15KMACHINE_s3adsp1800-qemu-microblazeeb = "qemumicroblazeeb"
16 16
17# MicroBlaze default generic KMACHINE 17# MicroBlaze default generic KMACHINE
18KMACHINE_microblaze = "microblaze" 18KMACHINE:microblaze = "microblaze"
19COMPATIBLE_MACHINE_microblaze = "microblaze" 19COMPATIBLE_MACHINE:microblaze = "microblaze"
20 20
21# Default kernel config fragements for specific machines 21# Default kernel config fragements for specific machines
22KERNEL_FEATURES_append_kc705-microblazeel = " bsp/xilinx/kc705-microblazeel-features/kc705-microblazeel-features.scc" 22KERNEL_FEATURES:append_kc705-microblazeel = " bsp/xilinx/kc705-microblazeel-features/kc705-microblazeel-features.scc"
23 23
diff --git a/meta-xilinx-bsp/recipes-kernel/lopper/lopper.bb b/meta-xilinx-bsp/recipes-kernel/lopper/lopper.bb
index 8ca7135e..fc8dc755 100644
--- a/meta-xilinx-bsp/recipes-kernel/lopper/lopper.bb
+++ b/meta-xilinx-bsp/recipes-kernel/lopper/lopper.bb
@@ -3,7 +3,7 @@ DESCRIPTION = "Tool to subset a system device tree"
3SECTION = "bootloader" 3SECTION = "bootloader"
4LICENSE = "BSD-3-Clause" 4LICENSE = "BSD-3-Clause"
5 5
6RDEPENDS_${PN} += " \ 6RDEPENDS:${PN} += " \
7 python3-core \ 7 python3-core \
8 dtc \ 8 dtc \
9 python3-dtc \ 9 python3-dtc \
diff --git a/meta-xilinx-bsp/recipes-kernel/lopper/xilinx-lops.bb b/meta-xilinx-bsp/recipes-kernel/lopper/xilinx-lops.bb
index cfa1bc87..77456376 100644
--- a/meta-xilinx-bsp/recipes-kernel/lopper/xilinx-lops.bb
+++ b/meta-xilinx-bsp/recipes-kernel/lopper/xilinx-lops.bb
@@ -3,7 +3,7 @@ DESCRIPTION = "Xilinx specific lop files"
3SECTION = "bootloader" 3SECTION = "bootloader"
4LICENSE = "BSD-3-Clause" 4LICENSE = "BSD-3-Clause"
5 5
6RDEPENDS_${PN} += "lopper" 6RDEPENDS:${PN} += "lopper"
7 7
8SRC_URI = " \ 8SRC_URI = " \
9 file://lop-microblaze-yocto.dts \ 9 file://lop-microblaze-yocto.dts \
@@ -23,5 +23,5 @@ do_install() {
23 cp ${S}/lop-xilinx-id-cpus.dts ${D}/${datadir}/lopper/lops/. 23 cp ${S}/lop-xilinx-id-cpus.dts ${D}/${datadir}/lopper/lops/.
24} 24}
25 25
26FILES_${PN} += "${datadir}/lopper/lops" 26FILES:${PN} += "${datadir}/lopper/lops"
27BBCLASSEXTEND = "native nativesdk" 27BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-xilinx-bsp/recipes-kernel/lopper/xilinx-lops/lop-microblaze-yocto.dts b/meta-xilinx-bsp/recipes-kernel/lopper/xilinx-lops/lop-microblaze-yocto.dts
index d710c10f..72eb4665 100644
--- a/meta-xilinx-bsp/recipes-kernel/lopper/xilinx-lops/lop-microblaze-yocto.dts
+++ b/meta-xilinx-bsp/recipes-kernel/lopper/xilinx-lops/lop-microblaze-yocto.dts
@@ -230,12 +230,12 @@
230 tname = tname[0]+str(cpu_addr) 230 tname = tname[0]+str(cpu_addr)
231 cpu_addr += 1 231 cpu_addr += 1
232 print( 'AVAILTUNES += \"microblaze-%s\"' % tname ) 232 print( 'AVAILTUNES += \"microblaze-%s\"' % tname )
233 print( 'TUNE_FEATURES_tune-microblaze-%s = \"' % tname, end='' ) 233 print( 'TUNE_FEATURES:tune-microblaze-%s = \"' % tname, end='' )
234 for t in n.tunes.values(): 234 for t in n.tunes.values():
235 print( ' %s' % t, end='' ) 235 print( ' %s' % t, end='' )
236 print( '\"' ) 236 print( '\"' )
237 print( 'PACKAGE_EXTRA_ARCHS_tune-microblaze-%s = \"${TUNE_PKGARCH}\"' % tname ) 237 print( 'PACKAGE_EXTRA_ARCHS:tune-microblaze-%s = \"${TUNE_PKGARCH}\"' % tname )
238 print( 'TUNE_FEATURES_tune-%s = \"${TUNE_FEATURES_tune-microblaze-%s}\"\\n' % (n.tune_type,tname) ) 238 print( 'TUNE_FEATURES:tune-%s = \"${TUNE_FEATURES:tune-microblaze-%s}\"\\n' % (n.tune_type,tname) )
239 239
240 "; 240 ";
241 }; 241 };