summaryrefslogtreecommitdiffstats
path: root/meta-xilinx-bsp/recipes-devtools
diff options
context:
space:
mode:
authorManjukumar Matha <manjukumar.harthikote-matha@xilinx.com>2018-04-10 12:38:57 -0700
committerManjukumar Matha <manjukumar.harthikote-matha@xilinx.com>2018-05-25 11:09:21 -0700
commit3c43f26d565c1f7c0936d01d895cb5a2de4e3deb (patch)
tree07bc929906b29ed24f5f11662a87559e3dd7578f /meta-xilinx-bsp/recipes-devtools
parentc1484bbce2c6b32fd77369a8bb1a8f238b10401b (diff)
downloadmeta-xilinx-3c43f26d565c1f7c0936d01d895cb5a2de4e3deb.tar.gz
Update recipes for Xilinx v2018.1 release
Update the arm-trusted-firmware, u-boot-xlnx, linux-xlnx, qemu-xilinx and qemu-devicetrees recipes for 2018.1 release Tested-by: Jaewon Lee <jaewon.lee@xilinx.com> Acked-by: Bhargava Sreekantappa Gayathri <bhargava.sreekantappa-gayathri@xilinx.com> Signed-off-by: Manjukumar Matha <manjukumar.harthikote-matha@xilinx.com>
Diffstat (limited to 'meta-xilinx-bsp/recipes-devtools')
-rw-r--r--meta-xilinx-bsp/recipes-devtools/qemu/files/memfd.patch57
-rw-r--r--meta-xilinx-bsp/recipes-devtools/qemu/qemu-devicetrees_2018.1.bb6
-rw-r--r--meta-xilinx-bsp/recipes-devtools/qemu/qemu-xilinx.inc6
-rw-r--r--meta-xilinx-bsp/recipes-devtools/qemu/qemu-xilinx_2018.1.bb6
4 files changed, 74 insertions, 1 deletions
diff --git a/meta-xilinx-bsp/recipes-devtools/qemu/files/memfd.patch b/meta-xilinx-bsp/recipes-devtools/qemu/files/memfd.patch
new file mode 100644
index 00000000..62e8d380
--- /dev/null
+++ b/meta-xilinx-bsp/recipes-devtools/qemu/files/memfd.patch
@@ -0,0 +1,57 @@
1Upstream-Status: Backport
2Signed-off-by: Ross Burton <ross.burton@intel.com>
3
4From 75e5b70e6b5dcc4f2219992d7cffa462aa406af0 Mon Sep 17 00:00:00 2001
5From: Paolo Bonzini <pbonzini@redhat.com>
6Date: Tue, 28 Nov 2017 11:51:27 +0100
7Subject: [PATCH] memfd: fix configure test
8MIME-Version: 1.0
9Content-Type: text/plain; charset=UTF-8
10Content-Transfer-Encoding: 8bit
11
12Recent glibc added memfd_create in sys/mman.h. This conflicts with
13the definition in util/memfd.c:
14
15 /builddir/build/BUILD/qemu-2.11.0-rc1/util/memfd.c:40:12: error: static declaration of memfd_create follows non-static declaration
16
17Fix the configure test, and remove the sys/memfd.h inclusion since the
18file actually does not exist---it is a typo in the memfd_create(2) man
19page.
20
21Cc: Marc-André Lureau <marcandre.lureau@redhat.com>
22Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
23---
24 configure | 2 +-
25 util/memfd.c | 4 +---
26 2 files changed, 2 insertions(+), 4 deletions(-)
27
28diff --git a/configure b/configure
29index 9c8aa5a98b..99ccc1725a 100755
30--- a/configure
31+++ b/configure
32@@ -3923,7 +3923,7 @@ fi
33 # check if memfd is supported
34 memfd=no
35 cat > $TMPC << EOF
36-#include <sys/memfd.h>
37+#include <sys/mman.h>
38
39 int main(void)
40 {
41diff --git a/util/memfd.c b/util/memfd.c
42index 4571d1aba8..412e94a405 100644
43--- a/util/memfd.c
44+++ b/util/memfd.c
45@@ -31,9 +31,7 @@
46
47 #include "qemu/memfd.h"
48
49-#ifdef CONFIG_MEMFD
50-#include <sys/memfd.h>
51-#elif defined CONFIG_LINUX
52+#if defined CONFIG_LINUX && !defined CONFIG_MEMFD
53 #include <sys/syscall.h>
54 #include <asm/unistd.h>
55
56--
572.11.0
diff --git a/meta-xilinx-bsp/recipes-devtools/qemu/qemu-devicetrees_2018.1.bb b/meta-xilinx-bsp/recipes-devtools/qemu/qemu-devicetrees_2018.1.bb
new file mode 100644
index 00000000..a73b9e57
--- /dev/null
+++ b/meta-xilinx-bsp/recipes-devtools/qemu/qemu-devicetrees_2018.1.bb
@@ -0,0 +1,6 @@
1require qemu-devicetrees.inc
2
3XILINX_RELEASE_VERSION = "v2018.1"
4
5BRANCH ?= "master"
6SRCREV ?= "d5017f8119b6493d8b2fcdfd5caa4e8b16580877"
diff --git a/meta-xilinx-bsp/recipes-devtools/qemu/qemu-xilinx.inc b/meta-xilinx-bsp/recipes-devtools/qemu/qemu-xilinx.inc
index 9b59ecce..b6c5dee5 100644
--- a/meta-xilinx-bsp/recipes-devtools/qemu/qemu-xilinx.inc
+++ b/meta-xilinx-bsp/recipes-devtools/qemu/qemu-xilinx.inc
@@ -10,12 +10,16 @@ LIC_FILES_CHKSUM = " \
10 file://COPYING.LIB;endline=24;md5=c04def7ae38850e7d3ef548588159913 \ 10 file://COPYING.LIB;endline=24;md5=c04def7ae38850e7d3ef548588159913 \
11 " 11 "
12 12
13FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
14
13PV = "${XILINX_QEMU_VERSION}-xilinx-${XILINX_RELEASE_VERSION}+git${SRCPV}" 15PV = "${XILINX_QEMU_VERSION}-xilinx-${XILINX_RELEASE_VERSION}+git${SRCPV}"
14BRANCH ?= "" 16BRANCH ?= ""
15REPO ?= "git://github.com/Xilinx/qemu.git;protocol=https" 17REPO ?= "git://github.com/Xilinx/qemu.git;protocol=https"
16 18
17BRANCHARG = "${@['nobranch=1', 'branch=${BRANCH}'][d.getVar('BRANCH', True) != '']}" 19BRANCHARG = "${@['nobranch=1', 'branch=${BRANCH}'][d.getVar('BRANCH', True) != '']}"
18SRC_URI = "${REPO};${BRANCHARG}" 20SRC_URI = "${REPO};${BRANCHARG} \
21 file://memfd.patch \
22 "
19 23
20S = "${WORKDIR}/git" 24S = "${WORKDIR}/git"
21 25
diff --git a/meta-xilinx-bsp/recipes-devtools/qemu/qemu-xilinx_2018.1.bb b/meta-xilinx-bsp/recipes-devtools/qemu/qemu-xilinx_2018.1.bb
new file mode 100644
index 00000000..1d6697cd
--- /dev/null
+++ b/meta-xilinx-bsp/recipes-devtools/qemu/qemu-xilinx_2018.1.bb
@@ -0,0 +1,6 @@
1require qemu-xilinx.inc
2
3XILINX_RELEASE_VERSION = "v2018.1"
4XILINX_QEMU_VERSION ?= "v2.11.0"
5BRANCH ?= "master"
6SRCREV ?= "1d5516986ea296d91a599ac23252e302a4003914"