summaryrefslogtreecommitdiffstats
path: root/meta-xilinx-bsp/recipes-bsp
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@amd.com>2022-12-07 18:55:01 -0800
committerMark Hatle <mark.hatle@amd.com>2023-04-10 09:03:22 -0700
commitad9315524b93751c0303622f536bfc3801c9a87e (patch)
tree0fbba59c8122b15ade0de4127706786a004c47db /meta-xilinx-bsp/recipes-bsp
parentee903da38d5a5d5580cb87cc05cc09983a602d34 (diff)
downloadmeta-xilinx-ad9315524b93751c0303622f536bfc3801c9a87e.tar.gz
fsbl-firmware: Update integration
Set COMPATIBLE_HOST more loosely to allow for baremetal builds. Update processing to use OBJCOPY and add additional deploy names. Signed-off-by: Mark Hatle <mark.hatle@amd.com>
Diffstat (limited to 'meta-xilinx-bsp/recipes-bsp')
-rw-r--r--meta-xilinx-bsp/recipes-bsp/embeddedsw/fsbl-firmware_%.bbappend12
1 files changed, 8 insertions, 4 deletions
diff --git a/meta-xilinx-bsp/recipes-bsp/embeddedsw/fsbl-firmware_%.bbappend b/meta-xilinx-bsp/recipes-bsp/embeddedsw/fsbl-firmware_%.bbappend
index 509a0dbb..6a23dc47 100644
--- a/meta-xilinx-bsp/recipes-bsp/embeddedsw/fsbl-firmware_%.bbappend
+++ b/meta-xilinx-bsp/recipes-bsp/embeddedsw/fsbl-firmware_%.bbappend
@@ -1,16 +1,20 @@
1# QEMU for the Kria SOM requires a section from the FSBL to be extracted 1# QEMU for the Kria SOM requires a section from the FSBL to be extracted
2 2
3FSBL_DEFAULT_NAME = "executable.elf" 3PMU_CONF_NAME ?= "pmu-conf"
4PMU_CONF_NAME = "pmu-conf.bin" 4PMU_CONF_BASE_NAME ?= "${PMU_CONF_NAME}-${PKGE}-${PKGV}-${PKGR}-${MACHINE}${IMAGE_VERSION_SUFFIX}"
5
6# Required so we can run objcopy in do_compile
7DEPENDS:append:zynqmp = " virtual/${TARGET_PREFIX}binutils"
5 8
6do_compile:append:zynqmp () { 9do_compile:append:zynqmp () {
7 if [ -z "${SYSTEM_DTFILE}" ]; then 10 if [ -z "${SYSTEM_DTFILE}" ]; then
8 aarch64-none-elf-objcopy --dump-section .sys_cfg_data=../${PMU_CONF_NAME} ${FSBL_DEFAULT_NAME} 11 ${OBJCOPY} --dump-section .sys_cfg_data=${B}/${PMU_CONF_NAME}.bin ${B}/${ESW_COMPONENT}
9 fi 12 fi
10} 13}
11 14
12do_deploy:append:zynqmp () { 15do_deploy:append:zynqmp () {
13 if [ -z "${SYSTEM_DTFILE}" ]; then 16 if [ -z "${SYSTEM_DTFILE}" ]; then
14 install -Dm 0644 ${B}/${PMU_CONF_NAME} ${DEPLOYDIR}/${PMU_CONF_NAME} 17 install -Dm 0644 ${B}/${PMU_CONF_NAME}.bin ${DEPLOYDIR}/${PMU_CONF_BASE_NAME}.bin
18 ln -s ${PMU_CONF_BASE_NAME}.bin ${DEPLOYDIR}/${PMU_CONF_NAME}.bin
15 fi 19 fi
16} 20}