summaryrefslogtreecommitdiffstats
path: root/meta-xilinx-bsp/recipes-bsp
diff options
context:
space:
mode:
authorSwagath Gadde <swagath.gadde@amd.com>2022-10-04 16:34:02 +0530
committerMark Hatle <mark.hatle@amd.com>2022-11-10 15:04:42 -0800
commit3182c3c10ffba0d92563bf83d9c583a30be3fabc (patch)
tree924cb581519646031560866f64c011ffe66432f4 /meta-xilinx-bsp/recipes-bsp
parent6cbae9509694a2ed65435f391c5a900e4c1d3908 (diff)
downloadmeta-xilinx-3182c3c10ffba0d92563bf83d9c583a30be3fabc.tar.gz
embeddedsw:add the pmu-conf extraction from fsbl
QEMU for all zynqmp platforms requires pmu-conf from fsbl binary section. Signed-off-by: Swagath Gadde <swagath.gadde@amd.com> Signed-off-by: Shubhangi Mahalle <shubhangi.shrikrushna-mahalle@amd.com> Signed-off-by: Mark Hatle <mark.hatle@amd.com>
Diffstat (limited to 'meta-xilinx-bsp/recipes-bsp')
-rw-r--r--meta-xilinx-bsp/recipes-bsp/embeddedsw/fsbl-firmware_%.bbappend12
1 files changed, 12 insertions, 0 deletions
diff --git a/meta-xilinx-bsp/recipes-bsp/embeddedsw/fsbl-firmware_%.bbappend b/meta-xilinx-bsp/recipes-bsp/embeddedsw/fsbl-firmware_%.bbappend
new file mode 100644
index 00000000..6ed358f2
--- /dev/null
+++ b/meta-xilinx-bsp/recipes-bsp/embeddedsw/fsbl-firmware_%.bbappend
@@ -0,0 +1,12 @@
1# QEMU for the Kria SOM requires a section from the FSBL to be extracted
2
3FSBL_DEFAULT_NAME = "executable.elf"
4PMU_CONF_NAME = "pmu-conf.bin"
5
6do_compile:append:zynqmp () {
7 aarch64-none-elf-objcopy --dump-section .sys_cfg_data=../${PMU_CONF_NAME} ${FSBL_DEFAULT_NAME}
8}
9
10do_deploy:append:zynqmp () {
11 install -Dm 0644 ${B}/${PMU_CONF_NAME} ${DEPLOYDIR}/${PMU_CONF_NAME}
12}