summaryrefslogtreecommitdiffstats
path: root/meta-xilinx-bsp/recipes-bsp
diff options
context:
space:
mode:
authorSandeep Gundlupet Raju <sandeep.gundlupet-raju@amd.com>2022-11-22 18:15:10 -0700
committerMark Hatle <mark.hatle@amd.com>2023-04-07 17:50:36 -0700
commit1c812625789975f16cae2e0aa7e1dd97e22e16d1 (patch)
treecff41d3877b435f36c58e23953b3f155a32f620b /meta-xilinx-bsp/recipes-bsp
parentcfd4ac6fc680d16899a5ccc71146dd95001e2d0f (diff)
downloadmeta-xilinx-1c812625789975f16cae2e0aa7e1dd97e22e16d1.tar.gz
u-boot: Add u-boot configs for kc705 board
Signed-off-by: Sandeep Gundlupet Raju <sandeep.gundlupet-raju@amd.com> Signed-off-by: Mark Hatle <mark.hatle@amd.com>
Diffstat (limited to 'meta-xilinx-bsp/recipes-bsp')
-rw-r--r--meta-xilinx-bsp/recipes-bsp/u-boot/files/kc705-microblazeel.cfg39
-rw-r--r--meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-xlnx_%.bbappend5
2 files changed, 44 insertions, 0 deletions
diff --git a/meta-xilinx-bsp/recipes-bsp/u-boot/files/kc705-microblazeel.cfg b/meta-xilinx-bsp/recipes-bsp/u-boot/files/kc705-microblazeel.cfg
new file mode 100644
index 00000000..8fb38950
--- /dev/null
+++ b/meta-xilinx-bsp/recipes-bsp/u-boot/files/kc705-microblazeel.cfg
@@ -0,0 +1,39 @@
1# SPDX-License-Identifier: MIT
2
3#........................................................................
4# WARNING
5#
6# This file is a u-boot configuration fragment, and not a full u-boot
7# configuration file. The final u-boot configuration is made up of
8# an assembly of processed fragments, each of which is designed to
9# capture a specific part of the final configuration (e.g. platform
10# configuration, feature configuration, and board specific hardware
11# configuration). For more information on u-boot configuration, please
12# refer the product documentation.
13#
14#.......................................................................
15
16#
17# Definitions for KC705 evaluation board
18#
19CONFIG_SYS_FLASH_PROTECTION=y
20CONFIG_SYS_FLASH_USE_BUFFER_WRITE=y
21CONFIG_SYS_FLASH_CFI=y
22CONFIG_FLASH_CFI_DRIVER=y
23CONFIG_CMD_FLASH=y
24CONFIG_CMD_IMLS=y
25CONFIG_MTD_NOR_FLASH=y
26CONFIG_MTD_DEVICE=y
27# CONFIG_CMD_SPI is not set
28# CONFIG_CMD_SF is not set
29# CONFIG_SPI_FLASH is not set
30# CONFIG_SPI_FLASH_BAR is not set
31# CONFIG_DM_SPI_FLASH is not set
32# CONFIG_DM_SPI is not set
33# CONFIG_SPI_FLASH_SPANSION is not set
34# CONFIG_SPI_FLASH_STMICRO is not set
35# CONFIG_SPI_FLASH_WINBOND is not set
36# CONFIG_SPI_FLASH_MACRONIX is not set
37# CONFIG_SPI is not set
38# CONFIG_SPI_FLASH_ISSI is not set
39# CONFIG_XILINX_SPI is not set \ No newline at end of file
diff --git a/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-xlnx_%.bbappend b/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-xlnx_%.bbappend
new file mode 100644
index 00000000..23b1eb50
--- /dev/null
+++ b/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-xlnx_%.bbappend
@@ -0,0 +1,5 @@
1FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
2
3SRC_URI:append:kc705-microblazeel = " \
4 file://kc705-microblazeel.cfg \
5 " \ No newline at end of file