summaryrefslogtreecommitdiffstats
path: root/meta-xilinx-bsp/README.md
diff options
context:
space:
mode:
authorManjukumar Matha <manjukumar.harthikote-matha@xilinx.com>2017-12-06 16:06:35 -0800
committerManjukumar Matha <manjukumar.harthikote-matha@xilinx.com>2017-12-13 16:11:14 -0800
commita18947c20dba2c0c38db8bde1ad4684995df4bbd (patch)
tree917bf2abbe439a6f99ede8cfafb25812dca54a9a /meta-xilinx-bsp/README.md
parent6ddc5873b0ede30e6542f0ab151a6236acc37944 (diff)
downloadmeta-xilinx-a18947c20dba2c0c38db8bde1ad4684995df4bbd.tar.gz
meta-xilinx: Restructuring meta-xilinx to support multiple layers
As discussed previously on mailing list, we are proceeding with layer restructuring. For rocko release we will have the following layers meta-xilinx ->meta-xilinx-bsp (current meta-xilinx) ->meta-xilinx-contrib In the subsequent releases we will add other layers from Xilinx meta-xilinx ->meta-xilinx-bsp (current meta-xilinx) ->meta-petalinux ->meta-xilinx-tools ->meta-xilinx-contrib This will provide one clone to get all the required meta layers from Xilinx for a complete solution, and the users can blacklist any layer which they don't want to use using bblayer.conf. This will enables us to help our vendors/partners to add their reference designs, board definitions etc. Recipe changes : * Move reference design zybo-linux-bd.bb to meta-xilinx-contrib * Move kernel patches realted to zybo-linux-bd-zynq7 board to meta-xilinx-contrib * Update README Signed-off-by: Manjukumar Matha <manjukumar.harthikote-matha@xilinx.com>
Diffstat (limited to 'meta-xilinx-bsp/README.md')
-rw-r--r--meta-xilinx-bsp/README.md86
1 files changed, 86 insertions, 0 deletions
diff --git a/meta-xilinx-bsp/README.md b/meta-xilinx-bsp/README.md
new file mode 100644
index 00000000..7df98cea
--- /dev/null
+++ b/meta-xilinx-bsp/README.md
@@ -0,0 +1,86 @@
1meta-xilinx
2===========
3
4This layer provides support for MicroBlaze, Zynq and ZynqMP.
5
6Additional documentation:
7
8* [Building](README.building.md)
9* [Booting](README.booting.md)
10
11Supported Boards/Machines
12=========================
13
14Boards/Machines supported by this layer:
15
16* MicroBlaze:
17 * [Xilinx ML605 (QEMU)](conf/machine/ml605-qemu-microblazeel.conf) - `ml605-qemu-microblazeel` (QEMU support)
18 * [Xilinx S3A DSP 1800 (QEMU)](conf/machine/s3adsp1800-qemu-microblazeeb.conf) - `s3adsp1800-qemu-microblazeeb` (QEMU support)
19 * [Xilinx KC705](conf/machine/kc705-microblazeel.conf) - `kc705-microblazeel`
20* Zynq:
21 * [Zynq (QEMU)](conf/machine/qemu-zynq7.conf) - `qemu-zynq7` (QEMU Support)
22 * [Xilinx ZC702](conf/machine/zc702-zynq7.conf) - `zc702-zynq7` (with QEMU support)
23 * [Xilinx ZC706](conf/machine/zc706-zynq7.conf) - `zc706-zynq7` (with QEMU support)
24 * [Avnet MicroZed](conf/machine/microzed-zynq7.conf) - `microzed-zynq7`
25 * [Avnet PicoZed](conf/machine/picozed-zynq7.conf) - `picozed-zynq7`
26 * [Avnet/Digilent ZedBoard](conf/machine/zedboard-zynq7.conf) - `zedboard-zynq7`
27 * [Digilent Zybo](conf/machine/zybo-zynq7.conf) - `zybo-zynq7`
28 * [Digilent Zybo Linux BD](conf/machine/zybo-linux-bd-zynq7.conf) - `zybo-linux-bd-zynq7`
29* ZynqMP:
30 * [Xilinx ZCU102](conf/machine/zcu102-zynqmp.conf) - `zcu102-zynqmp` (QEMU support)
31
32Additional information on Xilinx architectures can be found at:
33 http://www.xilinx.com/support/index.htm
34
35For Zybo Linux BD reference design, please see meta-xilinx-contrib layer
36
37Maintainers, Mailing list, Patches
38==================================
39
40Please send any patches, pull requests, comments or questions for this layer to
41the [meta-xilinx mailing list](https://lists.yoctoproject.org/listinfo/meta-xilinx):
42
43 meta-xilinx@lists.yoctoproject.org
44
45Maintainers:
46
47 Nathan Rossi <nathan@nathanrossi.com>
48 Manjukumar Harthikote Matha <manjukumar.harthikote-matha@xilinx.com>
49
50Dependencies
51============
52
53This layer depends on:
54
55 URI: git://git.openembedded.org/bitbake
56
57 URI: git://git.openembedded.org/openembedded-core
58 layers: meta
59
60Recipe Licenses
61===============
62
63Due to licensing restrictions some recipes in this layer rely on closed source
64or restricted content provided by Xilinx. In order to use these recipes you must
65accept or agree to the licensing terms (e.g. EULA, Export Compliance, NDA,
66Redistribution, etc). This layer **does not enforce** any legal requirement, it
67is the **responsibility of the user** the ensure that they are in compliance
68with any licenses or legal requirements for content used.
69
70In order to use recipes that rely on restricted content the `xilinx` license
71flag must be white-listed in the build configuration (e.g. `local.conf`). This
72can be done on a per package basis:
73
74 LICENSE_FLAGS_WHITELIST += "xilinx_pmu-rom"
75
76or generally:
77
78 LICENSE_FLAGS_WHITELIST += "xilinx"
79
80Generally speaking Xilinx content that is provided as a restricted download
81cannot be obtained without a Xilinx account, in order to use this content you
82must first download it with your Xilinx account and place the downloaded content
83in the `downloads/` directory of your build or on a `PREMIRROR`. Attempting to
84fetch the content using bitbake will fail, indicating the URL from which to
85acquire the content.
86